I don't know the device, but it should work if "all ports are switched" really does what it says. You should double check, and find one bridge, with all ethernet ports under tab-"ports" added to that bridge. An IP address can be given to the bridge for management, it has no influence on the payload traffic. If there is a default firewall setup the bridge should be part of the LAN "interface list", to allow and track passing traffic, or the firewall rules should be disabled/removed. Changing firewall (e.g. NAT) or routing will not influence anything in the flow between the interfaces. The traffic never leaves the switches. RouterOS only knows one interface, and that's the bridge. (all other interfaces are slave to the bridge)So I go for option two: Use it with the default bridge setup. I just choose defaults and it says "all ports are switched". Great! :) That sounds exactly like I need. I connect my WAN and my LAN-cable at the datacenter to the switch - and nothing happens. No internet - there appears to be some bridge traffic, but seems like the actual internet port 1 has no traffic. I even reset the switch to factory default, get the message that by default, all ports are switched - and still no luck. I have tried to add the ip to the bridge interface, but no luck. Added NAT-rule for all outgoing traffic from bridge (masqarade) to my ISPs gw (even though it should not be needed if it was a switch): No luck.
CRS switches has different default configuration.If it's like most Mikrotik routers, with the default configuration, port 1 will be configured as the WAN port and everything else connected in a bridge.
So much for what I expected. Never played with a CRS in RouterOS. The only one I have was switched to SwitchOS on day one.CRS switches has different default configuration.If it's like most Mikrotik routers, with the default configuration, port 1 will be configured as the WAN port and everything else connected in a bridge.
All ports bridged, and, if I remember correctly, a static IP assigned to that bridge.
There isn't LAN and WAN. It's just a switch. You have a lot of ports, all of them attached to one bridge. That's the default config.1. Yeah, I was thinking that also. Direct replacement with "dumb" D-link switch (non-configured) works, but as soon as I put the two cables to Mikrotik, it just doesn't work. It seems like default config is some kind of bridge and somehow, it doesn't want to bridge WAN and LAN. The bridge created by default might have some limits or something..
Could it be that I need to delete the default bridge it creates? While it suggest to create a bridge with all interfaces, maybe that is the problem?
Yes.Remove "WAN" from /interface list
"interface=ether1 list=WAN" - - - Change this to LAN.
I was desperate, so I just tried everything - I did change this when I saw that it didn't work out of the box ;) Since I use the same cable now on a dlink-switch now until I get this fixed, it should rule out any cable errors (then I should see same there). I have also tried to put internet on port 2 and 3.. So it must be a config-mistake. I'm going back to data center today to try and plug everything back on. I will also try a reboot, maybe something is stuck. I just try to collect as much info as possible to see what I can try when I'm there again.I prefer to avoid that "internet detect". It changes your configuration. There is absolutely no need for "internet detect".
If the connected ether ports remain disabled with the cable in, something is wrong with the cable or connector. (Did it snap in?).
I'll add it here for ease.Copy the contents of the file and post here as code. Doing this, we can see where Your config stands and stop the guessing game.
# model = CRS354-48G-4S+2Q+
# serial number =
/interface bridge
add admin-mac=08:55:31:BB:13:B5 auto-mac=no comment=defconf name=bridge
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=vpn ranges=192.168.89.2-192.168.89.255
add name=pool1 ranges=10.10.0.60-10.10.10.90
/ip dhcp-server
add address-pool=pool1 disabled=no interface=bridge name=server1
/ppp profile
set *FFFFFFFE local-address=192.168.89.1 remote-address=vpn
/interface bridge port
add bridge=bridge comment=defconf interface=ether1 trusted=yes
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=ether6
add bridge=bridge comment=defconf interface=ether7
add bridge=bridge comment=defconf interface=ether8
add bridge=bridge comment=defconf interface=ether9
add bridge=bridge comment=defconf interface=ether10
add bridge=bridge comment=defconf interface=ether11
add bridge=bridge comment=defconf interface=ether12
add bridge=bridge comment=defconf interface=ether13 trusted=yes
add bridge=bridge comment=defconf interface=ether14
add bridge=bridge comment=defconf interface=ether15
add bridge=bridge comment=defconf interface=ether16
add bridge=bridge comment=defconf interface=ether17
add bridge=bridge comment=defconf interface=ether18
add bridge=bridge comment=defconf interface=ether19
add bridge=bridge comment=defconf interface=ether20
add bridge=bridge comment=defconf interface=ether21
add bridge=bridge comment=defconf interface=ether22
add bridge=bridge comment=defconf interface=ether23
add bridge=bridge comment=defconf interface=ether24
add bridge=bridge comment=defconf interface=ether25
add bridge=bridge comment=defconf interface=ether26
add bridge=bridge comment=defconf interface=ether27
add bridge=bridge comment=defconf interface=ether28
add bridge=bridge comment=defconf interface=ether29
add bridge=bridge comment=defconf interface=ether30
add bridge=bridge comment=defconf interface=ether31
add bridge=bridge comment=defconf interface=ether32
add bridge=bridge comment=defconf interface=ether33
add bridge=bridge comment=defconf interface=ether34
add bridge=bridge comment=defconf interface=ether35
add bridge=bridge comment=defconf interface=ether36
add bridge=bridge comment=defconf interface=ether37
add bridge=bridge comment=defconf interface=ether38
add bridge=bridge comment=defconf interface=ether39
add bridge=bridge comment=defconf interface=ether40
add bridge=bridge comment=defconf interface=ether41
add bridge=bridge comment=defconf interface=ether42
add bridge=bridge comment=defconf interface=ether43
add bridge=bridge comment=defconf interface=ether44
add bridge=bridge comment=defconf interface=ether45
add bridge=bridge comment=defconf interface=ether46
add bridge=bridge comment=defconf interface=ether47
add bridge=bridge comment=defconf interface=ether48
add bridge=bridge comment=defconf interface=ether49
add bridge=bridge comment=defconf interface=qsfpplus1-1
add bridge=bridge comment=defconf interface=qsfpplus1-2
add bridge=bridge comment=defconf interface=qsfpplus1-3
add bridge=bridge comment=defconf interface=qsfpplus1-4
add bridge=bridge comment=defconf interface=qsfpplus2-1
add bridge=bridge comment=defconf interface=qsfpplus2-2
add bridge=bridge comment=defconf interface=qsfpplus2-3
add bridge=bridge comment=defconf interface=qsfpplus2-4
add bridge=bridge comment=defconf interface=sfp-sfpplus1
add bridge=bridge comment=defconf interface=sfp-sfpplus2
add bridge=bridge comment=defconf interface=sfp-sfpplus3
add bridge=bridge comment=defconf interface=sfp-sfpplus4
/interface detect-internet
set detect-interface-list=all internet-interface-list=all lan-interface-list=\
all wan-interface-list=all
/interface l2tp-server server
set enabled=yes use-ipsec=yes
/interface list member
add interface=ether49 list=WAN
add interface=ether1 list=LAN
add interface=ether2 list=LAN
add interface=ether3 list=LAN
add interface=ether4 list=LAN
add interface=ether5 list=LAN
add interface=ether6 list=LAN
add interface=ether7 list=LAN
add interface=ether8 list=LAN
add interface=ether9 list=LAN
add interface=ether10 list=LAN
add interface=ether11 list=LAN
add interface=ether12 list=LAN
add interface=ether13 list=LAN
add interface=ether14 list=LAN
add interface=ether15 list=LAN
add interface=ether16 list=LAN
add interface=ether17 list=LAN
add interface=ether18 list=LAN
add interface=ether19 list=LAN
add interface=ether20 list=LAN
add interface=ether21 list=LAN
add interface=ether22 list=LAN
add interface=ether23 list=LAN
add interface=ether24 list=LAN
add interface=ether25 list=LAN
add interface=ether26 list=LAN
add interface=ether27 list=LAN
add interface=ether28 list=LAN
add interface=ether29 list=LAN
add interface=ether30 list=LAN
add interface=ether31 list=LAN
add interface=ether32 list=LAN
add interface=ether33 list=LAN
add interface=ether34 list=LAN
add interface=ether35 list=LAN
add interface=ether36 list=LAN
add interface=ether37 list=LAN
add interface=ether38 list=LAN
add interface=ether39 list=LAN
add interface=ether40 list=LAN
add interface=ether41 list=LAN
add interface=ether42 list=LAN
add interface=ether43 list=LAN
add interface=ether44 list=LAN
add interface=ether45 list=LAN
add interface=ether46 list=LAN
add interface=ether47 list=LAN
add interface=ether48 list=LAN
add interface=qsfpplus1-1 list=LAN
add interface=qsfpplus1-2 list=LAN
add interface=qsfpplus1-3 list=LAN
add interface=qsfpplus1-4 list=LAN
add interface=qsfpplus2-1 list=LAN
add interface=qsfpplus2-2 list=LAN
add interface=qsfpplus2-3 list=LAN
add interface=qsfpplus2-4 list=LAN
add interface=sfp-sfpplus1 list=LAN
add interface=sfp-sfpplus2 list=LAN
add interface=sfp-sfpplus3 list=LAN
add interface=sfp-sfpplus4 list=LAN
/interface pptp-server server
set enabled=yes
/interface sstp-server server
set default-profile=default-encryption enabled=yes
/ip address
add address=XX/26 comment=defconf interface=bridge network=\
XX
add address=XX/26 interface=bridge network=XX
add address=XX/24 comment=LocalAdmin interface=bridge network=\
XX
/ip cloud
set ddns-enabled=yes
/ip dhcp-server network
add dns-server=8.8.8.8 gateway=XXXX
/ip dns
set servers=XXX,XX
/ip firewall nat
add action=masquerade chain=srcnat out-interface=bridge
add action=masquerade chain=srcnat dst-address=GWIP
/ip route
add gateway=GWIP
/ipv6 address
add address=XXX interface=bridge
/ppp secret
add name=vpn
/system routerboard settings
set boot-os=router-os
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=vpn ranges=192.168.89.2-192.168.89.255
add name=pool1 ranges=10.10.0.60-10.10.10.90
/ip dhcp-server
add address-pool=pool1 disabled=no interface=bridge name=server1
/ppp profile
set *FFFFFFFE local-address=192.168.89.1 remote-address=vpn
/interface detect-internet
set detect-interface-list=all internet-interface-list=all lan-interface-list=\
all wan-interface-list=all
/interface l2tp-server server
set enabled=yes use-ipsec=yes
/interface list member
add interface=ether49 list=WAN
add interface=ether1 list=LAN
add interface=ether2 list=LAN
add interface=ether3 list=LAN
add interface=ether4 list=LAN
add interface=ether5 list=LAN
add interface=ether6 list=LAN
add interface=ether7 list=LAN
add interface=ether8 list=LAN
add interface=ether9 list=LAN
add interface=ether10 list=LAN
add interface=ether11 list=LAN
add interface=ether12 list=LAN
add interface=ether13 list=LAN
add interface=ether14 list=LAN
add interface=ether15 list=LAN
add interface=ether16 list=LAN
add interface=ether17 list=LAN
add interface=ether18 list=LAN
add interface=ether19 list=LAN
add interface=ether20 list=LAN
add interface=ether21 list=LAN
add interface=ether22 list=LAN
add interface=ether23 list=LAN
add interface=ether24 list=LAN
add interface=ether25 list=LAN
add interface=ether26 list=LAN
add interface=ether27 list=LAN
add interface=ether28 list=LAN
add interface=ether29 list=LAN
add interface=ether30 list=LAN
add interface=ether31 list=LAN
add interface=ether32 list=LAN
add interface=ether33 list=LAN
add interface=ether34 list=LAN
add interface=ether35 list=LAN
add interface=ether36 list=LAN
add interface=ether37 list=LAN
add interface=ether38 list=LAN
add interface=ether39 list=LAN
add interface=ether40 list=LAN
add interface=ether41 list=LAN
add interface=ether42 list=LAN
add interface=ether43 list=LAN
add interface=ether44 list=LAN
add interface=ether45 list=LAN
add interface=ether46 list=LAN
add interface=ether47 list=LAN
add interface=ether48 list=LAN
add interface=qsfpplus1-1 list=LAN
add interface=qsfpplus1-2 list=LAN
add interface=qsfpplus1-3 list=LAN
add interface=qsfpplus1-4 list=LAN
add interface=qsfpplus2-1 list=LAN
add interface=qsfpplus2-2 list=LAN
add interface=qsfpplus2-3 list=LAN
add interface=qsfpplus2-4 list=LAN
add interface=sfp-sfpplus1 list=LAN
add interface=sfp-sfpplus2 list=LAN
add interface=sfp-sfpplus3 list=LAN
add interface=sfp-sfpplus4 list=LAN
/interface pptp-server server
set enabled=yes
/interface sstp-server server
set default-profile=default-encryption enabled=yes
/ip dhcp-server network
add dns-server=8.8.8.8 gateway=XXXX
/ip firewall nat
add action=masquerade chain=srcnat out-interface=bridge
add action=masquerade chain=srcnat dst-address=GWIP
/ip route
add gateway=GWIP
/ipv6 address
add address=XXX interface=bridge
/ppp secret
add name=vpn
/interface bridge vlan
add bridge=bridge untagged=ether48 vlan-ids=10 command="Management"
add bridge=bridge untagged=ether1,ether2,ether3,ether4 vlan-ids=20 comment="Servers1"
/interface bridge port
add bridge=bridge interface=ether1 pvid=20 comment="to ISP router"
add bridge=bridge interface=ether2 pvid=20 comment="to some server"
add bridge=bridge interface=ether3 pvid=20
add bridge=bridge interface=ether4 pvid=20
add bridge=bridge interface=ether48 pvid=10 comment="Management"
/interface vlan
add interface=bridge name=vlan10 vlan-id=10
/ip address
add address=192.168.88.1/24 interface=vlan10
You need to tell that to Mikrotik. It is automatically added. I have not use for wireless and have not configured it. The same for the bridge-layout and the other stuff you mentioned.Wireless ???? No need for wireless.Code: Select all/interface wireless security-profiles set [ find default=yes ] supplicant-identity=MikroTik
When I don't have any other switches downwards between this router/switch, I have to add vlan-setting to each servers network card to make it work?For you case, I would simply use a bridge with two VLANs:
10 - Management
20 - Servers1
Since the CRS354 has a very fancy switch chip, you can use the regular bridge fashion. (others need to use the /interface ethernet switch section)
For example:The Ether49 port seems to be directly attached to the CPU, and should not belong to any bridge. Just put an IP-address of choise on that.Code: Select all/interface bridge vlan add bridge=bridge untagged=ether48 vlan-ids=10 command="Management" add bridge=bridge untagged=ether1,ether2,ether3,ether4 vlan-ids=20 comment="Servers1" /interface bridge port add bridge=bridge interface=ether1 pvid=20 comment="to ISP router" add bridge=bridge interface=ether2 pvid=20 comment="to some server" add bridge=bridge interface=ether3 pvid=20 add bridge=bridge interface=ether4 pvid=20 add bridge=bridge interface=ether48 pvid=10 comment="Management" /interface vlan add interface=bridge name=vlan10 vlan-id=10 /ip address add address=192.168.88.1/24 interface=vlan10
Ah, cool :) That would solve a problem I have now, I want a clients server to not see mine. So I just set one client connected to port 10 as VLAN10 for instance, and my to port 20. If I don't set any VLAN on the internet-interface, they will still get into the internet? I was looking around for a way to isolate clients on the switch and I thought horzion-setting was the only thing I could use when having a bridge (and didn't quite understand it). Isolate them to vlan in that way you explain sounds the perfect solution :)No, untagged=ether1,ether2,ether3,ether4 means that those ports will be access ports (no vlan tags) that will work with regular servers and clients. Then pvid=20 will instruct the switch that this ports are member for VLAN20 (as in should be tagged with 20).
Also, you should enable VLAN-filtering on the bridge when done.
The idea was to access the switch both from Internet AND from a local closed non-internet-connected site. Management was actually the only thing that worked (both internet and local) until I found the solution ;)/ip address
add address=XX/26 comment=defconf interface=bridge network=\
XX
add address=XX/26 interface=bridge network=XX
add address=XX/24 comment=LocalAdmin interface=bridge network=\
XX
-> 3 different addresses on the same interface? Two of them with different masks? Why? What was the idea behind this?
Yeah, I know. It was only added during debug, so I could mange it somehow. But never mind, this issue is solved now, the error was setting gw during setup it seems.It is not advisable to make the switch accessible (managable) from the internet!
When you really need that, setup a VPN with proper authentication (e.g. L2TP/IPsec) and allow management only from that VPN.
I have created two VLANs on the bridge: One with port 1,2,10 (pvid 10) and one with 1,2,20 (pvid 20). All untagged. Is it first when I add vlan-filtering that the traffic will be isolated from eachother or should that be it? Port 10 and 20 is two different customers, while port 1/2 is my ISP.No, untagged=ether1,ether2,ether3,ether4 means that those ports will be access ports (no vlan tags) that will work with regular servers and clients. Then pvid=20 will instruct the switch that this ports are member for VLAN20 (as in should be tagged with 20).
Also, you should enable VLAN-filtering on the bridge when done.