routing rip> set redistribute-connected=yes redistribute-static=yes
routing rip interface> add interface=YOURPPPoE_interface receive=v2 send=v2 passive=no
routing rip network> add network=77.42.216.xx/29
I'd be cautious to set redistribute-connected to yes just like that, without filtering on prefixes, you never know how the ISP will handle the incoming advertisement of RFC1918 networks eventually connected at OP's side.To set up RIP:Code: Select allrouting rip> set redistribute-connected=yes ...
dearAfter disabling NAT on PPPoE interface, You need to setup RIP, but still details are missing.
To set up RIP:
You need first to have your public IPs assigned, this is usually done on the own router on empty bridge(s) (loopback device), using dst-nat afterwards to connect internal services to Internet.Code: Select allrouting rip> set redistribute-connected=yes redistribute-static=yes routing rip interface> add interface=YOURPPPoE_interface receive=v2 send=v2 passive=no routing rip network> add network=77.42.216.xx/29
Can you post a /ip print once PPPoE is connected? is 77.42.216.33 the remote IP of the tunnel? (appears as network on IP > Addresses)
Dear,dear
i did that the internet work but without my real ip
each time i connect pppoe it gave me ip like 94.187.61.165 and dns 77.42.128.32 and 77.42.130.32Dear,dear
i did that the internet work but without my real ip
there was a question in both mine and @Pukkita's post and you happily ignored it
The point is that your ISP is a bit cryptic on how exactly he expects you to set your side up, there are several ways how it could be done, and from the data they gave you it is not clear which one they choose on their side and expect you to follow. So we need to know the output of /ip address print and /ip route print when the PPPoE interface is up. Don't forget to replace your public addresses by some alias names but leave private addresses, if any, unchanged.
That's a misunderstanding. The address provided to you using PPPoE (in this run, 94.187.28.154) is used only for the inteconnection, so it can be any address, public or private, except the one(s) assigned to you. So it is not important what it is and that it changes.now i have created pppoe connection and the rip settings as stated above but the problem the real ip i got is not mine and its dynamic and changes every time i connect
Almost correct.the only information they give is disable NAT, enable ripv2 and use loopback
I assume you use the default firewall and in /ip firewall nat, the is a rule saying chain=srcnat action=masquerade out-interface=pppoe-out1 (or maybe out-interface-list=WAN).another question how do i disable NAT on my pppoe connection ?
dear there is my configuration that i didIf I don't know the starting point, I cannot give you a step-by-step guide. Press the [terminal] button in WebFig or Winbox and follow the instructions in my automatic signature.
And tell me how you are going to use your 5 public addresses, i.e. whether you are going to assign them to some other devices connected to the LAN side of your Mikrotik, or to your own PPPoE clients, or all of them will be only used to NAT the private addresses of the devices on the LAN.
Plus if you can, revoke the marking of the post by @rabienz as a solution, it is clearly not a solution of your OP.
dear sir
i have same problem like najifares and my isp is the same one and gave me this email that is not clear at all
now i have created pppoe connection and the rip settings as stated above but the problem the real ip i got is not mine and its dynamic and changes every time i connect
i did ip address print
the remote address is 77.42.129.xx and the local address is 94.187.28.154 while mine are different
the ISP is not willing to help or give information i don't know why.
the only information they give is disable NAT, enable ripv2 and use loopback
is there anything i can do ?
another question how do i disable NAT on my pppoe connection ?
thank you in advance
DearIf I don't know the starting point, I cannot give you a step-by-step guide. Press the [terminal] button in WebFig or Winbox and follow the instructions in my automatic signature.
And tell me how you are going to use your 5 public addresses, i.e. whether you are going to assign them to some other devices connected to the LAN side of your Mikrotik, or to your own PPPoE clients, or all of them will be only used to NAT the private addresses of the devices on the LAN.
Plus if you can, revoke the marking of the post by @rabienz as a solution, it is clearly not a solution of your OP.
dear sir
i have same problem like najifares and my isp is the same one and gave me this email that is not clear at all
now i have created pppoe connection and the rip settings as stated above but the problem the real ip i got is not mine and its dynamic and changes every time i connect
i did ip address print
the remote address is 77.42.129.xx and the local address is 94.187.28.154 while mine are different
the ISP is not willing to help or give information i don't know why.
the only information they give is disable NAT, enable ripv2 and use loopback
is there anything i can do ?
another question how do i disable NAT on my pppoe connection ?
thank you in advance
dear Rabih can you send me your phone number??
thank you
yes dear i configure static ip on my pcBefore I start digging into it:And to speed it up, regardless the answers above, what do the four following command line commands return?
- have you set the public address on the PC manually or did you leave "automatic" there?
- if manually, have you configured any DNS server IPs?
- can you ping the Mikrotik's IP (77.42.216.33) from the PC?
/routing rip print
/routing rip neighbor print
/routing rip interface print
/routing rip network print
/interface bridge
add name=private-ip-lan protocol-mode=none
add name=public-ip-lan protocol-mode=none
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1 name=pppoe-out1 \
password=****** use-peer-dns=yes user=******@ogeronet-2M.com
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/interface bridge port
add bridge=private-ip-lan interface=ether2
add bridge=public-ip-lan interface=ether3
/ip address
add address=192.168.88.1/24 interface=private-ip-lan network=192.168.88.0
add address=77.42.xx.xx/29 interface=public-ip-lan network=77.42.xx.xx
/ip firewall filter
add action=accept chain=input connection-state=established,related
add action=drop chain=input connection-state=invalid
add action=accept chain=input protocol=icmp
add action=accept chain=input comment=\
"permit any access from LAN with public IPs if really sure you need it" \
in-interface=public-ip-lan
add action=accept chain=input comment=\
"permit any access from LAN with private IPs" in-interface=private-ip-lan
# pppoe-out1 not ready
add action=accept chain=input comment="permit incoming RIP packets" dst-port=\
520 in-interface=pppoe-out1 protocol=udp
add action=drop chain=input disabled=yes
add action=fasttrack-connection chain=forward connection-state=\
established,related
add action=accept chain=forward connection-state=\
established,related,untracked
add action=drop chain=forward connection-state=invalid
add action=accept chain=forward in-interface=public-ip-lan
add action=accept chain=forward in-interface=private-ip-lan
add action=drop chain=forward
/ip firewall nat
# pppoe-out1 not ready
add action=masquerade chain=srcnat out-interface=pppoe-out1 src-address=\
192.168.88.0/24
/routing rip interface
add interface=pppoe-out1 receive=v2
/routing rip network
add network=77.42.xx.xx/29
/system routerboard settings
set silent-boot=no
Thank you Sindy/ip firewall filter add chain=forward action=accept dst-address=ip.of.that.server place-before=[find chain=forward in-interface=public-ip-lan]
offloads all the firewalling of that server to the Kerio.
Dear naji can you send your phone number i have the same problemdear there is my configuration that i didIf I don't know the starting point, I cannot give you a step-by-step guide. Press the [terminal] button in WebFig or Winbox and follow the instructions in my automatic signature.
And tell me how you are going to use your 5 public addresses, i.e. whether you are going to assign them to some other devices connected to the LAN side of your Mikrotik, or to your own PPPoE clients, or all of them will be only used to NAT the private addresses of the devices on the LAN.
Plus if you can, revoke the marking of the post by @rabienz as a solution, it is clearly not a solution of your OP.
should it work?
also i need that when i connect a pc to a port of mikrotik i should put real static ip on pc lan to get internet
/interface bridge
add name=EFM protocol-mode=none
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1 name=pppoe-out1 \
password=XXXXXXXXXXXXXX use-peer-dns=yes user=\
L407722@ogeronet-2M.com
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip address
add address=192.168.88.1/24 interface=ether2 network=192.168.88.0
add address=77.42.216.32/29 interface=EFM network=77.42.216.32
/ip firewall nat
# pppoe-out1 not ready
add action=src-nat chain=srcnat out-interface=pppoe-out1 src-address=\
192.168.88.1 to-addresses=77.42.216.32/29
/routing rip interface
add interface=pppoe-out1 receive=v2
add disabled=yes receive=v2
/routing rip network
add network=77.42.216.32/29
add network=192.168.88.0/24
/system identity
set name="EFM Jieh"
/system routerboard settings
set cpu-frequency=850MHz protected-routerboot=disabled
Thank you
Did u solve ur problem? I can help u if u wantDear naji can you send your phone number i have the same problemdear there is my configuration that i didIf I don't know the starting point, I cannot give you a step-by-step guide. Press the [terminal] button in WebFig or Winbox and follow the instructions in my automatic signature.
And tell me how you are going to use your 5 public addresses, i.e. whether you are going to assign them to some other devices connected to the LAN side of your Mikrotik, or to your own PPPoE clients, or all of them will be only used to NAT the private addresses of the devices on the LAN.
Plus if you can, revoke the marking of the post by @rabienz as a solution, it is clearly not a solution of your OP.
should it work?
also i need that when i connect a pc to a port of mikrotik i should put real static ip on pc lan to get internet
/interface bridge
add name=EFM protocol-mode=none
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1 name=pppoe-out1 \
password=XXXXXXXXXXXXXX use-peer-dns=yes user=\
L407722@ogeronet-2M.com
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip address
add address=192.168.88.1/24 interface=ether2 network=192.168.88.0
add address=77.42.216.32/29 interface=EFM network=77.42.216.32
/ip firewall nat
# pppoe-out1 not ready
add action=src-nat chain=srcnat out-interface=pppoe-out1 src-address=\
192.168.88.1 to-addresses=77.42.216.32/29
/routing rip interface
add interface=pppoe-out1 receive=v2
add disabled=yes receive=v2
/routing rip network
add network=77.42.216.32/29
add network=192.168.88.0/24
/system identity
set name="EFM Jieh"
/system routerboard settings
set cpu-frequency=850MHz protected-routerboot=disabled
Thank you
Thanks, very helpfullBy adding an appropriate rule to an appropriate place in your firewall.
Follow the hint in my automatic signature below if you want more specific advice.
What exactly is the "same issue" in your case? This topic was dealing with multiple ones throughout its history - first, how to set up RIP to fulfil ISP's requirements so that they could send traffic for your public IP subnet to you, and later how to set up the firewall so that your Mikrotik would forward requests from the internet to the devices on your LAN. So describe in detail what you want to achieve and how far did you get, and post your actual configuration - see my automatic signature below for anonymization hints.I have also the same issue
The scenario you describe is quite far from the original theme of this topic, and what is worse, there is no way to achieve exactly what you want without tight cooperation with your ISP. If I get you right and the same ISP company provides both the MPLS connection and the two ADSL connections, they may be able to use the ADSL connectivity as a backup route towards your public IP, but it largely depends on their overall network topology and their willingness to do so. If all the conditions above are met, it can be set up in a way that it doesn't require a human intervention but a dynamic routing protocol must be deployed to take care of the switchover.All my needs is to have alternative route if it is possible through ADSL for my public IPs when leased line goes down for the same ISP Without his intervention .since there is route for these Public IPs from ISP side to Leased line IP /30 that configured in our router interface with MPLS modem.
If I don't know the starting point, I cannot give you a step-by-step guide. Press the [terminal] button in WebFig or Winbox and follow the instructions in my automatic signature.
And tell me how you are going to use your 5 public addresses, i.e. whether you are going to assign them to some other devices connected to the LAN side of your Mikrotik, or to your own PPPoE clients, or all of them will be only used to NAT the private addresses of the devices on the LAN.
Plus if you can, revoke the marking of the post by @rabienz as a solution, it is clearly not a solution of your OP.
If we leave aside all the security aspects, all you need is a set of src-nat and dst-nat rules. So for a bi-directional, port-agnostic 1:1 NAT between a public IP address A.A.A.A and a private IP address B.B.B.B, you would useCan you provide a config where all 5 public addresses are to be used to NAT to different private address subnets on LAN
If we leave aside all the security aspects, all you need is a set of src-nat and dst-nat rules. So for a bi-directional, port-agnostic 1:1 NAT between a public IP address A.A.A.A and a private IP address B.B.B.B, you would useCan you provide a config where all 5 public addresses are to be used to NAT to different private address subnets on LAN
/ip firewall nat add chain=dstnat in-interface=pppoe-out1 dst-address=A.A.A.A action=dst-nat to-addresses=B.B.B.B
/ip firewall nat add chain=srcnat out-interface=pppoe-out1 src-address=B.B.B.B action=src-nat to-addresses=A.A.A.A
In the this topic, we consider a case where the traffic from the internet to A.A.A.A arrives to the Mikrotik via an L3 tunnel (PPPoE). In such a setup, there is no need that A.A.A.A was assigned to any interface on the Mikrotik itself.
Depending on your existing /ip firewall filter rules, you may have to explicitly permit the dst-nated traffic to pass from WAN to LAN.
If you don't want a port-agnostic 1:1 NAT but something more fine-grained, use as many dst-nat rules as needed.
I live quite far away from that ISP and only had the situation proxied by @rabienz and @Najifares.Do i have to do the RIP rules?
So you need more selective dst-nat rules, but the basic idea remains the same.I just wanna map different ports on different public ips to some servers on the LAN side
Since the time when the topic has started, I've set up a portable lab on my laptop, so I could now debug the configuration locally.but how do I configure the public IP /29 range I'm assigned if I'm getting a different single ip on pppoe?
I live quite far away from that ISP and only had the situation proxied by @rabienz and @Najifares.Do i have to do the RIP rules?
So from what I got that way, you have to advertise those IPs to ISP's equipment using RIP so that it would send you the traffic. Don't ask me why the ISP needs it, and even more important, don't ask me what happens if you start advertising some other IPs than those assigned to you :)
So you need more selective dst-nat rules, but the basic idea remains the same.I just wanna map different ports on different public ips to some servers on the LAN side
Since the time when the topic has started, I've set up a portable lab on my laptop, so I could now debug the configuration locally.but how do I configure the public IP /29 range I'm assigned if I'm getting a different single ip on pppoe?
It seems that RIP can only advertise existing routes, i.e. you cannot add a route to be advertised unless it exists in your routing table.
But you can keep redistribution of all the route types (connected, static, ospf-learned, bgp-learned) disabled and specify networks to be handled by RIP, provided that connected routes to these networks exist. So you have to create a bridge with no member ports and assign any address from your.public.sub.net/29 to it (except the first and last one of course). Then, you configure the RIP:
/routing rip interface
add interface=pppoe-out1 receive=v2 transmit=v2 passive=no
/routing rip network
add network=pppoe.gate.way.ip/32
add network=your.public.sub.net/29
will make the ISP start sending the traffic to you via the PPPoE.
Adding a network=0.0.0.0/0 under /routing rip network causes all connected networks to be advertised, and I could not find a way to filter out the unnecessary ones using /routing filter or /routing prefix-lists. So if you can't find a way, you have to stay with network=pppoe.gate.way.ip under /routing rip network; if that address is different each time the PPPoE client connects, you'll have to use a /ppp profile item for the PPPoE interface with an on-up script that will modify the /routing rip network item accordingly.
Another bit of information you may find interesting: you can use all 8 addresses from the /29, not just 5. You can use dst-nat also for the "network address" and "broadcast address", as well as the own address of the Mikrotik in that subnet, and you can do so even if you assign those 5 addresses directly to the LAN devices and let the MikroTik be their gateway; the only limitation is that the "network" and "broadcast" addresses won't be accessible for the devices running on the other five.
Dear Sindy,@markovic, the only thing I know about sonicwall is that it exists. So I've asked uncle Google for "sonicwall ripv2" and got this link. It looks pretty simple at first glance to me provided that you have some understanding on what you need to set up to satisfy Ogero, and my previous post should help with that part. What I don't know is whether there is any scripting possibility - if not, you'll have to update the the ARS configuration manually if/when/whenever the address assigned by PPPoE changes.
Our bandwith is 300mbps Down, and around half that Up, this is the max that the ISP has to offer, and we do not plan to increase it anytime soon.If it was me in your situation, inserting a Routerboard between the Sonicwall and the uplink would indeed be the easiest way, because I know something about Mikrotik but much less about Sonicwall. Whether it is also the easiest way for you is up to your own decision - to keep the settings of the Sonicwall totally unchanged, you'll need a little bit more configuration on the Mikrotik than what has been described in this topic so far.
Regarding the Mikrotik model to choose, it depends on the bandwidth your ISP provides you, so tell me the download & upload speeds for the current contract or, if you plan to get more bandwidth in a near future, the expected ones. It also depends in how much you want to modify the configuration of the Sonicwall - if it should keep acting as a PPPoE client, you have to set the Mikrotik to act as a PPPoE server, so the CPU requirements will be slightly higher and thus you may need a more powerful Mikrotik device than if you a use plain IPoE between the Mikrotik and the Sonicwall, which requires a modification of the WAN settings of the Sonicwall.
Thank you sindy.A hAP ac² seems to be the cheapest device to deal with these requirements. For a hEX, it could be a bit too much; a 4011 or a 5009 would clearly be an overkill.
It may still be a bit of a quest to put it all together. I'm afraid we'll have to deal with it when the hAP ac² arrives.
I use tens of these units and you can trust me that they do routeI checked the product.
Correct me if I'm wrong, but I says the product is only an access point and not a router.
From software point of view, all the RouterOS devices have all the routing capabilities, the only difference is the throughput and numbers of some objects that depend on license (like VPN tunnel interfaces). So yes, this device will be enough for your configuration.And if indeed I am wrong, does it support all the protocols that Ogero requires us to do (disable nat, rip v2 etc...)
Will this device be enough for my configuration?
Hey,I can help with the Mikrotik part if that's enough. Since you have 3 lines, it is quite likely you'll need 3 Mikrotiks, as I cannot see a way to make RIP advertise each of the 3 public IPs via another PPPoE client - no instances, no routing filters. If you have a spare PC with two Ethernet cards, it may save some expenses to run a virtual Mikrotik (CHR) on it, using a trial license, to prove the concept before investing into a hardware Mikrotik.
Here you go: viewtopic.php?p=902082#p902082 (and the three posts after just in case).If we can setup a teamviewer/remote session that we could work through it the mikrotik config part in order for it to push a static ip for the sonicwall i would really be grateful.
NVsXTVMzJ0k80Fwf/i1JAxewQsw7JfI38SQG0Cyium8TUMZubwbuPlszFsWax7rgHere you go: viewtopic.php?p=902082#p902082 (and the three posts after just in case).If we can setup a teamviewer/remote session that we could work through it the mikrotik config part in order for it to push a static ip for the sonicwall i would really be grateful.
I don't like open ends, so yes, it isIs this the correct info that i should provide ?
I have to correct myself - routing filters cannot be used with RIP, but routing prefix lists can, so we can control which addresses will be advertised via which uplink.Since you have 3 lines, it is quite likely you'll need 3 Mikrotiks, as I cannot see a way to make RIP advertise each of the 3 public IPs via another PPPoE client - no instances, no routing filters.
I assume I can help but I am not sure what the problem is.Can you help me please?
It's an RB850Gx2 running ROS 6.47.9
There are many ways, from one wasting 5 of your 8 addresses for "overhead" that works with any type of LAN client to more efficient ones where you can use all 8 addresses for your LAN clients but the on the LAN device side differs significantly between operating systems. For example, we were unable to set it up on an UBNT router.Can you let me have the instructions for programming a LAN port with a public IP, without using scr-nat and dst-nat rules that you mentioned in a previous post.
It defnitely does.Does this help?
Have you replaced the xxx in the IP addresses by the correct numeric values before pasting? But as you say you had to adjust the OSPF settings, maybe the sniffing is not necessary any more as it works as you expect now?Trying to copy and paste the line into a terminal window failed, so I tried to enter the line manually, this also failed.
I don't understand this sentence. Tell me the exact address you want to access and the exact address you want to access it from.I still cannot access private IP's when allocated with a public IP.
I don't think so at this stage. The dst-nat/src-nat method is the smplest one to configure overall, it just doesn't allow the public addresses to be up directly on the "customer's" devices.Should I drop the idea of using dst-nat and src-nat rules and use another method? If so which one?
From where??? From a device on a private address in LAN or from a device in the internet, such as your mobile cphone connected to LTE rather than the WiFi AP in the LAN?I can access this router using 192.168.121.200, but I cannot access it with 81.143.42.218
I would like to access this router with the public IP of 81.143.42.218
That would be correct for inbound connections to the 81.x.x.x. Only the initial packet of each connection is handled by the rules in dstnat and srcnat chains, so for an inbound connection, the dst-nat rule translates the 81.x.x.x. to 192.168.x.x, but no src-nat rule matches (currently). The eventual actions taken by the dst-nat and/or src-nat rules is remembered in the context data of the tracked connection and repeated for each subsequent packet of that connection, with regard to its direction. So within an inbound connection, all the "responses" of the server are automatically "un-dst-nated" and all the "requests" from the client are automatically dst-nated the same way like the initial one was.The dst-nat counter shows traffic is flowing with that rule, but the src-nat counter shows zero traffic.
So there are actually two parts, only loosely related to each other. One is to set up the RIPv2 the necessary way to let the ISP know which public /30 to route to you (which still seems to me like a crazy way of doing things at their side, but that's how it is), and the other one is how to forward the traffic for one of those addresses to the Fortigate. Using just one of them for the Fortigate and wasting the rest on the interconnection between the Mikrotik and the Fortigate is the simplest and most stupid way of doing that, but it may be the only possible one depending on what the configuraion possibilities on Fortigate are.settings provided from ISP is PPPoE username and password. in addition they provided 1 static real IP to be used in a /30 subnet. and require to disable NAT and use RIPv2.
In design [ISP Fiber Modem in bridge mode] Connected Cat6 Cable to Mikrotik Port1 then Mikrotik Port2 connected to Fortigate Wan port.
what i want is to use the the real IP either directly on FortiGate or from Mikrotik and forward traffic from/to this IP.
I think I managed to make it work, I will share the below Configs. I would like to know if that's Okay or if i can improve something.So there are actually two parts, only loosely related to each other. One is to set up the RIPv2 the necessary way to let the ISP know which public /30 to route to you (which still seems to me like a crazy way of doing things at their side, but that's how it is), and the other one is how to forward the traffic for one of those addresses to the Fortigate. Using just one of them for the Fortigate and wasting the rest on the interconnection between the Mikrotik and the Fortigate is the simplest and most stupid way of doing that, but it may be the only possible one depending on what the configuraion possibilities on Fortigate are.settings provided from ISP is PPPoE username and password. in addition they provided 1 static real IP to be used in a /30 subnet. and require to disable NAT and use RIPv2.
In design [ISP Fiber Modem in bridge mode] Connected Cat6 Cable to Mikrotik Port1 then Mikrotik Port2 connected to Fortigate Wan port.
what i want is to use the the real IP either directly on FortiGate or from Mikrotik and forward traffic from/to this IP.
So tell me what have you achieved so far and what are the WAN settings available at your Fortigate.
I have no idea what Mikrotik model you use and what DL/UL bandwidth Ogero gives you. Depening on these factors, you might want to save some CPU cycles per packet. Assigning the public IP directly to the Fortigate would remove the need for NAT, which in turn would remove the need for connection tracking of the communication between the Fortigate and the internet. To assign a public address directly to the Fortigate, you can set its own WAN address to that public one with a /32 mask and set the gateway to 10.130.131.1 - this is definitely possible if you set up a PPPoE server on the Mikrotik and set the WAN mode of the Fortigate to PPPoE, but doing that would somehow deny the purpose of lowering the CPU load. Whether the FG can accept such a setup in a plain IP-over-Ethernet configuration (static or DHCP) needs to be tested - some vendors can handle that, some cannot. In any of these "two and a half" variants, you would have to disable (and later remove if it works) the public address on the Mikrotik. The CIDR mask of the address assigned to ether2 would have to change from /30 to /32 and the network parameter of that address would have to change to the public address assigned to the FG.I would like to know if that's Okay or if i can improve something.
That's a task for someone else, I cannot provide a second opinion for a script suggested by myselfi was missing the highlighted in red above which is the gateway received when connected to PPPoE. my Concern is what if this gateway changes all of a sudden? is there a way to make it automated. i saw a script earlier in this topic... but i prefer a second opinion.
I am using x86 Mikrotik on a VMware ESXi.I have no idea what Mikrotik model you use and what DL/UL bandwidth Ogero gives you. Depening on these factors, you might want to save some CPU cycles per packet. Assigning the public IP directly to the Fortigate would remove the need for NAT, which in turn would remove the need for connection tracking of the communication between the Fortigate and the internet. To assign a public address directly to the Fortigate, you can set its own WAN address to that public one with a /32 mask and set the gateway to 10.130.131.1 - this is definitely possible if you set up a PPPoE server on the Mikrotik and set the WAN mode of the Fortigate to PPPoE, but doing that would somehow deny the purpose of lowering the CPU load. Whether the FG can accept such a setup in a plain IP-over-Ethernet configuration (static or DHCP) needs to be tested - some vendors can handle that, some cannot. In any of these "two and a half" variants, you would have to disable (and later remove if it works) the public address on the Mikrotik. The CIDR mask of the address assigned to ether2 would have to change from /30 to /32 and the network parameter of that address would have to change to the public address assigned to the FG.I would like to know if that's Okay or if i can improve something.
A secondary effect of such change would be that you could use the remaining three public addresses from the /30 for other purposes - it may or may not be useful for you.
That's a task for someone else, I cannot provide a second opinion for a script suggested by myselfi was missing the highlighted in red above which is the gateway received when connected to PPPoE. my Concern is what if this gateway changes all of a sudden? is there a way to make it automated. i saw a script earlier in this topic... but i prefer a second opinion.But I could not find any other way in the meantime since posting that.
please advise.
:global pppoegateway;
#change these values accordingly:
:local pinterface "pppoe-OgeroFiber"
:local subnetogero "192.168.0.0/24"
#No more changes
:log info "Fetching Ogero Gateway"
:local currentgateway [/ip route get number=[find gateway=$pinterface && distance=0 && scope=10] dst-address];
:if ($currentgateway != $pppoegateway) do={
:log info "OgeroGateway: Update needed"
:set pppoegateway $currentgateway
/routing rip network
remove [find]
add network=$pppoegateway
add network=$subnetogero
}
If so, conserving CPU on the Mikrotik VM might help the other VMs on the machine, but if that's not important, no need to change anything about the configuration.I am using x86 Mikrotik on a VMware ESXi for 280Mbps download and 150 Upload.
Indeed, I've said I've proposed to use a script, not that I've provided the contents of the scriptthe script am talking about was posted by DjSam
Thank you once again.If so, conserving CPU on the Mikrotik VM might help the other VMs on the machine, but if that's not important, no need to change anything about the configuration.I am using x86 Mikrotik on a VMware ESXi for 280Mbps download and 150 Upload.
Indeed, I've said I've proposed to use a script, not that I've provided the contents of the scriptthe script am talking about was posted by DjSam
Regarding the script itself - given that it will run once a day at most, there is no need to optimize it. The scripts spawned by on-up and on-down items of /ppp profile have access to a global variable holding the name of interface (and to several other global variables), so defining the interface name "manually" in the script could be avoided, but as said it doesn't deserve the time needed for debugging the change.