On my CRS125, I have a XS+DA0003 DAC plugged in which goes to the 'sfp-trunk/port16' port on the CRS125. The configuration for that on the CRS125 is:
Code: Select all
/interface ethernet
set [ find default-name=sfp1 ] advertise=1000M-full auto-negotiation=no name=sfp1-trunk
/interface ethernet switch egress-vlan-tag
add comment="trunk port" tagged-ports=ether20-trunk-upstairs-p1,ether21-trunk,ether22-trunk,ether23-trunk,ether24-trunk,sfp1-trunk,switch1-cpu vlan-id=99
add comment="trunk port" tagged-ports=ether20-trunk-upstairs-p1,ether21-trunk,ether22-trunk,ether23-trunk,ether24-trunk,sfp1-trunk vlan-id=10
add comment="trunk port" tagged-ports=ether20-trunk-upstairs-p1,ether21-trunk,ether22-trunk,ether23-trunk,ether24-trunk,sfp1-trunk vlan-id=20
add comment="trunk port" tagged-ports=ether20-trunk-upstairs-p1,ether21-trunk,ether22-trunk,ether23-trunk,ether24-trunk,sfp1-trunk vlan-id=30
add comment="trunk port" tagged-ports=ether20-trunk-upstairs-p1,ether21-trunk,ether22-trunk,ether23-trunk,ether24-trunk,sfp1-trunk vlan-id=40
add comment="trunk port" tagged-ports=ether20-trunk-upstairs-p1,ether21-trunk,ether22-trunk,ether23-trunk,ether24-trunk,sfp1-trunk vlan-id=41
add comment="trunk port" tagged-ports=ether20-trunk-upstairs-p1,ether21-trunk,ether22-trunk,ether23-trunk,ether24-trunk,sfp1-trunk vlan-id=42
add comment="trunk port" tagged-ports=ether20-trunk-upstairs-p1,ether21-trunk,ether22-trunk,ether23-trunk,ether24-trunk,sfp1-trunk vlan-id=43
/interface ethernet switch ingress-vlan-translation
add comment="access ports" customer-vid=0 new-customer-vid=99 ports="ether1-ucs-server,ether2-sonos,ether3-tivo,ether4-vlan99-router,ether5-idrac-dell,ether6-doorbird-p2,ether7-envisalink-p3,ether8-ucs-mgmt,ether9,ether10,ether11-basement-ap,ether12-hu\
e-hub,ether13-hikvision,ether14-samsung,ether15-outside-spare-p8,ether16-omni-p9,ether17-dell-server,ether18-kitchenap-p23"
add comment="access ports" customer-vid=0 new-customer-vid=10 ports=ether19-vlan10
/interface ethernet switch vlan
add ports=ether19-vlan10,ether20-trunk-upstairs-p1,ether21-trunk,ether22-trunk,ether23-trunk,ether24-trunk,sfp1-trunk vlan-id=10
add ports=ether20-trunk-upstairs-p1,ether21-trunk,ether22-trunk,ether23-trunk,ether24-trunk,sfp1-trunk vlan-id=20
add ports=ether20-trunk-upstairs-p1,ether21-trunk,ether22-trunk,ether23-trunk,ether24-trunk,sfp1-trunk vlan-id=30
add ports="ether1-ucs-server,ether2-sonos,ether3-tivo,ether4-vlan99-router,ether5-idrac-dell,ether6-doorbird-p2,ether7-envisalink-p3,ether8-ucs-mgmt,ether9,ether10,ether11-basement-ap,ether12-hue-hub,ether13-hikvision,ether14-samsung,ether15-outside-sp\
are-p8,ether16-omni-p9,ether17-dell-server,ether18-kitchenap-p23,ether20-trunk-upstairs-p1,ether21-trunk,ether22-trunk,ether23-trunk,ether24-trunk,sfp1-trunk,switch1-cpu" vlan-id=99
add ports=ether20-trunk-upstairs-p1,ether21-trunk,ether22-trunk,ether23-trunk,ether24-trunk,sfp1-trunk vlan-id=41
add ports=ether20-trunk-upstairs-p1,ether21-trunk,ether22-trunk,ether23-trunk,ether24-trunk,sfp1-trunk vlan-id=42
add ports=ether20-trunk-upstairs-p1,ether21-trunk,ether22-trunk,ether23-trunk,ether24-trunk,sfp1-trunk vlan-id=43
Code: Select all
/interface bridge
add name=BR1 protocol-mode=none vlan-filtering=yes
/interface ethernet
set [ find default-name=sfp-sfpplus10 ] comment="Bell Fibe (VLAN 10 Access Port)" name=access-vlan10
set [ find default-name=sfp-sfpplus11 ] comment="Bell Fibe (VLAN 99 Access Port)" name=access-vlan99
set [ find default-name=sfp-sfpplus16 ] auto-negotiation=no name=sfp-trunk
set [ find default-name=sfp-sfpplus3 ] disabled=yes name=sfp3
set [ find default-name=sfp-sfpplus4 ] disabled=yes name=sfp4
set [ find default-name=sfp-sfpplus7 ] disabled=yes name=sfp7
set [ find default-name=sfp-sfpplus8 ] disabled=yes name=sfp8
set [ find default-name=sfp-sfpplus9 ] disabled=yes name=sfp9
set [ find default-name=sfp-sfpplus12 ] disabled=yes name=sfp12
set [ find default-name=sfp-sfpplus13 ] disabled=yes name=sfp13
set [ find default-name=sfp-sfpplus14 ] disabled=yes name=sfp14
set [ find default-name=sfp-sfpplus15 ] disabled=yes name=sfp15
set [ find default-name=sfp-sfpplus6 ] auto-negotiation=no name=trunk-dell-ix0 speed=10Gbps
set [ find default-name=sfp-sfpplus5 ] auto-negotiation=no name=trunk-dell-ix1 speed=10Gbps
set [ find default-name=sfp-sfpplus2 ] auto-negotiation=no name=trunk-ucs-vmnic2 speed=10Gbps
set [ find default-name=sfp-sfpplus1 ] auto-negotiation=no name=trunk-ucs-vmnic3 speed=10Gbps
/interface vlan
add interface=BR1 name=vlan99 vlan-id=99
/interface lte apn
set [ find default=yes ] ip-type=ipv4-ipv6
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface bridge port
add bridge=BR1 frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=yes interface=trunk-ucs-vmnic3
add bridge=BR1 frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=yes interface=sfp-trunk
add bridge=BR1 frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=yes interface=trunk-ucs-vmnic2
add bridge=BR1 frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=yes interface=trunk-dell-ix0
add bridge=BR1 frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=yes interface=trunk-dell-ix1
add bridge=BR1 interface=access-vlan10 pvid=10
add bridge=BR1 interface=access-vlan99 pvid=99
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/interface bridge vlan
add bridge=BR1 tagged=sfp-trunk,trunk-ucs-vmnic2,trunk-ucs-vmnic3,trunk-dell-ix0,trunk-dell-ix1 vlan-ids=10
add bridge=BR1 tagged=sfp-trunk,trunk-ucs-vmnic2,trunk-ucs-vmnic3,trunk-dell-ix0,trunk-dell-ix1 vlan-ids=20
add bridge=BR1 tagged=sfp-trunk,trunk-ucs-vmnic2,trunk-ucs-vmnic3,trunk-dell-ix0,trunk-dell-ix1 vlan-ids=30
add bridge=BR1 tagged=sfp-trunk,trunk-ucs-vmnic2,trunk-ucs-vmnic3,trunk-dell-ix0,trunk-dell-ix1 vlan-ids=40
add bridge=BR1 tagged=BR1,sfp-trunk,trunk-ucs-vmnic2,trunk-ucs-vmnic3,trunk-dell-ix0,trunk-dell-ix1 vlan-ids=99
add bridge=BR1 tagged=sfp-trunk,trunk-ucs-vmnic2,trunk-ucs-vmnic3,trunk-dell-ix0,trunk-dell-ix1 vlan-ids=41
add bridge=BR1 tagged=sfp-trunk,trunk-ucs-vmnic2,trunk-ucs-vmnic3,trunk-dell-ix0,trunk-dell-ix1 vlan-ids=42
add bridge=BR1 tagged=sfp-trunk,trunk-ucs-vmnic2,trunk-ucs-vmnic3,trunk-dell-ix0,trunk-dell-ix1 vlan-ids=43
add bridge=BR1 tagged=sfp-trunk,trunk-ucs-vmnic2,trunk-ucs-vmnic3,trunk-dell-ix0,trunk-dell-ix1 vlan-ids=44
/ip dhcp-client
add disabled=no interface=vlan99
/system clock
set time-zone-name=America/Toronto
/system identity
set name=fibre-switch