[admin@instaler] > ip firewall mangle print
Flags: X - disabled, I - invalid, D - dynamic
0 ;;; UP TRAFFIC
chain=prerouting in-interface=lan
src-address=172.21.1.0/24 action=mark-packet
new-packet-mark=test-up passthrough=no
1 ;;; CONN-MARK
chain=forward src-address=172.21.1.0/24
action=mark-connection
new-connection-mark=test-conn passthrough=yes
2 ;;; DOWN-DIRECT CONNECTION
chain=forward in-interface=public
connection-mark=test-conn action=mark-packet
new-packet-mark=test-down passthrough=no
3 ;;; DOWN-VIA PROXY
chain=output out-interface=lan
dst-address=172.21.1.0/24 action=mark-packet
new-packet-mark=test-down passthrough=no
0 name="downstream" parent=lan packet-mark=test-down
limit-at=32000 queue=default priority=8
max-limit=32000 burst-limit=0
burst-threshold=0 burst-time=0s
1 name="upstream" parent=global-in
packet-mark=test-up limit-at=32000
queue=default priority=8
max-limit=32000 burst-limit=0
burst-threshold=0 burst-time=0s
you must learn networking to work with networking, so its enough documents and forum post to find the path to you perfect config.!I think MT forum is not the place to find solutions !! its only a place to describe problems ..
we must c ( as in other similar forums ) some sticky topics that explain and solve the major cases , and i think bandwidth manegement is a very important think to be solved here with all cases , many local interfaces , many subnets , web-proxy , masqurading , couse even in wiki we cant find the complete solution , and i think it must be added as sticky topics instead of ADV topics for MT products , and how long can the signal reach using 2 MT routerboards installed on a very high mountains each on a side of the SEA !!!!!!!
Nicely put...you must learn networking to work with networking, so its enough documents and forum post to find the path to you perfect config.!
no one can give you solution for your setup. i have give you primer where to start! if you dont know how to use mangle rules, or ip flow at all then ... RTFM
Zarko
SkopjeWirelessNetwork
who can solve this mestry ???t3rm - ignore samsoft08, he is just an impatient and frustrated MT user & knows not what he says.
I don't understand why you say you can't differentiate traffic originating from the proxy from traffic from the internet?
Surely mangling on the appropriate chain should accomplish what you are trying to achieve?
If you set different marks on forward vs output chain, you should be able to manage the different traffic flows?
t3rm - ignore samsoft08, he is just an impatient and frustrated MT user & knows not what he says.
I don't understand why you say you can't differentiate traffic originating from the proxy from traffic from the internet?
Surely mangling on the appropriate chain should accomplish what you are trying to achieve?
If you set different marks on forward vs output chain, you should be able to manage the different traffic flows?
and alsoA paket can enter processing conveyer of the router in two ways. First, a packet can come from one of the interfaces present in the roter (then the interface is referred as input interface). Second, it can be originated from a local process, like web proxy, VPN or others. Alike, there are two ways for a packet to leave the processing pipeline. A packet can leave through the one of the router's interfaces (in this case the interface is referred as output interface) or it can end up in the local process.
- the traffic which is destined to the router itself. The IP packets has destination address equal to one of the router's IP addresses. A packet enters the router through the input interface, sequentially traverses prerouting and input chains and ends up in the local process. Consequently, a packet can be filtered in the input chain filter and mangled in two places: the input and the prerouting chain filters.
- the traffic is originated from the router. In this case the IP packets have their source addresses identical to one of the router's IP addresses. Such packets travel through the output chain, then they are passed to the routing facility where an appropriate routing path for each packet is determined and leave through the postrouting chain.
- routable traffic, which is received at the router's MAC address, has an IP address different from any of the router's own addresses, and its destination can be found in the routing tables. These packets go through the prerouting, forward and postrouting chains.
Hallelujah! A believer!I think marking packets according to the wiki is 100% ok and it works as per quee tree rule . I mean the proxy traffic limit in the quee tree rule can deliver the alloted speed or unlimited
from the internel cache .
Let me try - I'm too lazy to give the complete config, and normally I prefer showing someone how to fish over actually giving them the fish :GWISA : I Give Up ....
The ISP only give to two of your clients totally 64kbps. It means each client gets 32Kbps CIR and 64Kbps MIR.
They can get 100Mbps, if the packets they requested already in cache.
Now , let me see your configuration then ..
- Rio.Martin -
Especially not to lazy users who just copy other people's work and don't have the mettle to accomplish anything by themselves...t3rm , router os can do everything you can imagine ,and everything you cant imagine but you have to read , read and read the manual , dont forget between lines , after reading the manual , read it again , after that go to the manual , raed it , you'll find the solution after reading the manual , and dont expect any examples !!!! no one will give you an example for somthing he doesnt know what it is !!! may be tons of words , but examples , sorry ..
oh puh-lease.... I remember this kind of challenge from my junior school days...if you DARE !!!!! ..
chain=forward action=jump jump-target=not-proxy out-interface=ether1
src-address=!192.168.1.2 src-port=!3128 protocol=tcp
chain=output action=jump jump-target=proxy out-interface=ether1
src-address=192.168.1.2 src-port=3128 protocol=tcp
chain=proxy action=mark-connection new-connection-mark=proxy passthrough=yes
chain=not-proxy action=mark-connection new-connection-mark=not-proxy
passthrough=yes
chain=proxy action=mark-packet new-packet-mark=proxy-flow passthrough=no
connection-mark=proxy
chain=forward action=add-dst-to-address-list src-address=192.168.1.2
src-port=3128 protocol=tcp address-list=proxy-fwd-dst address-list-timeout=5m
Well - that is the exact same presentation I suggested you watch in the beginning of this thread... in pdf format.sure its 100% correct , its similar to the example in the wiki , except in the wiki he marks packets coming out from the proxy directly without connection marking ..
we know that router os can deal with the difference , the question is not this difference..
I found an amazing explanation for packet flow so simple and so helpful its :
http://mum.mikrotik.com/presentations/2 ... traweb.pdf
I don't think so - It should read:our case is : packets in (3) = packets in (2) + packets from cache disk
correct ?
You don't - you seperate them at (3) and a missing identifying mark on the forward chain (call it 2.5?).now the question is how to seperate marking packets in (3) ? to give packets from the cache disk unlimited bandwidth ?
when you say (2) is equal to (3) you ignored all packets came out from the local process ( cache disk )packets out (3) = packets in (2) = packets from cache disk (and other local processes)
Thanks God
Finally GWISA understand ..
Although I always advocate this, in this case I'd like to figure it out myself - what with me having completed two MT courses over the past 3 years or so...training is the solution in this case - you have to know what you are doing and then it can be easily done using RouterOS, some things will ask more effort and more configuration rules, but over all everything can be done.
see our consultant list and pay them for complete solutions:
http://www.mikrotik.com/consultants.html
I think the killing time has passed?And I'll give my solution here ASAP before you people going to kill each other. Huh huh huh just joking. I know I'm new here as a forum user but I promise you about this solution. Now I'm bit busy I'll give my solution within 24 hours.
as always cheap advertising !!see our consultant list and pay them for complete solutions:
non real life talking , non scientific at all , we heared that talk since the early versions of router os , if it was true so why UPGRADING ???????????? if that was true it means 2.1 is equal to 3rc4 ????????but over all everything can be done.
maybe this is a solution , if we use output chain ,out interface = local , TOS = 4 !!!Hi! The solution is in 3.0 version. Change tos from "hits" in the proxy - Cache Hit DSCP (TOS) - option in web-proxy general settings, then mangle or anything. In version 2.9 or prior is not possible.
With the same TOS setting of 4?no its working with me on v3rc3 , i dont know how it can work on 2.9 ?
i agree , couse we solve this issue after a long discussion :Please don't hijack what has become a constructive discussion just to advertise your services...
add action=mark-packet chain=output comment="CACHE" disabled=no dscp=4 new-packet-mark=cache-packets \
out-interface=(local) passthrough=no
I'm thinking if we find a way to make it work with one ROS, why waste resources & use two?I don't know why you people don't interested in my web-proxy solution with 2 MT OS?
add action=mark-packet chain=output comment="CACHE" disabled=no dscp=4 new-packet-mark=cache-packets out-interface=(Local) passthrough=no
add comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=10000/20000 \
max-limit=30000/3000000 name="CACHED-PACKETS" packet-marks=cache-packets parent=none priority=3 \
queue=pcq-upload/pcq-download target-addresses=192.168.1.0/24 total-queue=default-small
Hi! The solution is in 3.0 version. Change tos from "hits" in the proxy - Cache Hit DSCP (TOS) - option in web-proxy general settings, then mangle or anything. In version 2.9 or prior is not possible.
which version is stable in your opinion ?? why do you upgrade before untill you reach v 2.9.46 ?offcourse thanks to npbrasil
Quote:
Hi! The solution is in 3.0 version. Change tos from "hits" in the proxy - Cache Hit DSCP (TOS) - option in web-proxy general settings, then mangle or anything. In version 2.9 or prior is not possible.
hello , i dont know if read my past topic or not ? it has been solved my friends , and i'm monitoring the results , and it is perfect ..
its by marking traffic coming from proxy with TOS = 4 , its the traffic generated in local process ( hard disk cache ) ..
for example i downloaded a file for the first time , my Q limit reachs the max limit ( red ) , and its the same value i can see in tourch , downloading the file for the second time in tourch it's more than 1.5M/s while my Q still at about 25k/s , i repeated the test many many times and i can see how successfull is this way ..
here is the rules i wrote :
Mangle : first rule in mangleSimple Q : first rule in simple QCode: Select alladd action=mark-packet chain=output comment="CACHE" disabled=no dscp=4 new-packet-mark=cache-packets out-interface=(Local) passthrough=no
and i will post some capture images of the result..Code: Select alladd comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=10000/20000 \ max-limit=30000/3000000 name="CACHED-PACKETS" packet-marks=cache-packets parent=none priority=3 \ queue=pcq-upload/pcq-download target-addresses=192.168.1.0/24 total-queue=default-small
offcourse thanks to npbrasilHi! The solution is in 3.0 version. Change tos from "hits" in the proxy - Cache Hit DSCP (TOS) - option in web-proxy general settings, then mangle or anything. In version 2.9 or prior is not possible.
Yes emmanuel you are right, TOS 4 is not working in my MT (3.0rc4n5) too.emmanuel wrote: TOS setting of 4 is not working in 3.0rc5 pl chcek it out
/ip firewall mangle
add action=mark-packet chain=output comment="cached packets" disabled=no \
dscp=4 new-packet-mark=cached out-interface=!wan passthrough=no
/queue simple
add comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all \
limit-at=0/0 max-limit=0/0 name="cached" packet-marks=cached parent=none \
priority=8 queue=default-small/default-small \
target-addresses=192.168.0.0/16 total-queue=default-small
Hey, what do u think u r? Am I sounds like a dump shit?!!skillful wrote:Maybe you need to hire a consultant to configure your router for you.
to get HIT cache objects with unlimited rateHi,
If you check this old post:
http://forum.mikrotik.com/viewtopic.php ... 334&hilit=
you can see that I've asked this web-cache issue last year (without reply).
Also, I asked this on my last Mikrotik training and get no answer
This is Not possible with 2.9.x routeros (at least until 2.9.46).
With routeros 3.0 you can do it , as wiki article said
how ever , routeros 3 is unestable yet.
In order to mark HIT OBJETS, I use a Linux box , with squid patched
with:
http://zph.bratcheda.org
This is the *only way* to get HIT cache objets with unlimited rate,
on routeros 2.9 series.
HIT objects are marked with ToS on squid configuration.
a MT rule on mangle table, can sent that objects to a simple (and unlimited) queue.
Regards...
Can you help me out, or it is not possible with MT OS??!!Simple Q : first rule in simple Q
Code:
add comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=10000/20000 \
max-limit=30000/3000000 name="CACHED-PACKETS" packet-marks=cache-packets parent=none priority=3 \
queue=pcq-upload/pcq-download target-addresses=192.168.1.0/24 total-queue=default-small
for your give hint . i make posible this to my linux box ! over 20 mb wan link and 2000 users are running well since 3 days ! thanks again