Thanks for response.If you'll have exactly as per your diagram, i.e. one LAN per port, each port different LAN, then you don't need VLANs at all. Simply remove all ports from bridge (then remove bridge), set appropriate IP address to each physical port and you're done. Add DHCP servers to interfaces you need (or configure DHCP relay if you want to have one central DHCP server not on router itself). The rest (firewall etc.) is usually not bound to interfaces but rather IP subnets. Ditto for routing.
Thank you very much. I've try to do such - think there is only bridge interface tagged member od VLANs (dont't know how to do that...)You sure can keep bridge and use VLANs for port separation. If you haven't already, have a look at this tutorial. What is special in your case is that only single physical port will be untagged member of corresponding VLAN while bridge interface will be tagged member of all VLANs.
/interface bridge
add admin-mac=XXXXXX auto-mac=no comment=defconf name=bridge \
protocol-mode=none
/interface vlan
add interface=ether2 name=vlan-ether2-PC vlan-id=20
add interface=ether3 name=vlan-ether3-CAMS vlan-id=30
add interface=ether4 name=vlan-ether4-NAS vlan-id=40
add interface=ether5 name=vlan-ether5-LAN vlan-id=50
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
add name=dhcp_pool1 ranges=192.168.20.2-192.168.20.254
add name=dhcp_pool2 ranges=192.168.30.2-192.168.30.254
add name=dhcp_pool3 ranges=192.168.40.2-192.168.40.254
add name=dhcp_pool4 ranges=192.168.50.2-192.168.50.254
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge name=defconf
add address-pool=dhcp_pool1 disabled=no interface=vlan-ether2-PC name=dhcp1
add address-pool=dhcp_pool2 disabled=no interface=vlan-ether3-CAMS name=dhcp2
add address-pool=dhcp_pool3 disabled=no interface=vlan-ether4-NAS name=dhcp3
add address-pool=dhcp_pool4 disabled=no interface=vlan-ether5-LAN name=dhcp4
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
/ip address
add address=192.168.88.1/24 comment=defconf interface=bridge network=\
192.168.88.0
add address=192.168.20.1/24 interface=bridge network=192.168.20.0
add address=192.168.30.1/24 interface=vlan-ether3-CAMS network=192.168.30.0
add address=192.168.40.1/24 interface=vlan-ether4-NAS network=192.168.40.0
add address=192.168.50.1/24 interface=vlan-ether5-LAN network=192.168.50.0
/ip dhcp-client
add comment=defconf disabled=no interface=ether1
/ip dhcp-server network
add address=192.168.20.0/24 gateway=192.168.20.1
add address=192.168.30.0/24 gateway=192.168.30.1
add address=192.168.40.0/24 gateway=192.168.40.1
add address=192.168.50.0/24 gateway=192.168.50.1
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
Trying to understand bridges and VLANs... Is this have more sense?The config you posted has nothing to do with bridge vlan-filtering which is nicely explained by tutorial I mentioned in my previous post.
/interface bridge add name=BR1 protocol-mode=none vlan-filtering=no
/interface bridge port
add bridge=BR1 interface=ether2 pvid=20
add bridge=BR1 interface=ether3 pvid=30
add bridge=BR1 interface=ether4 pvid=40
add bridge=BR1 interface=ether5 pvid=50
/interface bridge port
add bridge=BR1 interface=ether1
/interface bridge vlan
set bridge=BR1 tagged=ether1 [find vlan-ids=20]
set bridge=BR1 tagged=ether1 [find vlan-ids=30]
set bridge=BR1 tagged=ether1 [find vlan-ids=40]
set bridge=BR1 tagged=ether1 [find vlan-ids=50]
add bridge=BR1 tagged=BR1,ether1 vlan-ids=99
/interface vlan add interface=BR1 name=BASE_VLAN vlan-id=99
/ip address add address=192.168.0.3/24 interface=BASE_VLAN
/ip route add distance=1 gateway=192.168.0.1
/interface bridge port
set bridge=BR1 ingress-filtering=yes frame-types=admit-only-untagged-and-priority-tagged [find interface=ether1]
set bridge=BR1 ingress-filtering=yes frame-types=admit-only-untagged-and-priority-tagged [find interface=ether2]
set bridge=BR1 ingress-filtering=yes frame-types=admit-only-untagged-and-priority-tagged [find interface=ether3]
set bridge=BR1 ingress-filtering=yes frame-types=admit-only-untagged-and-priority-tagged [find interface=ether4]
/interface bridge port set bridge=BR1 ingress-filtering=yes frame-types=admit-only-vlan-tagged [find interface=ether1]
/interface bridge set BR1 vlan-filtering=yes
Trying to understand bridges and VLANs... Is this have more sense?The config you posted has nothing to do with bridge vlan-filtering which is nicely explained by tutorial I mentioned in my previous post.
Maybe it is stupid, but there is two reasons:Again, if the diagram is your stated method of showing us your requirments why are you farting around with vlans?
OK First step: no VLANs, no bridge.None at all, but in terms of learning,
a. its really cool to see that you setup your network without vlans and without the use of bridge.
# aug/30/2021 20:37:55 by RouterOS 6.48.4
# software id = ICTI-3408
#
# model = RB750Gr3
# serial number = XXXXXXXXXXXX
/interface list
add comment=defconf name=WAN
add name=LAN-ether2
add name=LAN-ether3
add name=LAN-ether4
add name=LAN-ether5
add comment=defconf include=LAN-ether2,LAN-ether3,LAN-ether4,LAN-ether5 name=\
LAN
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
add name=dhcp_ether2_192.168.20.0 ranges=192.168.20.20-192.168.20.200
add name=dhcp_ether3_192.168.30.0 ranges=192.168.30.10-192.168.30.200
add name=dhcp_ether4_192.168.40.0 ranges=192.168.40.10-192.168.40.200
add name=dhcp_ether5_192.168.50.0 ranges=192.168.50.10-192.168.50.200
/ip dhcp-server
add address-pool=dhcp_ether2_192.168.20.0 disabled=no interface=ether2 name=\
DHCP-ether2
add address-pool=dhcp_ether3_192.168.30.0 disabled=no interface=ether3 name=\
DHCP-ether3
add address-pool=dhcp_ether4_192.168.40.0 disabled=no interface=ether4 name=\
DHCP-ether4
add address-pool=dhcp_ether5_192.168.50.0 disabled=no interface=ether5 name=\
DHCP-ether5
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf list=LAN
add comment=defconf interface=ether1 list=WAN
add interface=ether2 list=LAN-ether2
add interface=ether3 list=LAN-ether3
add interface=ether4 list=LAN-ether4
add interface=ether5 list=LAN-ether5
/ip address
add address=192.168.30.1/24 interface=ether3 network=192.168.30.0
add address=192.168.40.1/24 interface=ether4 network=192.168.40.0
add address=192.168.50.1/24 interface=ether5 network=192.168.50.0
add address=192.168.20.1/24 interface=ether2 network=192.168.20.0
/ip dhcp-client
add comment=defconf disabled=no interface=ether1
/ip dhcp-server network
add address=192.168.20.0/24 gateway=192.168.20.1
add address=192.168.30.0/24 gateway=192.168.30.1
add address=192.168.40.0/24 gateway=192.168.40.1
add address=192.168.50.0/24 gateway=192.168.50.1
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
"defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
add action=accept chain=input comment="MY FW STARTS HERE" in-interface-list=\
LAN-ether2
add action=accept chain=forward in-interface-list=LAN-ether2
add action=accept chain=input in-interface-list=LAN-ether3
add action=accept chain=forward in-interface-list=LAN-ether3
add action=accept chain=input in-interface-list=LAN-ether4
add action=accept chain=forward in-interface-list=LAN-ether4
add action=accept chain=input in-interface-list=LAN-ether5
add action=accept chain=forward in-interface-list=LAN-ether5
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
in-interface-list=!LAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface-list=WAN
/system clock
set time-zone-name=Europe/Warsaw
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
Great Scott! Yoy're great Thanks for help!Yikes what did you do LOL.......
# aug/31/2021 19:32:47 by RouterOS 6.48.4
# software id = ICTI-3408
#
# model = RB750Gr3
# serial number = XXXXX
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
add comment="NO internet access" name=ALLOW_INTERNET
/ip pool
add name=dhcp_ether2_PC ranges=192.168.20.20-192.168.20.200
add name=dhcp_ether3_CAMS ranges=192.168.30.10-192.168.30.200
add name=dhcp_ether4_NAS ranges=192.168.40.10-192.168.40.200
add name=dhcp_ether5_WiFi ranges=192.168.50.10-192.168.50.200
/ip dhcp-server
add address-pool=dhcp_ether2_PC disabled=no interface=ether2 lease-time=2w \
name=DHCP-PC
add address-pool=dhcp_ether3_CAMS disabled=no interface=ether3 lease-time=2w \
name=DHCP-CAMS
add address-pool=dhcp_ether5_WiFi disabled=no interface=ether5 lease-time=2w \
name=DHCP-WiFi
add address-pool=dhcp_ether4_NAS disabled=no interface=ether4 lease-time=2w\
name=DHCP-NAS
/system logging action
add disk-file-name=disk1/log name=usb target=disk
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface l2tp-server server
set authentication=mschap2 enabled=yes use-ipsec=required
/interface list member
add comment=WAN interface=ether1 list=WAN
add comment="LAN - PC" interface=ether2 list=LAN
add comment="LAN - CAMS" interface=ether3 list=LAN
add comment="LAN - NAS" interface=ether4 list=LAN
add comment="LAN - WiFi" interface=ether5 list=LAN
add interface=ether2 list=ALLOW_INTERNET
add interface=ether5 list=ALLOW_INTERNET
/ip address
add address=192.168.30.1/24 interface=ether3 network=192.168.30.0
add address=192.168.40.1/24 interface=ether4 network=192.168.40.0
add address=192.168.50.1/24 interface=ether5 network=192.168.50.0
add address=192.168.20.1/24 interface=ether2 network=192.168.20.0
add address=192.168.10.1 interface=ether1 network=192.168.10.1
/ip dhcp-client
add comment=defconf disabled=no interface=ether1
/ip dhcp-server config
set store-leases-disk=1d
/ip dhcp-server network
add address=192.168.20.0/24 dns-server=192.168.10.1 gateway=192.168.20.1
add address=192.168.30.0/24 dns-server=192.168.10.1 gateway=192.168.30.1
add address=192.168.40.0/24 dns-server=192.168.10.1 gateway=192.168.40.1
add address=192.168.50.0/24 dns-server=192.168.10.1 gateway=192.168.50.1
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
"defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
in-interface-list=!LAN log-prefix=NOT_LAN
add action=accept chain=input comment="MY FW: accept INPUT from LAN" \
in-interface-list=LAN
add action=accept chain=forward comment=\
"MY FW: accept only ALLOWED FORWARD from LAN" in-interface-list=\
ALLOW_INTERNET
add action=accept chain=forward comment="MY FW: allow PCs access to all LAN" \
in-interface=ether2 out-interface-list=LAN
add action=drop chain=forward comment=\
"MY FW: drop IoT clients INTERNET access" src-address=\
192.168.50.201-192.168.50.250
add action=accept chain=forward comment=\
"MY FW: allow WiFis access to all LAN" in-interface=ether5 \
out-interface-list=LAN
add action=accept chain=forward comment="MY FW: allow NAS access to CAMs" \
in-interface=ether4 out-interface=ether3
add action=drop chain=forward comment="MY FW: drop ALL else" log=yes \
log-prefix=DROP_ELSE
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface-list=WAN
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/ppp secret
add local-address=192.168.50.50 name=xxxxxx profile=default-encryption \
remote-address=192.168.50.100 service=l2tp
/system clock
set time-zone-name=Europe/Warsaw
/system logging
set 0 action=usb
set 1 action=usb
/system routerboard settings
set silent-boot=yes
/tool bandwidth-server
set enabled=no
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
"add comment="NO internet access" name=ALLOW_INTERNET" - forgot to change commentJust looking at it quickly ascertained you need another port or a managed switch!.
You cannot separate users on the subnet attached to ether5. They are all on the same LAN.
You should separate users and IOT devices into two different ports and subnets!!
You do realize you don't need separate VLANs for each bit of connected device's MAC address, right?In fact on my main router I have about 20 vlans going through one port to a main managed switch.
Nope, not aware of other methods to accomplish same that are more optimal...You do realize you don't need separate VLANs for each bit of connected device's MAC address, right?In fact on my main router I have about 20 vlans going through one port to a main managed switch.
I'd like to love VLANsYes, that is the beauty of vlans.
They are required when you need to send more than one subnet through a port.
My router is Huawei AX3, and VLAN option looks like: After enabling "VLAN" feature it ask for VLAN number.Which wifi router? Model Number?
A wifi router can be turned into an AP switch but most consumer models then lose their ability for routing and vlans.
If that is the case then you would have to use your wifi device as a router and then the question becomes, is the consumer device able to accept vlans coming in on the WAN side or is it just designed for vlans on the LAN side of the house...........
So make and model number will let me do some research on that end.
In the meantime there are 5 port switches that can handle vlans for less then $25 US.
Almost, dual core. Bought for WiFi6 + gigabit + looks nice. I hate black spider-like routers with 176494 antennasThis beautiful white monster LOL.
https://consumer.huawei.com/en/routers/ax3-quad-core/ ??
I think there is no detailed manual, only Quick start with "hey, guy, just plug in and play". Only one thing about VLAN is "If you need to configure VLAN on your network, contact your broadband carrier to confirm the VLAN parameters, and enable the VLAN switch on the screen". With options: "VLAN ID" and "802.1p".Too bad, I cannot find a full user manual for this router? Only useless quick start guide. Did you get a manual on a CD for example??
Yep, I've messing a little bitI think you will be chasing your tail trying to get that to work then...
Now it looks fine (sorru for using images...): I'd like to define VLAN on Huawei, but then Huawei don't ger IP adress from MT DHCP Try configure VLAN on MT that way:I am not certain and the question is worded in such a way not to be clear, or its clear as mud!!
Not really. I'd like to do such easy VLAN configuration: Now I want create VLAN100 network (RED) for my Huawei device. Just for knowledgeIs this identifying vlan100 on ether5 that the wifi router is providing DHCP service for??
If so why are you setting dhcp server for it etc.......... it should be done on the H router??
OK, I think I will work with LANS with managed switchesGet rid of the unmanaged switch and replace it with a managed switch and all is possible, also suggest that you get APs that are designed to read vlan tags and not spend money on wifi routers.
EAP 245 by TPLINK comes to mind.
Yes, I've just been wonder, if my hardcore-configuration is possible using my devices only. Additional MT or managed switch is nice option, bu I have no space in my 6U rack caseAnother option is to get an MT router with more ports and use the hex as a managed switch ........
However that is far more expensive than just getting a basic managed 5 port switch.
Dooh! That's too bad, in this case it's totally bad idea to put VLANs via unmanaged switch. Seems to increase whole LAN data transmission because of VLANs only... Will stay with my subnets and firewall for traffic controlIn case switch did not learn mapping between dst MAC and switch port, or dst MAC is broadcast MAC address, then unmanged switch will transmit those frames through all ports.