My network devices connection:
Internet <--> Mikrotik Router <--> Switch (usually unmanaged) <--> Wifi Access Points
First I will describe my already running configuration and then describe you what I wish to achieve.
Code: Select all
/interface bridge
add admin-mac=02:B0:D1:A3:4D:37 auto-mac=no name=bridge1
/interface vlan
add interface=bridge1 name=GUEST_VLAN vlan-id=100
/ip pool
add name=pool.bridge ranges=192.168.1.2-192.168.1.254
add name=pool.guests ranges=192.168.2.2-192.168.2.254
/ip dhcp-server
add address-pool=pool.bridge disabled=no interface=bridge1 name=dhcp.bridge
add address-pool=pool.guests disabled=no interface=GUEST_VLAN name=dhcp.guests
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
/ip address
add address=192.168.1.1/24 interface=bridge1 network=192.168.1.0
add address=192.168.2.1/24 interface=GUEST_VLAN network=192.168.2.0
/ip dhcp-server network
add address=192.168.1.0/24 gateway=192.168.1.1
add address=192.168.2.0/24 gateway=192.168.2.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
Also the guests vlan that is running under the bridge is passing to wifi access points and eventually is untagged in order to get connected the guests terminals on my 192.168.2.0/24 network.
What I wish to achieve:
My purpose is to use only vlans in order to manage my devices and passing vlans on my wifi SSID.
When plugin a device on Mikrotik Router I want to get connected on management vlan in order to managing my devices (router and wifi access points), also I want to be able to pass BASE_VLAN (MANAGENET) and GUEST_VLAN on my wifi access point device. Also the wifi access point devices are going to get ip address from the dhcp server will running on BASE_VLAN.
Although I have read this topic in forum (viewtopic.php?f=23&t=143620&p=883307) in order to understand vlan I can't apply it to my configuration. Maybe I haven't completely understand it.
Could you please provide me some guides in order to achieve the above setup by using only vlans with bridge vlan filtering?
Kind Regards