Please document the as-path matching syntax. It looks like the work on the help page stopped in the middle of this.*) route-filters - fixed "as-path" regexp matcher;
Was already removed for 7.1rc5.No container package? Didn't mentioned in the changelog.
*) ssh - made SSH work in VRF's;
documentation updated with some of examples to start with.Please document the as-path matching syntax. It looks like the work on the help page stopped in the middle of this.*) route-filters - fixed "as-path" regexp matcher;
The added examples are regexp strings, but of course we already know these from RouterOS v6.documentation updated with some of examples to start with.
Please document the as-path matching syntax. It looks like the work on the help page stopped in the middle of this.
if ( bgp-med < 30 ) { accept }
There are two common ways how to operate with AS Path data:
convert whole AS path to string and let regexp operate on the string (ROS v6 or Cisco style)
let regexp operate on each entry in the AS path as a number (ROS v7, Juniper style)
The latter method is much faster and less resource-intensive than the string matching approach.
But now with as-path instead of bgp-med. Anything I try gets rejected as a syntax error.
/routing/filter/rule/add rule="if ( bgp-as-path ^1234 ) { accept }" chain=test
No examples represent exactly what documentation says, you should look through examples more carefully (look at what is matched and what is not matched from the example).This would seem to indicate that the as-path match gets passed a list of AS numbers and there are operators that would match one (e.g. the last) or "any item" in that list.
But the regexp examples still seem to assume the match is against an expanded numeric string of the entire path.
I second that !!when will PIM-SM be fixed? it isn't working at all currently.
Ok I have been trying with regexp in { } brackets (as it was previously listed in the documentation, but that has now been removed I see) and also with the keyword "regexp" and the operator ~ and with the regexp in quotes as it is usually required.But now with as-path instead of bgp-med. Anything I try gets rejected as a syntax error.No syntax error, all of provided regexp examples from the documentation works without syntax errorsCode: Select all/routing/filter/rule/add rule="if ( bgp-as-path ^1234 ) { accept }" chain=test
yes, you can test wi-fi speed with enabled fasttrack and without fasttrack@Grant newbie in mikrotik where can i execute or to set that in winbox?
Well, the examples are getting better now and I managed to enter some rules with bgp-as-path matching (which I previously had in v6) but note there still are some quirks.No examples represent exactly what documentation says, you should look through examples more carefully (look at what is matched and what is not matched from the example).
Confirmed!If found that L2TP client login reboots my CCR2004. Have to disable L2TP-server for stable system.
This did not happen with rc4.
Right, couldn't find it. Corrected the download link. Thanks!Why from softpedia?
What's wrong with the official download for 7.1rc4 / arm64 ? https://download.mikrotik.com/routeros/ ... -arm64.npk
One issue that keep hoping that is just going to fixed one day in v7...but still hasn't is "signal reporting with the TelIt 940/960s"*) lte - added AT chat support for Telit LN960;
/interface/lte/at-chat lte1 input="AT#CAINFO?"
output: #CAINFO: 121,800,5,457,-119,-82,-14,92,8b1e,11,1,1,123,2000,3,40,-112,
-90,-5,0,1,0,2,131,5110,3,125,-116,-86,-13,0,1,0,0 OK
/interface/ppp-client/at-chat ppp-out1 input="AT#CAINFO?"
output: ERROR: reply timeout
Winbox in a VRF is already there it looks like, but is missing from the changelog. It is in the v7 Routing Protocol Status page.Hopefully Winbox in a VRF will follow?
Please provide full AS path that this rule supposedly should match.Edit: the matches of bgp-as-path still do not work, no matter if a 12345$ or 12345+ match is used. It won't match.
Test case used: rule="if (bgp-as-path 4220406100+ and dst == 0.0.0.0/0) { accept; }"
It should match any path that ends in 4220406100 (I also tried \$ instead of +) like:Please provide full AS path that this rule supposedly should match.Edit: the matches of bgp-as-path still do not work, no matter if a 12345$ or 12345+ match is used. It won't match.
Test case used: rule="if (bgp-as-path 4220406100+ and dst == 0.0.0.0/0) { accept; }"
I have a similar issue for ASNs in the 4,200,000,000 to 4,294,967,294 range, in fact, for anything greater than 2147483647 (32bit signed max int). I'm guessing the matcher is operating on the ASN as a signed integer, not an unsigned as it should be.Please provide full AS path that this rule supposedly should match.Edit: the matches of bgp-as-path still do not work, no matter if a 12345$ or 12345+ match is used. It won't match.
Test case used: rule="if (bgp-as-path 4220406100+ and dst == 0.0.0.0/0) { accept; }"
try:It should match any path that ends in 4220406100 (I also tried \$ instead of +) like:
4220404000,4220407200,4220403600,4220406000,4220406100
4220406100
These are shown as "filtered" after applying the above filter, also when using this: "if (dst == 0.0.0.0/0 and bgp-as-path 4220406100\$) { accept; }"
but when using the rule "if (dst == 0.0.0.0/0) { accept; }" they are accepted.
I also tried using a num-set but I cannot find the syntax to use it.
"if (dst == 0.0.0.0/0 and bgp-as-path [[num-set-name]]\$) { accept; }" is refused (after creating name=num-set-name with range=4220406100).
if (dst == 0.0.0.0/0 and bgp-as-path -74561196\$) { accept; }
Confirmed, OSPFv3 is also not working for me in rc6. It was working in rc5 I'm pretty sure.using RouterOS 7.1RC6 with EVE-NG, when we configure OSPFv3 when starting the routers, everything works perfectly when turning off the lab and turning on OSPV3 again stops working, and does not form a neighbor
You have to create a support ticket to them I think. I got my own RB5009 still with factory ROS 7.05. I believe they already came out with 7.0.9 factory ROS. Try asking them if they can give, but till now I have not upgrade my RB5009 to any RC version,afraid I can't go back to factory if got any bugs from my use perspective.proxy-arp on bridge not working (running 7.1rc4 - as 7.1rc6 reboots 2004 router during IPsec/L2TP connection).
In case anybody asked - to define split VPN without extra routes and to not create extra phase 2 definitions for site-2-site IPSec VPN.
It just simplifies configuration significantly.
This RoS development sucks... they are using users to test the software... My 2004 is completely unusable in this state.
Is there any option to get back to 7.0.4 factory installed?
I have not upgrade my RB5009 to any RC version,afraid I can't go back to factory if got any bugs from my use perspective.
Yes, it starts from rc5 when IPSec hardware acceleration support is introduced. My CCR2004 will be rebooted within a minute once IPSec tunnel is connected.If found that L2TP client login reboots my CCR2004. Have to disable L2TP-server for stable system.
This did not happen with rc4.
Yes that works! Indeed a signed/unsigned bug. Let's hope it will be fixed soon because we use this range all over the (closed) network.try:
Code: Select allif (dst == 0.0.0.0/0 and bgp-as-path -74561196\$) { accept; }
edit: spoiler: it's definitely a signed/unsigned bug.
rule="if (bgp_as_path [[:numset_name:]]) {accept}"Did you get the num-set feature working? I cannot figure out how it should work from the docs (commandline config does not like [[ nor \[\[ or similar)...
Ok thanks, I was just thinking that might be it (borrowed from another context) and now I see the documentation has been fixed.rule="if (bgp_as_path [[:numset_name:]]) {accept}"
IM also able to crash my 4011 in matter of 5min by setting codel queue, sent several logs, i think they really need to add some better debugging, they never find any crash log in supout that router self generates...CAKE queue still not fix yet on hexS with
pppoe-server
Router reboot
Can you show the output of these commands when ospf adjacency is not forming?using RouterOS 7.1RC6 with EVE-NG, when we configure OSPFv3 when starting the routers, everything works perfectly when turning off the lab and turning on OSPV3 again stops working, and does not form a neighbor @mrz
Big jump in Linux kernel version. What else would you expect?High memory usage on Caplite and RB750gr3 after 7.1b6
(About 16 MB more than version 6.49 )
6.49 => 44.1MB free memory
7.1b6 => 27MB free memory
That is probably a quite complicated configuration or it has something like a DNS blocklist with thousands of items loaded.High memory usage on Caplite and RB750gr3 after 7.1b6
(About 16 MB more than version 6.49 )
6.49 => 44.1MB free memory
7.1b6 => 27MB free memory
Yes that works! Indeed a signed/unsigned bug. Let's hope it will be fixed soon because we use this range all over the (closed) network.
Did you get the num-set feature working? I cannot figure out how it should work from the docs (commandline config does not like [[ nor \[\[ or similar)...
Thank you for the feedback.My audience wifiwave2 is finally stable on latest rc builds.
It has been very unstable on betas, dropping clients sometimes every few minutes.
Thanks for fixing this!
I haven’t spotted however anything on any tv release notes which would explain improvement.
# nov/10/2021 11:25:50 by RouterOS 7.1rc6
# software id = xxxx-xxxx
#
# model = RB941-2nD
# serial number = xxxx
/interface pwr-line set [ find default-name=pwr-line1 ] disabled=yes
/interface bridge add name=bridge1
/interface wireless set [ find default-name=wlan1 ] ssid=MikroTik
/interface list add name=WAN
/interface list add name=LAN
/interface wireless security-profiles set [ find default=yes ] supplicant-identity=MikroTik
/ip pool add name=pool1 ranges=192.168.202.2-192.168.202.20
/ip dhcp-server add add-arp=yes address-pool=pool1 interface=bridge1 name=server1
[b]#interrupted[/b]
...
#error exporting /mpls/traffic-eng/path
...
#error exporting /routing/bgp/template
#error exporting /routing/pimsm/instance
...
#error exporting /interface/vpls/bgp-vpls
...
#error exporting /mpls/interface
#error exporting /mpls/ldp
#error exporting /mpls/ldp/accept-filter
#error exporting /mpls/ldp/advertise-filter
#error exporting /mpls/ldp/interface
#error exporting /mpls/ldp/local-mapping
#error exporting /mpls/ldp/neighbor
#error exporting /mpls/ldp/remote-mapping
#error exporting /mpls/traffic-eng/interface
#error exporting /mpls/traffic-eng/tunnel
...
#error exporting /routing/bgp/connection
#error exporting /routing/bgp/vpn
...
#error exporting /routing/pimsm/bsr/candidate
#error exporting /routing/pimsm/bsr/rp-candidate
#error exporting /routing/pimsm/interface-template
#error exporting /routing/pimsm/static-rp
...
I consider it an improvement! Hopefully the features protected routerboot, reformat-hold-button and reformat-hold-button-max are being discontinued.hAP ac2, 7.1rc6, winbox 3.31, missing routerboard options: protected routerboot, reformat-hold-button and reformat-hold-button-max.
Nice to know the issue from the 7.0rc is still present, it's very hard to provide a supout when the process to create one take 4 hours to complete.hAP lite (RB941-2nD) - Ros 7.1 rc6
Edit: after 4h it completed the verbose export. Update the error list.
In the mean time it generated also a supout.rif, say in 5 minutes!Nice to know the issue from the 7.0rc is still present, it's very hard to provide a supout when the process to create one take 4 hours to complete.hAP lite (RB941-2nD) - Ros 7.1 rc6
Edit: after 4h it completed the verbose export. Update the error list.
I see the same thing happening, this also happens when the link between routers disconnect/connect.using RouterOS 7.1RC6 with EVE-NG, when we configure OSPFv3 when starting the routers, everything works perfectly when turning off the lab and turning on OSPV3 again stops working, and does not form a neighbor @mrz
That's an improvement, my rb941 is timing out and dropping winbox, telnet and web sessions at present, it's working it just refuses to let me login, only been up 50 hours.In the mean time it generated also a supout.rif, say in 5 minutes!
Nice to know the issue from the 7.0rc is still present, it's very hard to provide a supout when the process to create one take 4 hours to complete.
/routing table
add fib name=main
add fib name=""
I had the same issue with a dynamic and static "main" table after upgrading from ROS 6. I had to reset configuration to no-defaults and paste the .rsc back in to fix it. It did not seem to be possible to delete the extra static "main" table, because it had the same name as the dynamic one, although that was several versions ago when I tried.What entries are to be expected in /routing/table ?
Duplicate "main" and empty table appearing after the upgrade will be fixed in the next RC.What entries are to be expected in /routing/table ?
Simple solution: Do not use beta software in production.It is very worrying to take it to a mountain more than 100 kilometers away and that the electricity goes away and does not return until someone goes to turn it on again
This is by definition not possible.Simple solution: Do not use beta software in production.It is very worrying to take it to a mountain more than 100 kilometers away and that the electricity goes away and does not return until someone goes to turn it on again
You are correct. In that case, if it works, do not upgrade until propper version has been released and tested.
Not true either...My understanding is that the factory installed version (now at 7.0.9) is considered stable for the device. It won’t have all the tweaks that have been made in RC that are released after the factory installed version was created, but it’s suppose to be stable. So if you’re really worried, stick with the factory version for now. If you’ve already updated your RB5009 to an RC you can email support and they can provide you the 7.0.9 image and/or netinstall just in case you need it.
Thanks Normis, I did.Panbambaryla please email support@mikrotik.com and report all these issues you are having
I see these too on multiple RC6 systems but not quite so often. Just a couple per day and not from all neighbours.I have received a lot of this warning message on my RB5009 over my neighbor which is using ROS v6.49. Is this a bug from the beta3 version?
OspfInterface { { *12 0.0.0.0 0 ROUTERIP } Backup DR Broadcast } auth data corrupted from REMOTEIP
As far as I know you are posting logging of a wireless client that is losing wireless connection. Is this client the only client connected? Why do you think this is a case of port flapping? I always assumed that port flapping is a port that is disabled and enabled unintended.Severe port flapping with RB4011iGS+5HacQ2HnD + rc6.
I see nothing like that, ethernet ports rock solid here on my RB4011.Severe port flapping with RB4011iGS+5HacQ2HnD + rc6.
system,error,critical kernel failure in previous bootAnything in logs after unsuccessfull upgrade?
Chateau 12 is the same. It's the same on previous versions. wrote in support - no result.Low wi-fi speed if fasttrack is disabling
Hap ac2
Does the ether1 connect to a LAN device (not WAN) ? If you switch to another ethernet port , do you still have this port flapping ? If yes, it could be the issue of the device. for example: the apple TV 4K has this issue (if it is wire connection). It is a well known issue of Apple TV.Severe port flapping with RB4011iGS+5HacQ2HnD + rc6.
Submitted supout: https://help.mikrotik.com/servicedesk/s ... /SUP-65942
Disabling auto negotiation does not fix this. Disabling port and re-enabling it fixes it (temporarily).
Hi!on CCR2004-16G-2S+ we have 2 of them in production running around 100 pppoe clients each i get random reboot every 3-5 days. have you found any solution regarding the same. 1 running 7.1rc5 and 1 running 7.1rc6. generated a ticket already on support
had the same issue on factory installed 7.0.4 stable i dont use L2TPHi!on CCR2004-16G-2S+ we have 2 of them in production running around 100 pppoe clients each i get random reboot every 3-5 days. have you found any solution regarding the same. 1 running 7.1rc5 and 1 running 7.1rc6. generated a ticket already on support
Give it a try and install 7.1rc4 which seems to be more stable as rc5 introduces IPSec hardware accelleration what could be the problem. Look at my previous posts.
Ether1 connects to ONT. Downgraded to RC5 and have zero issues for more than 12h... when in RC6 after a couple of minutes from restart/port disable and re-enable it would show the same behavior.Does the ether1 connect to a LAN device (not WAN) ? If you switch to another ethernet port , do you still have this port flapping ? If yes, it could be the issue of the device. for example: the apple TV 4K has this issue (if it is wire connection). It is a well known issue of Apple TV.
I would not have run beta software in production. Only if there was no other solution. Even then I would have looked for other solution.on CCR2004-16G-2S+ we have 2 of them in production, 1 running 7.1rc5 and 1 running 7.1rc6. generated a ticket already on support
i alreday tried same with factory install 7.0.4 but the issue is sameI would not have run beta software in production. Only if there was no other solution. Even then I would have looked for other solution.on CCR2004-16G-2S+ we have 2 of them in production, 1 running 7.1rc5 and 1 running 7.1rc6. generated a ticket already on support
Mikrotik support itself says that the 7.1rcx is better than the factory rOS 7.0.x (RB5009 and CCR2004-16G-2S+)I would not have run beta software in production. Only if there was no other solution. Even then I would have looked for other solution.
Yeah it looks like there are still some cases of "configuration deemed to be invalid, deleted"....
I temporarily solved the situation by changing the "Group Key Update" parameter from 00:05:00 to 02:00:00disconnected, group key exchange timeout
Ah, good to know!I repartitioned my RB4011 under 6.49, copied to both partitions and upgraded one to 7.1rc5, now rc6.
That all worked fine. So I am not sure if repartition works on v7 but running from a partition certainly does.
I have seen it happen once now on my RB4011 that has been running rc6 since it was released.A strange situation has arisen with the keys. Previously, devices did not turn off in batchesdisconnected, group key exchange timeout
As I said before, If I were you, I would try to create an SQL script that automatically updates the PPP accounting sessions with the IPv6 DHCP accounting information. It should be possible at least, now that everything is being stored in RADIUS.Delegated IPv6 Prefix Parameter is still not included in Radius Accounting Packet for PPP Service.
Unfortunately I have lost my trust in that aspect of RouterOS, now that I have a confirmed problem on my RB4011 (arm) that does not occur with exactly the same configuration on my RB2011 (mipsbe).I can't imagine it only doesn't work on a RB5009.
RB5009 IGMP Proxy not working
Tried disable snooping, still not work.Unlike pim, igmp-proxy is working fine here on 2 different devices. I can't imagine it only doesn't work on a RB5009. Check that you don't accidently block igmp, and make sure the RB5009 is the igmp-querier for all downstream interfaces. Also try to disable and re-enable igmp-snooping in bridge settings.
In my configuration not work.Works great here on my RB5009
RB5009 IGMP Proxy not working
Your configuration is missing from your post. At least do a /routing igmp-proxy export and post the output here.In my configuration not work.
/routing igmp-proxyYour configuration is missing from your post. At least do a /routing igmp-proxy export and post the output here.In my configuration not work.
/routing igmp-proxy interfaceYour configuration is missing from your post. At least do a /routing igmp-proxy export and post the output here.In my configuration not work.
Diff an export after each reboot? What a headache. I'm also seeing regular configuration loss on reboot, particularly on devices which I've been actively working/making changes on. Configuration loss is not something we should be seeing at RC level, alpha and maybe beta, sure. I really hope Mikrotik are prioritizing this issue for next updates. Also the need to disable and re-enable bgp-networks address-list after reboot or intermittent issues, is really frustratingWhen I upgraded from rc5 to rc6 I did not have those issues again, but probably I was just lucky... I have learned by now that after every reboot of v7 one should export the config and diff it to an export made before the reboot, to make sure nothing was silently lost....
(and I often have to do that twice because the first time I forget to add the show-sensitive parameter...)
Well I have posted several issues with BGP in the rc5 and rc6 release topics, both cosmetic and frustrating.is really frustrating
My laptop is stationary but loses connection regularly. Reconnection is in progress. This was not the case before.A strange situation has arisen with the keys. Previously, devices did not turn off in batchesI temporarily solved the situation by changing the "Group Key Update" parameter from 00:05:00 to 02:00:00disconnected, group key exchange timeout
I hope there will be a full-fledged solution to this problem
Mikrotik Chateau 12
v7.1rc6
Its not RC as RC, in another company is RC usually prity stabel. But in mikrotik, is RC deep beta, stable is RC and long term is stable. But the last time they suppriesed all of us, and after upgrading to long term version many devices did not start again,..so not even the long term version is stableDiff an export after each reboot? What a headache. I'm also seeing regular configuration loss on reboot, particularly on devices which I've been actively working/making changes on. Configuration loss is not something we should be seeing at RC level, alpha and maybe beta, sure. I really hope Mikrotik are prioritizing this issue for next updates. Also the need to disable and re-enable bgp-networks address-list after reboot or intermittent issues, is really frustrating
When I upgraded from rc5 to rc6 I did not have those issues again, but probably I was just lucky... I have learned by now that after every reboot of v7 one should export the config and diff it to an export made before the reboot, to make sure nothing was silently lost.
(and I often have to do that twice because the first time I forget to add the show-sensitive parameter...)
Hi mducharme,As I said before, If I were you, I would try to create an SQL script that automatically updates the PPP accounting sessions with the IPv6 DHCP accounting information. It should be possible at least, now that everything is being stored in RADIUS.Delegated IPv6 Prefix Parameter is still not included in Radius Accounting Packet for PPP Service.