I am currently preparing a bunch of routers that will be connected to the web, routing public IPs (BGP feeds).
In the "big vendors" world, I would have a separate VRF for the management, that would be completely isolated from the normal traffic.
Trying to replicate this, I have prepared my management interface/VRF as such:
Code: Select all
/ip address
add address=yyy.yyy.yyy.yyy/24 interface=ether2 network yyy.yyy.yyy.0
add address=xxx.xxx.xxx.xxx/24 interface=ether1 network xxx.xxx.xxx.0
/ip route
add distance=1 gateway=xxx.xxx.xxx.1 routing-mark=mgmt
add distance=1 gateway=yyy.yyy.yyy.1
/ip route vrf
add interfaces=ether1 routing-mark=mgmt
Where yyy.yyy.yyy.yyy is a public IP of the router, and xxx.xxx.xxx.xxx its management IP. Doing this however still makes it possible to reach the mgmt IP if I have a static route manually, such as
Code: Select all
route add xxx.xxx.xxx.0/24 yyy.yyy.yyy.yyy
Mind you, that enables me to reach xxx.xxx.xxx.xxx only, not the whole management network xxx.xxx.xxx.0/24.
As I want as little firewalling on this router as possible, I was wondering if there is a best practice to make sure that this management interface isn't reachable on the default routing table without using firewalling? I know that I can disable management services from answering on any but the defined management interface, but that still makes it possible to at least ping this management IP from public IPs.
Thanks!