in v6 I used route filters to add "set check gateway" as a dynamic-in filter rule that allowed to check for ping in the automatic routes.
I can't find that option in v7. Is it there on a different location or is it missing that option?
/routing filter
add chain=dynamic-in distance=1 set-check-gateway=ping set-distance=1
/routing filter rule
add chain=dynamic-in comment="101 -> 1 with check-gateway=ping" rule=\
"if (distance == 101) { set distance 1; set gw-check icmp; }"
add chain=dynamic-in comment="102 -> 2 with check-gateway=ping" rule=\
"if (distance == 102) { set distance 2; set gw-check icmp; }"
/ip dhcp-client
add default-route-distance=77 interface="ether8 - ISP2-CM" script=\
":if (\$bound=1) do={\r\
\n /system script run check-gateway\r\
\n :log info \"Setting Check-Gateway ISP2-CM\"\r\
\n}" use-peer-dns=no use-peer-ntp=no
/system script
add dont-require-permissions=no name=check-gateway owner=admin policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="/ip route set [find distance=77] check-gateway=ping"