Hi,
We got this issue when "peers" are in the same network, try to change the /interface wireguard peers > allowed-address=xxx.xxx.xxx.xxx/32 on the router.
You can keep your /ip address of the router with a /24 (for example) so devices can communicate together.
A working configuration:
/interface wireguard
add listen-port=13231 mtu=1420 name=wireguard-server
/interface wireguard peers
add allowed-address=192.168.89.2/32 comment="Device 1" interface=wireguard-server public-key="[YourPublicKey]="
add allowed-address=192.168.89.3/32 comment="Device 2" interface=wireguard-server public-key="[YourPublicKey]="
add allowed-address=192.168.89.4/32 comment="Device 3" interface=wireguard-server public-key="[YourPublicKey]="
add allowed-address=192.168.89.5/32 comment="Device 4" interface=wireguard-server public-key="[YourPublicKey]="
/ip address
add address=192.168.89.1/24 comment="WIREGUARD VPN" interface=wireguard-server
/ip firewall filter
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related hw-offload=yes
add action=accept chain=forward
add action=accept chain=input
add action=accept chain=output
We did the test on top of the default config, so internal network is 192.168.88.0/24 and added VPN network on 192.168.
89.0/24. For the tests, we disabled all default firewall rules and added those, but DON'T DO IT FOR PRODUCTION!
If you want the VPN clients able to talk to internal network (192.168.88.0/24) but not between clients, add this line in firewall:
/ip firewall filter add action=drop chain=forward disabled=yes dst-address=192.168.89.0/24 src-address=192.168.89.0/24
It's a lab and only tests for now, but maybe it can help you.
Best Regards,