*) pppoe - fixed DHCPv6 PD;
This cannot be done as the pppoe client need to be attached to the vlan. If the vlan is put under a bridge, how can the pppoe client connect to its pppoe server?I can confirm that this issue is not fixed on rc5.
but there is a workaround, if you put the vlan interface for the pppoe on a bridge, DHCPv6-PD works
This cannot be done as the pppoe client need to be attached to the vlan. If the vlan is put under a bridge, how can the pppoe client connect to its pppoe server?but there is a workaround, if you put the vlan interface for the pppoe on a bridge, DHCPv6-PD works
Hello you can do like the example below:This cannot be done as the pppoe client need to be attached to the vlan. If the vlan is put under a bridge, how can the pppoe client connect to its pppoe server?
/interface bridge
add name=bridge priority=0x4000
/interface vlan
add interface=bridge mtu=1600 name=WAN_vlan vlan-id=35
/interface pppoe-client
add add-default-route=yes disabled=no interface=WAN_vlan name=PPPoEv4 user=<redacted>
add disabled=no interface=WAN_vlan name=PPPoEv6 user=<redacted>/ipv6
# in case that you have bridge vlan filtering on
/interface bridge vlan
add bridge=bridge comment=WAN_vlan tagged=ether10,bridge vlan-ids=35
I tried your setup but it didn't work. How come you only put a vlan under a bridge interface without any ether interface for the bridge? The bridge itself not physical interface, I am so confuse now.Hello you can do like the example below:This cannot be done as the pppoe client need to be attached to the vlan. If the vlan is put under a bridge, how can the pppoe client connect to its pppoe server?
note that in my case I use two PPPoE connections, one for v4 another for v6
Code: Select all/interface bridge add name=bridge priority=0x4000 /interface vlan add interface=bridge mtu=1600 name=WAN_vlan vlan-id=35 /interface pppoe-client add add-default-route=yes disabled=no interface=WAN_vlan name=PPPoEv4 user=<redacted> add disabled=no interface=WAN_vlan name=PPPoEv6 user=<redacted>/ipv6 # in case that you have bridge vlan filtering on /interface bridge vlan add bridge=bridge comment=WAN_vlan tagged=ether10,bridge vlan-ids=35
I came up with similar solution. And it works.Hello you can do like the example below:This cannot be done as the pppoe client need to be attached to the vlan. If the vlan is put under a bridge, how can the pppoe client connect to its pppoe server?
note that in my case I use two PPPoE connections, one for v4 another for v6
Code: Select all/interface bridge add name=bridge priority=0x4000 /interface vlan add interface=bridge mtu=1600 name=WAN_vlan vlan-id=35 /interface pppoe-client add add-default-route=yes disabled=no interface=WAN_vlan name=PPPoEv4 user=<redacted> add disabled=no interface=WAN_vlan name=PPPoEv6 user=<redacted>/ipv6 # in case that you have bridge vlan filtering on /interface bridge vlan add bridge=bridge comment=WAN_vlan tagged=ether10,bridge vlan-ids=35
Dear joedoelv do you mind sharing your setup for KPN or any hint for fixing MTU? It has been 3 days pulling my hair out to setup dhcp-pd for KPN with no luck..I came up with similar solution. And it works.
The only catch was l2mtu on ports/bridge due to KPN using jumbo pppoe mtu and mru.
/interface bridge
add name=br_wan
/interface bridge port
add bridge=br_wan hw=no interface=ether8
/interface vlan
add interface=br_wan name=vlan_wan vlan-id=6
/ppp profile
set *0 use-ipv6=no
add name=ipv6 use-ipv6=required
/interface pppoe-client
add add-default-route=yes allow=pap disabled=no interface=vlan_wan name=ppoe_wan
add allow=pap disabled=no interface=vlan_wan name=ppoe_wan6 profile=ipv6
/ipv6 dhcp-client
add interface=ppoe_wan6 pool-name=kpn request=prefix
Interface | MTU | L2 MTU
br_wan | 1500 | 1514
vlan_wan | 1500 | 1510
ppoe_wan6 | 1480 | -
I use the following for Bell Canada and it gives me an MTU of 1500:MTU
Code: Select allInterface | MTU | L2 MTU br_wan | 1500 | 1514 vlan_wan | 1500 | 1510 ppoe_wan6 | 1480 | -
Interface | MTU | L2 MTU
ether1 | 1520 | 1534
br_wan | 1520 | 1534
pppoe-out1 | no value set (default)
/ipv6 dhcp-client add add-default-route=yes comment="IPv6 myISP" interface=pppoe-out1 pool-name= IPv6-myISP-pool1 request=prefix use-peer-dns=no
/ipv6 address add comment="IPv6 myISP" from-pool=IPv6-myISP-pool1 interface=bridge
I tried this method but my DHCPv6-PD still on searching. Using latest stable v7.1.1 version.
This cannot be done as the pppoe client need to be attached to the vlan. If the vlan is put under a bridge, how can the pppoe client connect to its pppoe server?
Create (another) bridge, add physical interface to it as tagged bridge port, set bridge interface as tagged member of same VLAN, create corresponding VLAN interface and set pppoe client to use this VLAN interface. Or set bridge interface with PVID set to VLAN ID, set bridge interface as untagged member port of said VLAN and set pppoe client to use bridge interface (as it's untagged already).
Make sure you explicitly disable HW offloading for this bridge ... there's nothing to offload in this case since all traffic will have to pass (slow) CPU anyway.
As far as the erroneous insertion of DSCP flags on VLAN interfaces (which I believe is underlying this issue) is concerned I have confirmation from Mikrotik that the issue will be fixed but that there is no committed timeline for when this will happen.Anyone have any information on whether this issue will be resolved in upcoming firmwares or not?
Thanks for the updateAs far as the erroneous insertion of DSCP flags on VLAN interfaces (which I believe is underlying this issue) is concerned I have confirmation from Mikrotik that the issue will be fixed but that there is no committed timeline for when this will happen.Anyone have any information on whether this issue will be resolved in upcoming firmwares or not?
Yes. If you tag on an external device, in my case on a CRS317, things work.0) Is it possible to try setup without VLAN? Does it work then?
Problem came up about half a year ago. SUP-59296 is a good start.2) and support output file from router, that has dhcp,debug logs and increased memory-lines for memory topic.
Thanks, great news!Thank you very much for the report. We found out the issue, that some VLAN packets are not processed correctly. We are working on the fix for the issue.
Is this the fix for the issue?Thank you very much for the report. We found out the issue, that some VLAN packets are not processed correctly. We are working on the fix for the issue.
*) vlan - fixed improper VLAN priority addition for routed packets;
Doesn't seem so, still broken here with 7.2rc2Is this the fix for the issue?Thank you very much for the report. We found out the issue, that some VLAN packets are not processed correctly. We are working on the fix for the issue.
7.2rc2/rc3 changelog:*) vlan - fixed improper VLAN priority addition for routed packets;
Doesn't seem so, still broken here with 7.2rc2
Is this the fix for the issue?
7.2rc2/rc3 changelog:
Doesn't seem so, still broken here with 7.2rc2
It is definitely going to be fixed in v7.2 lol. Don't expect they will fix prior to version 7.1.xDoesn't look like its fixed in 7.1.2
Lol yeah deep down I knew that, hopefully it is fixed in v7.2 (so far the RC's haven't been very promising)It is definitely going to be fixed in v7.2 lol. Don't expect they will fix prior to version 7.1.xDoesn't look like its fixed in 7.1.2
On 7.1.3 my issue with set priorytet is fixed now. Everything is working now perfect.In my case (IPv4-DHCP Client - searching) Mikrotik support diagnosed that it is a problem with "non-working bridge filter rules". Priority cannot be set.
Unfortunately They cannot provide any time estimates when fix will be available.
I have seen duplicated pppoe clients on proposed workaround, one for IPv4 and one for IPv6. Is It really necesary to perform such split when IPv4 pppoe os working fine?Or set bridge interface with PVID set to VLAN ID, set bridge interface as untagged member port of said VLAN and set pppoe client to use bridge interface (as it's untagged already).
Is the fix expected to land in 7.2 somewhere?Thank you very much for the report. We found out the issue, that some VLAN packets are not processed correctly. We are working on the fix for the issue.
I did not get the proposed solution working for with vlan on a bridge device, and DHCPv6-PD over pppoe. I do now use a spare RB941-2nD as switch to translate VLAN 7 tagged on one port to plain Ethernet without VLAN tag on an other port in front of the RB5009. DHCPv6-PD works now on the RB5009, if i do PPPoE on an ether-interface.On v7.1.3 I still have the issue with DHCPv6-PD over pppoe tagged lan, does anyone has an export example for the following earlier proposed workaround?I have seen duplicated pppoe clients on proposed workaround, one for IPv4 and one for IPv6. Is It really necesary to perform such split when IPv4 pppoe os working fine?Or set bridge interface with PVID set to VLAN ID, set bridge interface as untagged member port of said VLAN and set pppoe client to use bridge interface (as it's untagged already).
Thanks in advance
No there is no news yet, we are all patiently waiting for it to be resolved & no it is currently not fixed in 7.2rc4Any news on this topic, is it already fixed in 7.2rc4?
What is the status of this issue? If we have high level 3 steps: 1. analysing and understanding, 2. fixing & testing, 3. Fix to an rc version?
Where is this issue now? Is there any timeline to share when this will be fixed?
Any update?Thank you very much for the report. We found out the issue, that some VLAN packets are not processed correctly. We are working on the fix for the issue.
Can anyone confirm that this version fixes the issue?*) ipv6 - fixed VLAN tagged PPPoE packet receiving on RB5009;
I will check later tonight, and report back.I found this line in the 7.2rc5 changelog:Can anyone confirm that this version fixes the issue?*) ipv6 - fixed VLAN tagged PPPoE packet receiving on RB5009;
/interface bridge
add ingress-filtering=no name=bridge vlan-filtering=yes
/interface bridge port
add bridge=bridge interface=ether5-ONT pvid=999
add bridge=bridge interface=e-sfp-CRS305
/interface bridge vlan
add bridge=bridge tagged=e-sfp-CRS305,ether5-ONT,bridge vlan-ids=35
/interface vlan
add interface=bridge mtu=1600 name=WAN_vlan vlan-id=35
/interface pppoe-client
add add-default-route=yes interface=WAN_vlan name=PPPoEv4
add interface=WAN_vlan name=PPPoEv6
/ipv6 dhcp-client
add add-default-route=yes interface=PPPoEv6 pool-name=GUA-pool rapid-commit=no request=prefix use-peer-dns=no
/ppp profile
set *0 use-ipv6=no
add name=ipv6 use-ipv6=required
I have 7.2.1 on wAP R ac, and DHCPv6-PD does not work for me over PPPoE client (no errors, nothing).You should only have one bridge, you separate the networks with a vlan, you can have a lan vlan also under the same bridge.
below you can see how I configured mine, I need to add that I was never affected by this issue, because I always use my wan vlan under the main bridge, for flexibility reasons.