You cannot save a backup of the configuration and load it on another model. But you can export the configuration into a script and run that script on another device regardless its architecture. In order to make it run successfully after configuration reset, you have to modify it a bit, basically it is enough to add a :delay 1m at the beginning, provided that the number of ethernet and WiFi interfaces is the same on both the source and target device.Are there any export of interface that I can do and import them to save time?
Here is the lTAP export, I too am concerned about not having 192.168.88.1 by default, I have tried netinstall several times.You cannot save a backup of the configuration and load it on another model. But you can export the configuration into a script and run that script on another device regardless its architecture. In order to make it run successfully after configuration reset, you have to modify it a bit, basically it is enough to add a :delay 1m at the beginning, provided that the number of ethernet and WiFi interfaces is the same on both the source and target device.Are there any export of interface that I can do and import them to save time?
But from what you say, something is rotten about the LtAP, as in the default configuration, there should indeed be a 192.168.88.1/24 address attached to ether1. What does /export currently show on the LtAP?
Also, what is the /export of the LHG, i.e. do you use LTE passthrough mode or does the LHG act as a router?
The question is how does the default configuration look like in case of 7.1.3 on LtAP.I have tried netinstall several times.
# sep/ 2/2020 3: 9:38 by RouterOS 7.1.3
# software id = ZFR6-6BCM
#
script: #| Welcome to RouterOS!
#| 1) Set a strong router password in the System > Users menu
#| 2) Upgrade the software in the System > Packages menu
#| 3) Enable firewall on untrusted networks
#| 4) Set your country name to observe wireless regulations
#| -----------------------------------------------------------------------------
#| WISP Bridge:
#| * wireless and LAN interfaces are bridged;
#| wlan1 Configuration:
#| mode: ap-bridge;
#| band: 2ghz-b/g/n;
#| tx-chains: 0;1;
#| rx-chains: 0;1;
#| installation: outdoor;
#| wpa2: no;
#| ht-extension: 20/40mhz-XX;
#| LAN Configuration:
#| DHCP Client: enabled on bridge (LAN port);
:global ssid;
:global defconfMode;
:log info "Starting defconf script";
#-------------------------------------------------------------------------------
# Apply configuration.
# these commands are executed after installation or configuration reset
#-------------------------------------------------------------------------------
:if ($action = "apply") do={
# wait for interfaces
:local count 0;
:while ([/interface ethernet find] = "") do={
:if ($count = 30) do={
:log warning "DefConf: Unable to find ethernet interfaces";
/quit;
}
:delay 1s; :set count ($count +1);
};
:local count 0;
:while ([/interface wireless print count-only] < 1) do={
:set count ($count +1);
:if ($count = 40) do={
:log warning "DefConf: Unable to find wireless interface(s)";
/ip address add address=192.168.88.1/24 interface=ether1 comment="defconf";
/quit
}
:delay 1s;
};
/interface wireless {
:local ifcId [/interface wireless find where default-name=wlan1]
:local currentName [/interface wireless get $ifcId name]
set $ifcId mode=ap-bridge band=2ghz-b/g/n disabled=no wireless-protocol=any \
distance=dynamic installation=outdoor
set $ifcId channel-width=20/40mhz-XX;
set $ifcId frequency=auto
:local wlanMac [/interface wireless get $ifcId mac-address];
:set ssid "MikroTik-$[:pick $wlanMac 9 11]$[:pick $wlanMac 12 14]$[:pick $wlanMac 15 17]"
set $ifcId ssid=$ssid
}
/interface bridge
add name=bridge disabled=no auto-mac=yes protocol-mode=rstp comment=defconf;
:local bMACIsSet 0;
:foreach k in=[/interface find where !(slave=yes || name~"bridge")] do={
:local tmpPortName [/interface get $k name];
:if ($bMACIsSet = 0) do={
:if ([/interface get $k type] = "ether") do={
/interface bridge set "bridge" auto-mac=no admin-mac=[/interface get $tmpPortName mac-address];
:set bMACIsSet 1;
}
}
:if (([/interface get $k type] != "ppp-out") && ([/interface get $k type] != "lte")) do={
/interface bridge port
add bridge=bridge interface=$tmpPortName comment=defconf;
}
}
/ip dhcp-client add interface=bridge disabled=no comment="defconf";
}
#-------------------------------------------------------------------------------
# Revert configuration.
# these commands are executed if user requests to remove default configuration
#-------------------------------------------------------------------------------
:if ($action = "revert") do={
/user set admin password=""
/system routerboard mode-button set enabled=no
/system routerboard mode-button set on-event=""
/system script remove [find comment~"defconf"]
/ip firewall filter remove [find comment~"defconf"]
/ipv6 firewall filter remove [find comment~"defconf"]
/ipv6 firewall address-list remove [find comment~"defconf"]
/ip firewall nat remove [find comment~"defconf"]
/interface list member remove [find comment~"defconf"]
/interface detect-internet set detect-interface-list=none
/interface detect-internet set lan-interface-list=none
/interface detect-internet set wan-interface-list=none
/interface detect-internet set internet-interface-list=none
/interface list remove [find comment~"defconf"]
/tool mac-server set allowed-interface-list=all
/tool mac-server mac-winbox set allowed-interface-list=all
/ip neighbor discovery-settings set discover-interface-list=!dynamic
:local o [/ip dhcp-server network find comment="defconf"]
:if ([:len $o] != 0) do={ /ip dhcp-server network remove $o }
:local o [/ip dhcp-server find name="defconf" !disabled]
:if ([:len $o] != 0) do={ /ip dhcp-server remove $o }
/ip pool {
:local o [find name="default-dhcp" ranges=192.168.88.10-192.168.88.254]
:if ([:len $o] != 0) do={ remove $o }
}
:local o [/ip dhcp-client find comment="defconf"]
:if ([:len $o] != 0) do={ /ip dhcp-client remove $o }
/ip dns {
set allow-remote-requests=no
:local o [static find comment="defconf"]
:if ([:len $o] != 0) do={ static remove $o }
}
/ip address {
:local o [find comment="defconf"]
:if ([:len $o] != 0) do={ remove $o }
}
:foreach iface in=[/interface ethernet find] do={
/interface ethernet set $iface name=[get $iface default-name]
}
/interface bridge port remove [find comment="defconf"]
/interface bridge remove [find comment="defconf"]
/interface bonding remove [find comment="defconf"]
/interface wireless cap set enabled=no interfaces="" caps-man-addresses=""
/interface wireless reset-configuration wlan1
/interface wireless security-profile set default mode=none\
authentication-types="" disable-pmkid=no wpa2-pre-shared-key="" comment=""
/caps-man manager set enabled=no
/caps-man manager interface remove [find comment="defconf"]
/caps-man manager interface set [ find default=yes ] forbid=no
/caps-man provisioning remove [find comment="defconf"]
/caps-man configuration remove [find comment="defconf"]
}
:log info Defconf_script_finished;
:set defconfMode;
:set ssid;
caps-mode-script: #-------------------------------------------------------------------------------
# Note: script will not execute at all (will throw a syntax error) if
# dhcp or wireless-fp packages are not installed
#-------------------------------------------------------------------------------
#| CAP configuration
#|
#| Wireless interfaces are set to be managed by CAPsMAN.
#| All ethernet interfaces and CAPsMAN managed interfaces are bridged.
#| DHCP client is set on bridge interface.
# bridge port name
:global brName "bridgeLocal";
:global logPref "defconf:";
:global action;
:log info $action
:if ($action = "apply") do={
# wait for ethernet interfaces
:local count 0;
:while ([/interface ethernet find] = "") do={
:if ($count = 30) do={
:log warning "DefConf: Unable to find ethernet interfaces";
/quit;
}
:delay 1s; :set count ($count + 1);
}
:local macSet 0;
:local tmpMac "";
:foreach k in=[/interface ethernet find] do={
# first ethernet is found; add bridge and set mac address of the ethernet port
:if ($macSet = 0) do={
:set tmpMac [/interface ethernet get $k mac-address];
/interface bridge add name=$brName auto-mac=no admin-mac=$tmpMac comment="defconf";
:set macSet 1;
}
# add bridge ports
/interface bridge port add bridge=$brName interface=$k comment="defconf"
}
# try to add dhcp client on bridge interface (may fail if already exist)
:do {
/ip dhcp-client add interface=$brName disabled=no comment="defconf"
} on-error={ :log warning "$logPref unable to add dhcp client";}
# try to configure caps (may fail if for example specified interfaces are missing)
:local interfacesList "";
:local bFirst 1;
# wait for wireless interfaces
:while ([/interface wireless find] = "") do={
:if ($count = 30) do={
:log warning "DefConf: Unable to find wireless interfaces";
/quit;
}
:delay 1s; :set count ($count + 1);
}
# delay just to make sure that all wireless interfaces are loaded
:delay 5s;
:foreach i in=[/interface wireless find] do={
if ($bFirst = 1) do={
:set interfacesList [/interface wireless get $i name];
:set bFirst 0;
} else={
:set interfacesList "$interfacesList,$[/interface wireless get $i name]";
}
}
:do {
/interface wireless cap
set enabled=yes interfaces=$interfacesList discovery-interfaces=$brName bridge=$brName
} on-error={ :log warning "$logPref unable to configure caps";}
}
:if ($action = "revert") do={
:do {
/interface wireless cap
set enabled=no interfaces="" discovery-interfaces="" bridge=none
} on-error={ :log warning "$logPref unable to unset caps";}
:local o [/ip dhcp-client find comment="defconf"]
:if ([:len $o] != 0) do={ /ip dhcp-client remove $o }
/interface bridge port remove [find comment="defconf"]
/interface bridge remove [find comment="defconf"]
}
custom-script:
/ip/dhcp-client/disable [find interface~"bridge"]
/interface/bridge/port/enable [find interface=ether1]
/interface/list/member/remove [/interface/list/member/find list=WAN interface=ether1]
Unfortunately, what I copied and pasted is all that is there after a rest and after netinstall... it's weird. I built it up and manually added IP and DHCP values etc. Got internet working and did a full back up. Decided to do a fresh netinstall and restore the backup but again no IP or access unless I used winbox mac address. LTE not in the drop down list. Eventually after adding it all back manually the QuickSet now shows LTE options. I just wanted to see if this is normal LtAP behavior or if mine is goofy right out of the box.The question is how does the default configuration look like in case of 7.1.3 on LtAP.I have tried netinstall several times.
/system/default-configuration/print file=defconf will place the default configuration script into a file named defconf.txt, which you can download and inspect.
Other than that, what if you do /ip/address/add address=192.168.88.1/24 interface=bridge and assign some other address from 192.168.88.0/24 to your PC manually, will you be able to login via IP address rather than MAC address?
Can I just add the script you posted to mine?@sindy, I think this thread is a continuation of viewtopic.php?t=182960 ...
The default configuration is really just those lines on the LtAP, it starts as the "WISP AP" default it seems
But I can see the confusion here. Looking at the QuickSet profiles, none support LTE. While most LTE RBs have either "LTE AP" or "LTE" as a QuickSet profiles. BUT despite the LtAP having SIM slots, it does not have any LTE-based QuickSet profiles...
You could try the "Home AP" mode, that will get you a Wi-Fi network with a LAN to test the LTE part. But you'd have change ether1 by removing the /ip/dhcp-client on ether1, and adding ether1 to the /interface/bridge/port
I grabbed the 7.1.3 output of the /system/default-config from an LtAP at 7.1.3 here:
That's why I've suggested you to dump the default configuration script and see whether it adds the IP address etc. Since you can add all that manually, the hardware is not broken. Hence the most likely thing is a suboptimal contents of the default configuration script in the 7.1.3 package for the mmips architecture.I just wanted to see if this is normal LtAP behavior or if mine is goofy right out of the box.
Where can I get a good known working copy of 7.1.3 then? I obtained mine from MikrTik's website.That's why I've suggested you to dump the default configuration script and see whether it adds the IP address etc. Since you can add all that manually, the hardware is not broken. Hence the most likely thing is a suboptimal contents of the default configuration script in the 7.1.3 package for the mmips architecture.I just wanted to see if this is normal LtAP behavior or if mine is goofy right out of the box.
I don't say it broke during download. If it indeed doesn't set the items you're missing, it has been broken in development.Where can I get a good known working copy of 7.1.3 then? I obtained mine from MikrTik's website.
It more the default config is different than the LHRG etc, thus why the OP is having issues since the default isn't just working.... The LtAP default uses a bridge with a DHCP client, both ether1 and wlan1 are part of the bridge, with no /ip/address (e.g. default is DHCP from ether1). That seem the V7 defaults in both 7.1.3 and rc7.2rc4.That's why I've suggested you to dump the default configuration script and see whether it adds the IP address etc. Since you can add all that manually, the hardware is not broken. Hence the most likely thing is a suboptimal contents of the default configuration script in the 7.1.3 package for the mmips architecture.I just wanted to see if this is normal LtAP behavior or if mine is goofy right out of the box.
Look into the default configuration script of 7.1.3 as posted by @Amm0 in this post. It sets exactly what OP is getting. No point in spawning it over and over again, the result will be the same.I would suggest you to reset to defaults, then upgrade to 7.1.3 and test again...
How can I grab the 7.1.3 output of the /system/default-config from my LtAP?Mikrotik help page on "Default Configuration" has a clue on what's going on here. See https://help.mikrotik.com/docs/display/ ... igurations
If the LtAP comes without any Mikrotik LTE modems install, comes to the "WISP Bridge" configuration. While LtAP that come with Mikrotik LTE modems (e.g. "4G kit", etc), default to "LTE CPE AP Router".
But all the LtAP should still at least have the same potential alternative defaults in QuickSet IMO. But regardless, if you apply the "Home AP" configuration from the screensoot, then paste in the 5 config lines, it should works the same as the "LTE CPE AP Router" config "flavor" that be on LHGG/SXT/wAP/etc.
Obviously if you reset to defaults or do netinstall, any QuickSet or other configuration will be lost & you'll be back the "WISP Bridge" mode.
@sindy i installed a LTAP LTE6 this week.Look into the default configuration script of 7.1.3 as posted by @Amm0 in this post. It sets exactly what OP is getting. No point in spawning it over and over again, the result will be the same.I would suggest you to reset to defaults, then upgrade to 7.1.3 and test again...
The way I've suggested above. But you don't need to do that - @Amm0 has already posted the result a few posts earlier.How can I grab the 7.1.3 output of the /system/default-config from my LtAP?
As @Amm0 wrote above, there is a difference between the default configuration script of an LtAP "LTE(6) kit" (where the LTE modem is pre-installed by Mikrotik) and the default configuration script of a bare LtAP shipped without any LTE modem.@sindy i installed a LTAP LTE6 this week.
I noticed nothing strange compared to other MikroTIK LTE devices i' ve used ( WAP, WAP LTE6, LHGG,) as far as the configuration is concerned .
Actually now I'm wondeing where can I get the default configurations from? I could just load them if I had them, right?Mikrotik help page on "Default Configuration" has a clue on what's going on here. See https://help.mikrotik.com/docs/display/ ... igurations
If the LtAP comes without any Mikrotik LTE modems install, comes to the "WISP Bridge" configuration. While LtAP that come with Mikrotik LTE modems (e.g. "4G kit", etc), default to "LTE CPE AP Router".
But all the LtAP should still at least have the same potential alternative defaults in QuickSet IMO. But regardless, if you apply the "Home AP" configuration from the screensoot, then paste in the 5 config lines, it should works the same as the "LTE CPE AP Router" config "flavor" that be on LHGG/SXT/wAP/etc.
Obviously if you reset to defaults or do netinstall, any QuickSet or other configuration will be lost & you'll be back the "WISP Bridge" mode.
ok @sindy, i see your point... My first step always when logging in to a new device is reset to no defaults, so i don't really look what the defaults are or not...As @Amm0 wrote above, there is a difference between the default configuration script of an LtAP "LTE(6) kit" (where the LTE modem is pre-installed by Mikrotik) and the default configuration script of a bare LtAP shipped without any LTE modem.@sindy i installed a LTAP LTE6 this week.
I noticed nothing strange compared to other MikroTIK LTE devices i' ve used ( WAP, WAP LTE6, LHGG,) as far as the configuration is concerned .
I think the OP has an SXT and/or LHGG, and guessing the defaults "just worked" out-of-the-box of those. While he set the APN, t-mobile doesn't care so good chance those unit work if you just put in a SIM card. No config required .ok @sindy, i see your point... My first step always when logging in to a new device is reset to no defaults, so i don't really look what the defaults are or not...
Then a reset to no-defaults and step by step configuration with no quickset...
Kind of, with the sxt and LHG all I did was change the APN after allowing the default suggested config to be applied.I think the OP has an SXT and/or LHGG, and guessing the defaults "just worked" out-of-the-box of those. While he set the APN, t-mobile doesn't care so good chance those unit work if you just put in a SIM card. No config required .ok @sindy, i see your point... My first step always when logging in to a new device is reset to no defaults, so i don't really look what the defaults are or not...
Then a reset to no-defaults and step by step configuration with no quickset...
Just a guess here, be curious to confirm if that was @cascom experience?
Everyone has been so helpful and the config tips get me going however, defaulting and resetting and netinstalls all get me back to my same problem... the device only offers a MAC address in Winbox, it won't ever get to 192.168.88.1 as all other MikroTik devices I have worked with. Should I be concerned about that?Here https://help.mikrotik.com/docs/display/ ... tupexample you can see the APN configuration...
Then, in a simple Router setup, create a Bridge and add the ether1 and wlan interfaces as ports, set an IP address to the Bridge interface e.g. 192.168.1.1/24, create a DHCP server on the Bridge interface, set a DNS server and allow remote requests and masquerade your LTE interface...
The above configuration should give you access to the internet from a Client PC...
Ofcorse you need to setup your Firewall...
https://help.mikrotik.com/docs/display/ ... t+Firewall
My suggestion would be to reset to no defaults and try configure step by step your device...
No.Everyone has been so helpful and the config tips get me going however, defaulting and resetting and netinstalls all get me back to my same problem... the device only offers a MAC address in Winbox, it won't ever get to 192.168.88.1 as all other MikroTik devices I have worked with. Should I be concerned about that?Here https://help.mikrotik.com/docs/display/ ... tupexample you can see the APN configuration...
Then, in a simple Router setup, create a Bridge and add the ether1 and wlan interfaces as ports, set an IP address to the Bridge interface e.g. 192.168.1.1/24, create a DHCP server on the Bridge interface, set a DNS server and allow remote requests and masquerade your LTE interface...
The above configuration should give you access to the internet from a Client PC...
Ofcorse you need to setup your Firewall...
https://help.mikrotik.com/docs/display/ ... t+Firewall
My suggestion would be to reset to no defaults and try configure step by step your device...
I think it must know from some hardware id someplace it's the "LtAP without modems". This is MAYBE what's guiding what ROS is using for defaults. So not sure how to trick it get different defaults.Do you think an LtAP with a MODEM from factory will behave different after netinstalls done to it as well or am I off there?
Well, the LtAP is not quite a home device nor an enterprise device, it is middle... And you have one that, by default, has no modems. So Mikrotik has to pick something as a default to ship on it. Now they assume the more common case for a device with 3 SIM slots is as a 2.4Ghz Wi-Fi repeater, even though it has only pretty underpowered internal antennas for Wi-Fi. That's a questionable call IMO, but argueable not a "bug"Are we still saying the file from MikroTik is just missing a few basics?
Can you please /export hide-sensitive the configuration you have after reset to no defaults was made ?Everyone has been so helpful and the config tips get me going however, defaulting and resetting and netinstalls all get me back to my same problem...
# mar/18/2022 18:25:22 by RouterOS 7.1.3Can you please /export hide-sensitive the configuration you have after reset to no defaults was made ?Everyone has been so helpful and the config tips get me going however, defaulting and resetting and netinstalls all get me back to my same problem...
ip firewall/nat/add chain=srcnat out-interface-list=WAN action=masquerade
ip address/add address=192.168.1.1/24 interface=Bridge
@cascom, that actually just the default configuration, NOT the no-default=yes version. @Zacharias was suggesting using:
Can you please /export hide-sensitive the configuration you have after reset to no defaults was made ?
/system reset-configuration no-defaults=yes keep-users=yes
Thank you for that, also @ammo and the rest have been great... ended up making an RMA as more issue continued. Random reboots, wifi drops and general loss of connection thru winbox after sitting for a while. I will post updates when I get the nnew LtAP, maybe I'll ge tit with a MODEM pre-installed.ether1 is not your WAN port... lte1 is your WAN port...
So remove ether1 from the WAN list and add your lte interface...
Also i see no masquerade rule for your LTE interface...
No IP address assignment on your Bridge and no DHCP servers...Code: Select allip firewall/nat/add chain=srcnat out-interface-list=WAN action=masquerade
e.g.Code: Select allip address/add address=192.168.1.1/24 interface=Bridge
Your LHGG has a default configuration that just works with LTE and creates LAN on ether1. The issue here is NO default configuration is going to do that on the LtAP version you have. So basically you're going to have tackle on the LtAP, one way or another.
I have now done this on 3 different brand new LtAP units and all behave same or worse.
The main symptoms I have narrowed down are none of them will stay accessible via the ethernet port, this issue is by far the worst. I can get service up and running on the internet but after a reboot I sometimes lose the ability to communicate via winbox unless I go wifi. When I ethernet I regularly lose internet connection but again on wifi it's fine.
In some random cases the the device loses the LTE quickset options from the drop down menu.
If I leave it alone and don;t use the Ethernet port then the system is stable, I just can't rely on it... I don't want to deploy for wifi applications only (I need the eth1 to work fully)
What are you seeing in the logs? If it's a crash, that explain "losing a port". M/R/STP could also explain ports going "dead"...are the LtAP plugged into a larger network switch (e.g. a cisco etc with bpdu-guard enable)?Your LHGG has a default configuration that just works with LTE and creates LAN on ether1. The issue here is NO default configuration is going to do that on the LtAP version you have. So basically you're going to have tackle on the LtAP, one way or another.
I have now done this on 3 different brand new LtAP units and all behave same or worse.
The main symptoms I have narrowed down are none of them will stay accessible via the ethernet port, this issue is by far the worst. I can get service up and running on the internet but after a reboot I sometimes lose the ability to communicate via winbox unless I go wifi. When I ethernet I regularly lose internet connection but again on wifi it's fine.
In some random cases the the device loses the LTE quickset options from the drop down menu.
If I leave it alone and don;t use the Ethernet port then the system is stable, I just can't rely on it... I don't want to deploy for wifi applications only (I need the eth1 to work fully)
I am on 7.2 both OS and firmwareI'd also recommend trying 7.2. It has a lot of LTE fixes over any of the 7.1.x versions.
/ip dhcp-server network
add address=0.0.0.0/24 gateway=0.0.0.0
Release and renew of my PC NIC fixes getting internet and so does Rebooting power to the Router I plug into the LtAP - just had not seen that needed on my other TiksYou might try deleting an extra IP/dhcp—server/network that quickset must have created:
Should not be there. You can safely delete it. Not sure that explain port drops.Code: Select all/ip dhcp-server network add address=0.0.0.0/24 gateway=0.0.0.0
Other than that your config looks like it should have LTE internet on WiFi or Ethernet1…
Updating an LTAP on 7.2.1, the ROS update was successfulI'd also recommend trying 7.2. It has a lot of LTE fixes over any of the 7.1.x versions.