Hello,
I just upgraded ROS from 6.49.5 to 7.2 and remote management to WAN doesnt work anymore. Did anything change? I have enabled port 8291 in Firewall and it is locked down to 3 networks I am accesing it from.
# apr/12/2022 13:44:16 by RouterOS 7.2
# software id = 4VLT-G4K3
#
# model = RBD53iG-5HacD2HnD
# serial number = F34E0F6BD6E0
/interface bridge
add admin-mac=DC:2C:6E:13:6C:13 auto-mac=no name=bridge
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX \
disabled=no distance=indoors frequency=auto installation=indoor mode=\
ap-bridge ssid=ap-snkfd wireless-protocol=802.11
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=\
20/40/80mhz-XXXX disabled=no distance=indoors frequency=auto \
installation=indoor mode=ap-bridge ssid=ap-snkfd wireless-protocol=\
802.11
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface lte apn
set [ find default=yes ] ip-type=ipv4 use-network-apn=no
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods="" \
mode=dynamic-keys supplicant-identity=MikroTik
/ip pool
add name=dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=dhcp interface=bridge name=defconf
/interface bridge port
add bridge=bridge comment=defconf ingress-filtering=no interface=ether2
add bridge=bridge comment=defconf ingress-filtering=no interface=ether3
add bridge=bridge comment=defconf ingress-filtering=no interface=ether4
add bridge=bridge comment=defconf ingress-filtering=no interface=ether5
add bridge=bridge comment=defconf ingress-filtering=no interface=wlan1
add bridge=bridge comment=defconf ingress-filtering=no interface=wlan2
/ip neighbor discovery-settings
set discover-interface-list=LAN
/ipv6 settings
set max-neighbor-entries=8192
/interface list member
add interface=bridge list=LAN
add interface=ether1 list=WAN
/interface ovpn-server server
set auth=sha1,md5
/ip address
add address=192.168.88.1/24 interface=bridge network=192.168.88.0
/ip dhcp-client
add comment=defconf interface=ether1
/ip dhcp-server network
add address=192.168.88.0/24 gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment="mikrotik remote management" dst-port=\
8291 protocol=tcp
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
"defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related hw-offload=yes
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface-list=WAN
add action=dst-nat chain=dstnat comment="snkfd-srv ssh" in-interface=\
ether1 protocol=tcp to-addresses=192.168.88.234 to-ports=22
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
set api disabled=yes
set winbox address=192.168.88.0/24,10.78.146.0/23,10.78.128.0/23,10.77.8.0/23
set api-ssl disabled=yes
/ipv6 address
add address=::1 from-pool=pf interface=bridge
/ipv6 dhcp-client
add add-default-route=yes interface=ether1 pool-name=pf request=\
address,prefix
/ipv6 nd
set [ find default=yes ] ra-interval=20s-1m
add interface=bridge ra-interval=20s-1m
/system clock
set time-zone-name=Europe/Prague
/system leds
set 0 interface=wlan1 leds=led1,led2,led3,led4,led5 type=\
wireless-signal-strength
set 1 leds=poe-led type=poe-out
/system package update
set channel=testing
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
/ip firewall filter
add action=accept chain=input comment="mikrotik remote management" dst-port=\
8291 protocol=tcp
/ip service
set winbox address=192.168.88.0/24,10.78.146.0/23,10.78.128.0/23,10.77.8.0/23
Yeah, of course. Network behind NAT, internal network and two networks where VPN is (both VPN IPs are fixed, so having enabled two more networks might be too much, but whatever..) I am getting inside exclusively just through VPN hosted in private network.All of the IPs on your "set winbox address" line are RFC 1918 private subnets.
Huh? Pardon me, I am confused. I think it has nothing to do with that. And it doesnt really matter if I use or dont use VPN.And only now you say "I use VPN"???????
Network behind NAT
it doesnt really matter if I use or dont use VPN.
Not if you're making use of that firewall rule on line 55, which allows direct connection to port 8291 from the WAN side. To make that usable, you'd have to put your WAN IP into the address list I pointed out.
It does if your VPN IP address is in the winbox address list but your public IP is not.
I am testing from 2 different locations with "debug" enabled. Nothing shows up in the log. Winbox just says ERROR: Router refused connection.According to this rule there is no restriction on IP address, so it should be open for everyone.
You might want to activate logging to be able to do some debugging.
Are you testing from another location?Code: Select all/ip firewall filter add action=accept chain=input comment="mikrotik remote management" dst-port=\ 8291 protocol=tcp
Dont think, instead - PROVIDE missing information. There is something not clear on your VPN and how you access this router externally that is not well understood.Huh? Pardon me, I am confused. I think it has nothing to do with that. And it doesnt really matter if I use or dont use VPN.And only now you say "I use VPN"???????
My suggestion for this rule is as follows:The llama has arrived......
......
add chain=input action=accept in-interface-list=Trusted dst-port=winboxport protocol=tcp src-address-list=authorized
Dont think, instead - PROVIDE missing information. There is something not clear on your VPN and how you access this router externally that is not well understood.
Huh? Pardon me, I am confused. I think it has nothing to do with that. And it doesnt really matter if I use or dont use VPN.
A diagram may help.
If you knew all the answers you wouldnt be asking for help, so help us help you by not making assumptions of what is or isnt relevant!!
Well its better than it was before, but also I prefer clear direct targettng and thus do not like any use of ! symbol unless absolutely necessary.My suggestion for this rule is as follows:The llama has arrived......
......
add chain=input action=accept in-interface-list=Trusted dst-port=winboxport protocol=tcp src-address-list=authorized
add chain=input action=accept in-interface-list=!WAN dst-port=8291 protocol=tcp src-address-list=Trusted
Why, to accept Winbox from everywhere except WAN for VPN specifically ... for the admin this IMO scales far better and prevents WAN exploits.
This way the port for Winbox can remain the default.
On further inspections. DISAGREE WITH WINBOX Port staying as default, CHANGE IT should be the automatic admin action!!!My suggestion for this rule is as follows:The llama has arrived......
......
add chain=input action=accept in-interface-list=Trusted dst-port=winboxport protocol=tcp src-address-list=authorized
add chain=input action=accept in-interface-list=!WAN dst-port=8291 protocol=tcp src-address-list=Trusted
Why, to accept Winbox from everywhere except WAN for VPN specifically ... for the admin this IMO scales far better and prevents WAN exploits.
This way the port for Winbox can remain the default.