I've been trying many different things and its not seems to be working traffic still goes to the best route and not out of specific gateway.
I marked the connections and marked the traffic with src-address and still no good I see it uses mac of wan2 instead of wan1.
Here is my set up 10 ports 1 and 2 are WAN's, 3-10 are bridged as are my 2 wlans.
so all LAN traffic is in BRIDGE.
I need some IP's from the LAN traffic to go through WAN1 where at WAN2 is the default.
Please help by posting a working configuration.
Code: Select all
[@gateway1] /ip firewall mangle>
25 ;;; ECMP
chain=input action=mark-connection new-connection-mark=frontier_conn in-interface=ether1
26 ;;; ECMP
chain=input action=mark-connection new-connection-mark=xfinity_conn in-interface=ether2
27 ;;; ECMP
chain=output action=mark-routing new-routing-mark=to_frontier connection-mark=frontier_conn
28 ;;; ECMP
chain=output action=mark-routing new-routing-mark=to_xfinity connection-mark=xfinity_conn
[@gateway1] /ip firewall mangle> /ip route print where !disabled
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
0 A S ;;; to_frontier
0.0.0.0/0 x.x.x.x 1
1 A S ;;; to_xfinity
0.0.0.0/0 x.x.x.x 1
2 A S ;;; ECMP_xfinity_frontier
0.0.0.0/0 x.x.x.x 1
x.x.x.x
x.x.x.x
[@gateway1] /ip firewall nat> print where !disabled
Flags: X - disabled, I - invalid, D - dynamic
2 chain=srcnat action=masquerade out-interface=ether1
3 chain=srcnat action=masquerade out-interface=ether2
[@gateway1] /interface bridge port> export
# apr/10/2022 23:53:53 by RouterOS 6.48.4
# software id = NUTA-4YVB
#
# model = RB4011iGS+5HacQ2HnD
# serial number = F03C0EEDBD0B
/interface bridge port
add bridge=bridge interface=ether3
add bridge=bridge interface=ether4
add bridge=bridge interface=ether6
add bridge=bridge interface=ether7
add bridge=bridge interface=ether8
add bridge=bridge interface=ether9
add bridge=bridge interface=ether10
add bridge=bridge interface=sfp-sfpplus1
add bridge=bridge interface=wlan1
add bridge=bridge interface=wlan2
add bridge=bridge interface=ether5
I want LAN ip of 192.168.1.38 to go out of WAN1 ONLY never to use WAN2. Can this be achieved. I want to see the MAC between it and WAN2 in the sniffer, how can this be achieved?
Thank you for your help!