Actually it's not that complicated either ... it's different than IPv4 indeed so one has to learn a few things anew.I wish IPV6 was as simple and easy as IPV4!
Thanks for your response.Post the config, parts /ipv6 address, /ipv6 route and /ipv6 dhcp-client (or whatever method is used by ISP to dekegate you tge prefix).
Worst part for me about IPv6 is that the IP addresses themselves are not easy to read or memorize. The simplicity of IPv4 address numbering and subnetting is part of what makes networking logical and fun for me. I actually see this as a major design flaw of IPv6, so much so that I don't think IPv6 will ever defeat IPv4 in mainstream networks. Something else will come along before that can ever happen. Just my prediction (but I hope I am right). It's unfortunate that IPv4 quantities are so finite/limited because apart from that, I see no reason to have an entirely new IP numbering standard. TL;DR? IPv6 sucks.I wish IPV6 was as simple and easy as IPV4!
/ipv6 address
add address=::1/64 from-pool=mypool interface=LAN1
add address=::1/64 from-pool=mypool interface=LAN2
...
Solution would be if RouterOS accepted hints, e.g. addresses like ::1:0:0:0:1/64, ::2:0:0:0:1/64. They could be combined with prefix, and you'd always get xxxx:xxxx:xxxx:xx01::1/64 and xxxx:xxxx:xxxx:xx02::1/64. Unfortunately, it's currently not supported.
Sorry for my misunderstanding:I was hoping to see output of export command ... print shows running config but there are number of ways to get there ...
It is like I wrote above: it does not ensure it, in theory it might go wrong, but in practice it works right. That is, the local networks get a subnet address out of the obtained pool in the sequence they have been added (and which is the sequence they are listed when exporting /ipv6 address).@pe1chl: OP's settings don't ensure that same /64 prefix is used on same subnet after router reboots (given that prefix delegated by ISP doesn't change). It doesn't happen often, but it can happen.
When that is the cause, it is probably also sufficient to remove the EUI-64 option and set the address to ::1 which would also be easier to remember.There's one possible problem with bridges I found. If bridge has default config that takes MAC address from one of ports, it can change as ports are added, removed, disabled or enabled. And when it happens, it triggers prefix change and it gets new one every time. It can be prevented by manually setting admin-mac=xx:xx:xx:xx:xx:xx for bridge.
In general I cannot find much about adding a server to MikroTik equipment with IPv6 on the internet. It must be quite new to the community.
/ipv6 address
add interface=privateBridge address=::1/64 from-pool="IPv6 Prefix" advertise=yes
/ipv6 pool add
name=test60 prefix=2001:db8:8584:890::/60 prefix-length=64
/ipv6 address
add address=::1/64 from-pool=test60 interface=test1
add address=::1/64 from-pool=test60 interface=test2
add address=::1/64 from-pool=test60 interface=test3
ipv6 address print
Flags: I, D - DYNAMIC; G, L - LINK-LOCAL
Columns: ADDRESS, FROM-POOL, INTERFACE, ADVERTISE
# ADDRESS FROM-POOL INTERFACE ADVERTISE
...
19 G 2001:db8:8584:890::1/64 test60 test1 yes
20 G 2001:db8:8584:891::1/64 test60 test2 yes
21 G 2001:db8:8584:892::1/64 test60 test3 yes
/ipv6 address
add address=2001:db8:1::1 advertise=no disabled=yes interface=test1
add address=::1/64 from-pool=test60 interface=test1
ipv6/address/print
Flags: X, I, D - DYNAMIC; G, L - LINK-LOCAL
Columns: ADDRESS, FROM-POOL, INTERFACE, ADVERTISE
# ADDRESS FROM-POOL INTERFACE ADVERTISE
...
19 XG 2001:db8:1::1/64 test1 no
20 G 2001:db8:8584:890::1/64 test60 test1 yes
21 DG 2001:db8:8584:890::1/64 test1 no
/ipv6 address add interface=test1 address=fe80::dead:beef:0001/64
/ipv6 pool add name="ipv6-pool" prefix=fe80::/16 prefix-length=64
/ipv6 address add interface=test1 address=::dead:beef:1/24 from-pool="ipv6-pool"