Nothing like a slovakian lovefest!
Regardless if nothing has happened, it only takes one incident to ruin ones life, what MKX is suggesting is common sense and prudent firewall rules, that are easy to implement and that ALSO include your blocking strategy by default.
THis is a stock setup that keeps the required default rules and keep access to the router, solely to the admin and blocks all traffic except that specifically permitted.
/ip firewall address-list
add address=admin-IP1 list=Authorized
add address=admin-IP2 list=Authorized
{ etc....... }
/ip firewall filter
{Input Chain}
(default rules to keep)
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment="defconf: accept to local loopback:" dst-address=127.0.0.1
(user rules)
add action=accept chain=input src-address-list=Admin
add action=accept chain=input comment="Allow LAN DNS queries-UDP" \
dst-port=53 in-interface-list=LAN protocol=udp
add action=accept chain=input comment="Allow LAN DNS queries - TCP" \
dst-port=53 in-interface-list=LAN protocol=tcp
add action=drop chain=input comment="drop all else"
{forward chain}
(default rules to keep)
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
(user rules)
add action=accept chain=forward comment="allow internet traffic" in-interface-list=LAN out-interface-list=WAN
add action=accept chain=forward comment="allow port forwarding" connection-nat-state=dstnat { disable or remove if not req'd }
add action=drop chain=forward comment="drop all else"
.........
It should be fairly easy to add what you mean by kid control, but you stated it in config speak and not requirement speak.
1. identify user(s)/device(s), groups of users/devices
2. identify what traffic they should be allowed to execute.
3. the rules above block all other traffic automatically.
For example the above rules
input chain --> allow the admin to config the router
input chain --> allow all LAN users access to router DNS services
forward chain --> allow all LAN users access to internet
forward chain --> allow port forwarding,, in case you have any port forwarding or dst-nat requirements ( can be disable or removed if not useful ).
What I dont understand is the purpose of kid control.
Are you attempting to control a number of IP/mac addresses as to
a. where they can go in terms of internet?
b. what time they can execute traffic?
etc.........