/ip firewall filter
add chain=input action=accept protocol=icmp
add chain=input action=accept dst-address=127.0.0.1
- ok, I've learnt something new, thxICMP is not only used for "PING", but also for PMTUD... read this:
https://en.wikipedia.org/wiki/Path_MTU_Discovery
- yes, you are corrent .. maybe I should read "little bit more" before I mess with FW rules .. ok, I will read it tomorrow, today I just create two rules ..Instead of nickeling and diming the OP,
Just to to this link and choose Option/Para B. - viewtopic.php?t=182373
Besides that, this tells me you dont really know what the firewall rules do and need to learn more before adding rules from the default.
DANGER
add chain=input comment="allow Winbox" in-interface=ether1-gateway port=8291 protocol=tcp
Why would you allow input FROM the WAN to your winbox port?
Why would you use the default port anyway?
Another clue dont know what you are doing>
MISSING the action function in many rules including the danger rule above which saves your bacon in that respect!!
/ip firewall filter add action=drop chain=input comment="Drop all not coming from LAN" in-interface-list=!LAN
/ip firewall filter
add action=jump chain=input comment="ICMP Flow" jump-target=ICMP protocol=icmp
add action=accept chain=ICMP icmp-options=0:0 protocol=icmp
add action=accept chain=ICMP icmp-options=3:0-4 protocol=icmp
add action=accept chain=ICMP icmp-options=3:9-10 protocol=icmp
add action=accept chain=ICMP icmp-options=3:13 protocol=icmp
add action=accept chain=ICMP icmp-options=8:0 protocol=icmp
add action=accept chain=ICMP icmp-options=11:0-1 protocol=icmp
add action=accept chain=ICMP icmp-options=12:0 protocol=icmp
add action=drop chain=ICMP log=yes log-prefix=--->ICMP
add action=accept chain=input comment="Established Connections" connection-state=established,related,untracked
add action=drop chain=input comment=Invalid connection-state=invalid
add action=accept chain=input comment="IP Services" dst-port=WINBOX protocol=tcp
add action=drop chain=input comment="Drop all not coming from LAN" in-interface-list=!LAN
add action=jump chain=forward comment="Jump Flow" jump-target=ICMP protocol=icmp
add action=accept chain=forward comment="IPsec Policy" ipsec-policy=in,ipsec
add action=accept chain=forward ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment=FastTrack connection-state=established,related hw-offload=yes
add action=accept chain=forward comment="Established Connections" connection-state=established,related,untracked
add action=reject chain=forward comment=Invalid connection-state=invalid reject-with=icmp-admin-prohibited
add action=drop chain=forward comment="Drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
add action=reject chain=output comment=Invalid connection-state=invalid reject-with=icmp-admin-prohibited
add action=jump chain=output comment="Jump Flow" jump-target=ICMP protocol=icmp
/ip firewall filter
add chain=input action=accept dst-address=127.0.0.1
Thats the problem, management of something like MT routers that have so many capabilities comes with the responsibility that you have to accept. You should be responsible and config your network as secure as it can be regardless of whether the client's device is ON or OFF. When you entire this category well, you are on your own.becasue if computer is turned off, port will be closed
Did I catch your point correctly?I am curious though from the experts, if RDP is on port 11268, and the dst-nat address has a source address and thus the port is not visible on scans.
What makes the RDP unsafe? Isnt RDP a password proteced login as well?? Not overly familiar with RDP.......
/ip firewall nat
add action=dst-nat chain=dstnat comment="RDP" disabled=yes dst-address="router public IP" dst-port=11268 protocol=tcp src-address=2.2.2.2 to-addresses=192.168.1.2 to-ports=3389
True, But that's for the static public IP. most of the remote clients don't have one which will eliminate the possibility of assignment to the specific src address. these days I saw many VDSs with a cracked credential for sale, I assume they are password protected too.Yes you did, exactly.
/ip firewall addresses
add ip=static-client1 list=authorizedServer
add ip=static-client2 list=authorizedServer
.....
add ip=static-clientX list=authorizedServer
add ip=dyndnsname1 list=authorizedServer
add ip=dyndnsname2 list=authorizedServer
.....
add ip=dyndnsnameX list=authorizedServer
DO NOT OPEN ADMIN INTRAFACE FROM INTERNET!!!!!!add chain=input comment="allow Winbox" in-interface=ether1-gateway port=8291 protocol=tcp