i have 4 users some of them download a lot and I want to limit them after they reach 4 gigabyte per day
I did simple queue for each one of them to limit upload and download rate speed
I want limit users according to amount of download
I use dhcp server in my network
I try script below and nothing happened
can anyone help me and explain steps
Code: Select all
/queue simple {
:for i from=1 to= 254 do={
:local queue [find target=("10.10.10." . $i . "/32")]
:if ([:len $queue] != 0) do={
:local traf [get $queue total-bytes]
:put ("Queue (" . [get $queue target] . ") traf: " . $traf)
:if ($traf > 10) do={
set [find target-addresses=("10.0.0." . $i)] max-limit= 32000/256000
}
}
}
}