Consider there's a point-to-point connection between two routers. Can be either a tunnel (e.g. wireguard or IPIP or anything else) or direct ethernet connection. To make that connection usable for passing packets between devices, one has to assign IP address to the interface and then configure routing.
Classical use on ethernet interfaces would be to create a routing subnet (/30 or larger) in this way:
/ip address
add address=192.168.254.25/30 interface=etherX network=192.168.254.24
/ip route
add dst-address=<remote network> gateway=192.168.254.26
(this assumes the other end of that ethernet link is set with IP address 192.168.254.26/30).
The /32 way of doing it is slightly different. Let's say local router can use 192.168.15.233 as PtP interface IP address and the remote router uses 10.20.30.45 as interface of its end of same PtP tunnel. So the configuration of local end would be like this:
/ip address
add address=192.168.15.233/32 network=10.20.30.45 interface=PtPinterface
/ip route
add dst-address=<remote network> gateway=10.20.30.45
One can then further obfuscate the /32 addressing by reusing one of existing IP address that router might already have. For example, local router has several LANs attached, one of addresses is 172.19.13.1/24. It is possible to reuse the address, but with /32 network mask:
/ip address
add address=172.19.13.1/24 interface=<LAN interface> network=172.19.13.0 # existing LAN address
add address=172.19.13.1/32 interface=PtPinterface network=10.20.30.45
/ip route
add dst-address=<remote network> gateway=10.20.30.45
The difference between the two /32 examples is in what traceroute shows: when a device from remote network (beyond remote router) starts traceroute, the IP address shown with hop hitting local router will be different as IP address shown is the one of ingress interface. So the difference is only cosmetics (and avoiding to use separate set of addresses for link only).
Next possibility (out of scope of the question) is that it is possible to use PtP links completely address-less, like this
/ip address
add address=172.19.13.1/24 interface=<LAN interface> network=172.19.13.0 # existing LAN address
/ip route
add dst-address=<remote network> gateway=Ptpinterface pref-src=172.19.13.1
(the pref-src setting is to fix the IP address shown in ICMP replies, such as the one shown by traceroute. If this property is not set explicitly, router will select one of existing own IP addresses (I'm not sure how exactly selection is done).
When thinking about it, it seems to me that from addressing point of view it should be possible to configure mutiple logical PtP links using /32 addressing over same physical ethernet interface, but I don't know how would that actually work. One would have to wireshark such ethernet link to see what kind of MAC addresses are used in such case. The fact that IP address used is /32 implies that sender doesn't look for MAC address of receiver's NIC and thus uses broadcast MAC address when sending packets out. If this is indeed the case, then multiple logical PtP links could co-exist, but all traffic would hit all involved NICs (any ethernet switch in between wouldn't have anything to work with when selecting egress port for individual frames).
So, in short, don't do it