Dear All
I played around with Tools that RouterOS provided but I can't find a way to test outgoing UDP port from inside RouterOS itself. Example. Is "160.111,111,160 UDP Port 51820" Open? Similar to telnet 160.111.111.160 51820 but for UDP
/ip dns
set allow-remote-requests=yes
/ip dns static
add name=wgtest address=1.2.3.4
/ip firewall nat
add chain=dstnat dst-address=<server address> protocol=udp dst-port=51820 content=wgtest action=redirect to-ports=53
/ip firewall filter
add chain=input protocol=udp dst-port=53 connection-nat-state=dstnat action=accept
:put [resolve wgtest server=<server address> server-port=51820]
The quickest way on Linux is to use a dstnat rule to redirect what has arrived to UDP port 51820 to 53 - provided that the DNS service has already been up on said Linux, and that it is configured to respond to queries from the internet, which is usually not the case for security reasons.Oh, I have only one Mikrotik device. Do you know the quickest way to spin up a DNS SERVER port 51820 on linux?
tcpdump -i eth0 'udp port 51820'
15:07:47.474818 IP ezecom.45.118.222.0.149.ezecom.com.6163 > h.wireguard_server.com.51820: UDP, length 148
15:07:51.677908 IP h.wireguard_server.com.51820 > ezecom.45.118.222.0.149.ezecom.com.18733: UDP, length 96