Hello there, I successfully running RB450 router with VLAN config. Ether4 port is a trunk port which is working fine (connected to CRS354). Now I wanted to use another port (ether3) on RB450 as access port to one of the VLANs. Unfortunately, i can't connect to the desired network through it.
/interface bridge
add name=br-WAN
add name=br-switch1
/interface bridge port
add bridge=br-WAN interface=ether1
add bridge=br-switch1 interface=ether2
add bridge=br-switch1 interface=ether3
add bridge=br-switch1 interface=ether4
add bridge=br-switch1 interface=ether5
/interface vlan
add interface=br-switch1 name=vlan-PUBLIC vlan-id=3
add interface=br-switch1 name=vlan-KS vlan-id=4
/interface ethernet switch
set switch1 switch-all-ports=no
/interface ethernet switch port
set ether2 vlan-mode=disabled
set ether3 default-vlan-id=3 vlan-header=always-strip vlan-mode=secure
set ether4 vlan-header=add-if-missing vlan-mode=secure
set ether5 vlan-mode=disabled
set switch1-cpu vlan-mode=secure
/interface ethernet switch vlan
add ports=ether3,ether4,switch1-cpu switch=switch1 vlan-id=3
add ports=ether4,switch1-cpu switch=switch1 vlan-id=4