need manual for ecmp [edit] load balance if you can
I'd start with the differences between PCC ,ECMP, etc here (e.g. packet vs session):
https://help.mikrotik.com/docs/display/ ... +Balancing
Unforentently Mikrotik's docs do leave you hanging with ECMP. But it quite easy. In V7, an ECMP route is created just by add routes for same distance=1. So for example, if we assuming your 100Mbs WAN1's gateway is 2.1.1.1, and your 50Mb/s WAN2's gateway is 2.2.2.2 (and you already do any NAT stuff), an load balanced (by session) is created by:
/ip route add distance=1 dst-address=0.0.0.0/0 gateway=2.1.1.1 check-gateway=ping
/ip route add distance=1 dst-address=0.0.0.0/0 gateway=2.1.1.1 check-gateway=ping
/ip route add distance=1 dst-address=0.0.0.0/0 gateway=2.2.2.2 check-gateway=ping
You'll note they all use the same distance and "E" will appear in the routing table. You'd need to REPLACE your existing WAN gateways, remove PCC, etc. to use. But that's the approach, as show your 100Mb/s WAN would be favored 2 to 1 with 50Mb/s WAN. e.g. you send 2x the traffic out WAN1, since it has 2x the speed of WAN2.
I don't know what config you have or are working with. But without a config and ideally diagram... I can't even say ECMP is what you need. But that's how it works.