does it do the same, if you change the local role to "igp rr"
with the new changes to BGP in v7 everything is explicitly defined i.e. filters are required.
try creating a outbound filter with only one rule ex: add chain=Default-Out disabled=no rule="accept;"
with that defined it should pass all routes
Yep not ready for production. I for one will be waiting till all my lab testing passes with flying colors.
It's sad really that v7 had been under development for more than 8 years and still is not ready for production use, and to make matters worse they are already releasing v7 only devices.
I do wonder what model did you run the test on? was it a CHR or was it a hardware device with a Tilera cpu ?
I am curious as to how to make it so when you have IGRP routes flap that you don't flap EGRP BGP routes. SO I get that if you have more specific routes than a larger range than a /24 you can use a blackhole route and it wont flap however you have to filter out the more specific routes from announcing on BGP unless that is desired. But in the case of having /24 networks that are not part of a larger range you cannot use blackhole routes correct as the other routes are not more specific. How would that be worked around?I have two border routers that both keep full BGP routing tables of their upstream connection and their neighbors upstream connection. Typically the default iBGP configuration will announce all routes in the table to its peer. This seems impossible with RouterOS v7 for some reason. eBGP is announcing the prefixes I have in bgp-networks and have a static blackhole route for so that's fine but I should not need to do that to share all routes with an iBGP peer. How is that accomplished in v7? I'm assuming there is a configuration setting i'm missing.
Would I just need to set the blackhole route distance to higher than the IGRP /24 route or set to 255?I am curious as to how to make it so when you have IGRP routes flap that you don't flap EGRP BGP routes. SO I get that if you have more specific routes than a larger range than a /24 you can use a blackhole route and it wont flap however you have to filter out the more specific routes from announcing on BGP unless that is desired. But in the case of having /24 networks that are not part of a larger range you cannot use blackhole routes correct as the other routes are not more specific. How would that be worked around?I have two border routers that both keep full BGP routing tables of their upstream connection and their neighbors upstream connection. Typically the default iBGP configuration will announce all routes in the table to its peer. This seems impossible with RouterOS v7 for some reason. eBGP is announcing the prefixes I have in bgp-networks and have a static blackhole route for so that's fine but I should not need to do that to share all routes with an iBGP peer. How is that accomplished in v7? I'm assuming there is a configuration setting i'm missing.
Hey jd603,
Just checking in I am curious if this issue has been resolved with any of the beta versions or any Stable-ish release of 7.2.x
Bump.
The good news is the flap bug from my first attempt at moving to v7 is gone. The bad news is, me along with several others are still having issues with this one... I have tried every config option and variant to get v7 to announce all its eBGP learned routes to its iBGP peers. Nothing works. This is a basic necessity for running BGP on a LAN with more than one router. Is there an actual example of this working correctly anywhere? Config example perhaps?
/interface bridge
add name=lo-ipv4
add name=lo-ipv6
/interface bonding
add mode=802.3ad name=bonding1 slaves=sfp-sfpplus1,sfp-sfpplus2 transmit-hash-policy=layer-3-and-4
/interface vlan
add interface=bonding1 name=vlan901-isp1-hooli vlan-id=901
add interface=bonding1 name=vlan3000-ptmp-edge-routers vlan-id=3000
add interface=bonding1 name=vlan3100-ptp-core vlan-id=3100
/interface lte apn
set [ find default=yes ] ip-type=ipv4
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip vrf
add interfaces=ether15 name=vrf-mgmt
/port
set 0 name=serial0
set 1 name=serial1
/routing bgp template
add address-families=ip as=1016 name=as1016-v4 router-id=100.127.1.1
add address-families=ipv6 as=1016 name=as1016-v6 router-id=100.127.1.1
/routing id
add id=100.127.1.1 name=rid-main select-dynamic-id=only-vrf select-from-vrf=main
/routing ospf instance
add disabled=no name=ospf-instance-v2-ipv4 router-id=rid-main routing-table=main
add disabled=no name=ospf-instance-v3-ipv6 router-id=rid-main routing-table=main version=3
/routing ospf area
add disabled=no instance=ospf-instance-v2-ipv4 name=ospf-area-0-ipv4
add disabled=no instance=ospf-instance-v3-ipv6 name=ospf-area-0-ipv6
/ip settings
set max-neighbor-entries=8192
/ipv6 settings
set max-neighbor-entries=8192
/interface ovpn-server server
set auth=sha1,md5
/ip address
add address=100.126.1.1/29 interface=vlan3100-ptp-core network=100.126.1.0
add address=100.127.1.1 interface=lo-ipv4 network=100.127.1.1
add address=203.0.113.2/29 interface=vlan901-isp1-hooli network=203.0.113.0
add address=100.126.12.1/29 interface=vlan3000-ptmp-edge-routers network=100.126.12.0
/ip dhcp-client
add interface=ether15
add disabled=yes interface=ether1
/ip firewall address-list
add address=198.18.0.0/22 list=add-list-as1016-ipv4-internal
/ip service
set ssh vrf=vrf-mgmt
set winbox vrf=vrf-mgmt
/ipv6 address
add address=200:1ce:a1a:3100::1 advertise=no interface=vlan3100-ptp-core
add address=200:1ce:127::1/128 advertise=no interface=lo-ipv6
add address=3ffe:1001:1002::2 advertise=no interface=vlan901-isp1-hooli
add address=200:1ce:a1a:3000::1 advertise=no interface=vlan3000-ptmp-edge-routers
/ipv6 dhcp-client
add interface=ether1 request=address
/ipv6 firewall address-list
add address=200:1ce:127::1/128 list=add-list-as1016-ipv6-internal
/routing bgp connection
add disabled=no input.affinity=afi local.address=100.127.1.1 .role=ibgp-rr-client name=peer-ipv4-rtr-core-01 nexthop-choice=force-self \
output.default-originate=always .filter-chain=as1016-ipv4-internal-permit-default .network=add-list-as1016-ipv4-internal remote.address=\
100.127.1.3 .as=1016 templates=as1016-v4
add input.affinity=afi local.address=200:1ce:127::1 .role=ibgp-rr-client name=peer-ipv6-rtr-core-01 nexthop-choice=force-self \
output.default-originate=always .filter-chain=as1016-ipv6-internal-permit-default .network=add-list-as1016-ipv6-internal remote.address=\
200:1ce:127::3 .as=1016 templates=as1016-v6
add add-path-out=all address-families=ip as=1016 disabled=yes hold-time=30m keepalive-time=1m local.role=ebgp-peer name=isp1-hooli remote.address=\
203.0.113.1/32 .as=65101 router-id=100.127.1.1 routing-table=main templates=as1016-v4
add address-families=ip as=1016 disabled=no input.affinity=afi local.address=100.126.12.1 .role=ibgp name=peer-ipv4-rtr-edge-02 nexthop-choice=default \
output.default-originate=always remote.address=100.126.12.2/32 .as=1016 router-id=100.127.1.1 routing-table=main templates=as1016-v4
add address-families=ipv6 as=1016 disabled=no input.affinity=afi local.address=200:1ce:a1a:3000::1 .role=ibgp name=peer-ipv6-rtr-edge-02 \
nexthop-choice=default output.default-originate=always remote.address=200:1ce:a1a:3000::2/128 .as=1016 router-id=100.127.1.1 routing-table=main \
templates=as1016-v6
/routing filter community-large-list
add communities=1016:1016:4 list=bgp-community-large-1016-1016-4
add communities=1016:1016:6 list=bgp-community-large-1016-1016-6
/routing filter community-list
add communities=1016:0 list=bgp-community-1016-0
/routing filter rule
add chain=as1016-ipv4-internal-permit-default rule=\
"if (dst in 198.18.0.0/22 && dst-len > 22) { set bgp-large-communities bgp-community-large-1016-1016-4; accept; }"
add chain=as1016-ipv4-internal-permit-default rule="if (dst== 0.0.0.0/0) { accept; }"
add chain=as1016-ipv4-internal-permit-default rule="if (dst in 0.0.0.0/0) { reject;}"
add chain=as1016-ipv6-internal-permit-default rule=\
"if (dst in 200:1ce::/32 && dst-len > 32) { set bgp-large-communities bgp-community-large-1016-1016-6; accept; }"
add chain=as1016-ipv6-internal-permit-default rule="if (dst==::/0) { accept; }"
add chain=as1016-ipv6-internal-permit-default rule="if (dst in ::/0) { reject;}"
/routing ospf interface-template
add area=ospf-area-0-ipv4 disabled=no interfaces=vlan3100-ptp-core type=ptp
add area=ospf-area-0-ipv4 disabled=no interfaces=lo-ipv4
add area=ospf-area-0-ipv6 disabled=no interfaces=vlan3100-ptp-core type=ptp
add area=ospf-area-0-ipv6 disabled=no interfaces=lo-ipv6 networks=200:1ce:127::1/128 passive
add area=ospf-area-0-ipv4 disabled=no interfaces=vlan901-isp1-hooli passive
add area=ospf-area-0-ipv4 disabled=no interfaces=vlan3000-ptmp-edge-routers
/system identity
set name=rtr-edge-01.v7.ipa.dev
/system package update
set channel=testing
/system resource irq rps
set ether1 disabled=no
/tool bandwidth-server
set authenticate=no
/tool romon
set enabled=yes
/interface bridge
add name=lo-ipv4
add name=lo-ipv6
/interface ethernet
set [ find default-name=ether15 ] name=ether15-mgmt
set [ find default-name=sfp-sfpplus1 ] name=sfp-sfpplus1-crs326-02
set [ find default-name=sfp-sfpplus2 ] name=sfp-sfpplus2-crs326-02
/interface bonding
add mode=802.3ad name=bonding1-crs326-02 slaves=sfp-sfpplus1-crs326-02,sfp-sfpplus2-crs326-02 transmit-hash-policy=layer-3-and-4
/interface vlan
add interface=bonding1-crs326-02 name=vlan902-isp2-initech vlan-id=902
add interface=bonding1-crs326-02 name=vlan3000-ptmp-edge-routers vlan-id=3000
add interface=bonding1-crs326-02 name=vlan3200-ptp-core vlan-id=3200
/interface lte apn
set [ find default=yes ] ip-type=ipv4
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/port
set 0 name=serial0
set 1 name=serial1
/routing bgp template
add address-families=ip as=1016 name=as1016-v4 router-id=100.127.1.2
add address-families=ipv6 as=1016 name=as1016-v6 router-id=100.127.1.2
/routing id
add id=100.127.1.2 name=rid-main
add id=100.127.1.2 name=rid-main select-dynamic-id=only-vrf select-from-vrf=main
/routing ospf instance
add disabled=no name=ospf-instance-v2-ipv4 router-id=rid-main
add disabled=no name=ospf-instance-v3-ipv6 router-id=rid-main version=3
/routing ospf area
add disabled=no instance=ospf-instance-v2-ipv4 name=ospf-area-0-ipv4
add disabled=no instance=ospf-instance-v3-ipv6 name=ospf-area-0-ipv6
/ip settings
set max-neighbor-entries=8192
/ipv6 settings
set max-neighbor-entries=8192
/interface ovpn-server server
set auth=sha1,md5
/ip address
add address=100.126.1.9/29 interface=vlan3200-ptp-core network=100.126.1.8
add address=100.127.1.2 interface=lo-ipv4 network=100.127.1.2
add address=198.51.100.2/29 interface=vlan902-isp2-initech network=198.51.100.0
add address=100.126.12.2/29 interface=vlan3000-ptmp-edge-routers network=100.126.12.0
/ip dhcp-client
add interface=ether15-mgmt
/ipv6 address
add address=200:1ce:127::2/128 advertise=no interface=lo-ipv6
add address=200:1ce:a1a:3200::2 advertise=no interface=vlan3200-ptp-core
add address=200:1ce:a1a:3000::2 advertise=no interface=vlan3000-ptmp-edge-routers
/ipv6 firewall address-list
add address=200:1ce:1001::/48 list=add-list-as1016-ipv6-services
add address=200:1ce:1002::/48 list=add-list-as1016-ipv6-services
add address=200:1ce:1003::/48 list=add-list-as1016-ipv6-services
/ipv6 nd
set [ find default=yes ] ra-lifetime=none
/ipv6 nd prefix default
set preferred-lifetime=4h valid-lifetime=4h
/routing bgp connection
add local.address=100.127.1.2 .role=ibgp-rr-client name=peer-ipv4-rtr-core-01 output.filter-chain=as1016-ipv4-services-no-default \
.keep-sent-attributes=yes .network=add-list-as1016-ipv4-services remote.address=100.127.1.3 .as=1016 templates=as1016-v4
add address-families=ipv6 as=1016 disabled=no local.address=200:1ce:127::2 .role=ibgp-rr-client name=peer-ipv6-rtr-core-01 \
output.keep-sent-attributes=yes .network=add-list-as1016-ipv6-services remote.address=200:1ce:127::3/128 .as=1016 router-id=100.127.1.2 \
routing-table=main templates=as1016-v6
add add-path-out=all address-families=ip as=1016 disabled=no keepalive-time=1m local.role=ebgp-peer name=isp2-initech remote.address=198.51.100.1/32 \
.as=65102 router-id=100.127.1.2 routing-table=main templates=as1016-v4
add address-families=ip as=1016 disabled=no input.affinity=afi local.address=100.126.12.2 .role=ibgp name=peer-ipv4-rtr-edge-01 nexthop-choice=default \
output.default-originate=always remote.address=100.126.12.1/32 .as=1016 router-id=100.127.1.2 routing-table=main templates=as1016-v4
add address-families=ipv6 as=1016 disabled=no local.address=200:1ce:a1a:3000::2 .role=ibgp name=peer-ipv6-rtr-edge-01 output.keep-sent-attributes=yes \
.network=add-list-as1016-ipv6-services remote.address=200:1ce:a1a:3000::1/128 .as=1016 router-id=100.127.1.2 routing-table=main templates=\
as1016-v6
/routing filter community-large-list
add communities=1016:1016:4 list=bgp-community-large-1016-1016-4
add communities=1016:1016:6 list=bgp-community-large-1016-1016-6
/routing filter rule
add chain=as1016-ipv4-internal-permit-default rule=\
"if (dst in 198.18.0.0/22 && dst-len > 22) { set bgp-large-communities bgp-community-large-1016-1016-4; accept; }"
add chain=as1016-ipv4-internal-permit-default rule="if (dst== 0.0.0.0/0) { accept; }"
add chain=as1016-ipv4-internal-permit-default rule="if (dst in 0.0.0.0/0) { reject;}"
add chain=as1016-ipv6-internal-permit-default rule=\
"if (dst in 200:1ce::/32 && dst-len > 32) { set bgp-large-communities bgp-community-large-1016-1016-6; accept; }"
add chain=as1016-ipv6-internal-permit-default rule="if (dst==::/0) { accept; }"
add chain=as1016-ipv6-internal-permit-default rule="if (dst in ::/0) { reject;}"
/routing ospf interface-template
add area=ospf-area-0-ipv4 disabled=no interfaces=vlan3200-ptp-core type=ptp
add area=ospf-area-0-ipv4 disabled=no interfaces=lo-ipv4
add area=ospf-area-0-ipv6 disabled=no interfaces=lo-ipv6 networks=200:1ce:127::2/128 passive
add area=ospf-area-0-ipv6 disabled=no interfaces=vlan3200-ptp-core type=ptp
add area=ospf-area-0-ipv4 disabled=no interfaces=vlan902-isp2-initech passive
add area=ospf-area-0-ipv4 disabled=no interfaces=vlan3000-ptmp-edge-routers
/system clock
set time-zone-name=America/New_York
/system identity
set name=rtr-edge-02.v7.ipa.dev
/system package update
set channel=testing
/system resource irq rps
set ether1 disabled=no
/tool bandwidth-server
set authenticate=no
/tool romon
set enabled=yes
/tool sniffer
set file-limit=10000KiB
/interface bridge
add frame-types=admit-only-vlan-tagged name=bridge-main vlan-filtering=yes
add name=lo-ipv4
add name=lo-ipv6
/interface ethernet
set [ find default-name=sfp-sfpplus1 ] auto-negotiation=no name=sfp-sfpplus1-crs326-01 speed=10Gbps
set [ find default-name=sfp-sfpplus2 ] auto-negotiation=no name=sfp-sfpplus2-crs326-01 speed=10Gbps
/interface vlan
add interface=bridge-main name=vlan3100-ptp-edge-01 vlan-id=3100
add interface=bridge-main name=vlan3200-ptp-edge-02 vlan-id=3200
/interface bonding
add mode=802.3ad name=bonding1-crs326-01 slaves=sfp-sfpplus1-crs326-01,sfp-sfpplus2-crs326-01 transmit-hash-policy=layer-3-and-4
/disk
set disk1 parent=nvme1 partition-offset=512 partition-size="512 110 190 080" slot=disk1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip vrf
add interfaces=ether13 name=vrf-mgmt
/port
set 0 name=serial0
/routing bgp template
add address-families=ip as=1016 cluster-id=100.127.1.3 name=as1016-v4-rr router-id=100.127.1.3
add address-families=ipv6 as=1016 cluster-id=100.127.1.3 name=as1016-v6-rr router-id=100.127.1.3
/routing id
add id=100.127.1.3 name=rid-main select-dynamic-id=only-vrf select-from-vrf=main
/routing ospf instance
add disabled=no name=ospf-instance-v3-ipv6 router-id=rid-main version=3
add disabled=no name=ospf-instance-v2-ipv4 router-id=rid-main
/routing ospf area
add disabled=no instance=ospf-instance-v3-ipv6 name=ospf-area-0-ipv6
add disabled=no instance=ospf-instance-v2-ipv4 name=ospf-area-0-ipv4
/interface bridge port
add bridge=bridge-main interface=bonding1-crs326-01
/interface ethernet switch l3hw-settings
set fasttrack-hw=no icmp-reply-on-error=no
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/ip settings
set max-neighbor-entries=8192
/ipv6 settings
set max-neighbor-entries=8192
/interface bridge vlan
add bridge=bridge-main tagged=bonding1-crs326-01,bridge-main vlan-ids=3100
add bridge=bridge-main tagged=bonding1-crs326-01,bridge-main vlan-ids=3200
/ip address
add address=100.126.1.2/29 interface=vlan3100-ptp-edge-01 network=100.126.1.0
add address=100.126.1.10/29 interface=vlan3200-ptp-edge-02 network=100.126.1.8
add address=100.127.1.3 interface=lo-ipv4 network=100.127.1.3
/ip dhcp-client
add interface=ether13
/ip service
set ssh vrf=vrf-mgmt
set winbox vrf=vrf-mgmt
/ipv6 address
add address=200:1ce:a1a:3100::3 advertise=no interface=vlan3100-ptp-edge-01
add address=200:1ce:127::3/128 advertise=no interface=lo-ipv6
add address=200:1ce:a1a:3200::3 advertise=no interface=vlan3200-ptp-edge-02
/routing bgp connection
add address-families=ip as=1016 cluster-id=100.127.1.3 disabled=no local.address=100.127.1.3 .role=ibgp-rr name=peer-ipv4-rtr-edge-01 remote.address=\
100.127.1.1/32 .as=1016 router-id=100.127.1.3 routing-table=main templates=as1016-v4-rr
add address-families=ip as=1016 cluster-id=100.127.1.3 disabled=no local.address=100.127.1.3 .role=ibgp-rr name=peer-ipv4-rtr-edge-02 \
output.default-originate=if-installed remote.address=100.127.1.2/32 .as=1016 router-id=100.127.1.3 routing-table=main templates=as1016-v4-rr
add address-families=ipv6 as=1016 cluster-id=100.127.1.3 disabled=no local.address=200:1ce:127::3 .role=ibgp-rr name=peer-ipv6-rtr-edge-01 \
remote.address=200:1ce:127::1/128 .as=1016 router-id=100.127.1.3 routing-table=main templates=as1016-v6-rr
add address-families=ipv6 as=1016 cluster-id=100.127.1.3 disabled=no local.address=200:1ce:127::3 .role=ibgp-rr name=peer-ipv6-rtr-edge-02 \
output.default-originate=if-installed remote.address=200:1ce:127::2/128 .as=1016 router-id=100.127.1.3 routing-table=main templates=as1016-v6-rr
/routing ospf interface-template
add area=ospf-area-0-ipv6 disabled=no interfaces=lo-ipv6 networks=200:1ce:127::3/128 passive
add area=ospf-area-0-ipv4 disabled=no interfaces=vlan3100-ptp-edge-01 type=ptp
add area=ospf-area-0-ipv4 disabled=no interfaces=vlan3200-ptp-edge-02 type=ptp
add area=ospf-area-0-ipv4 disabled=no interfaces=lo-ipv4
add area=ospf-area-0-ipv6 disabled=no interfaces=vlan3100-ptp-edge-01 type=ptp
add area=ospf-area-0-ipv6 disabled=no interfaces=vlan3200-ptp-edge-02 type=ptp
/system clock
set time-zone-name=America/New_York
/system identity
set name=rtr-core-01.v7.ipa.dev
/system ntp client
set enabled=yes
/system ntp client servers
add address=time.google.com
/system package update
set channel=testing
/tool romon
set enabled=yes
The routes are not being sent at all. So.. for example, if the routes learned from eBGP on router 1 are active on both routers and the eBGP session is lost, the inactive eBGP routes from router 2 would need to become active in the local routing table after the failed routes get removed, they would then be sent to router 1 and once those are processed and loaded they will become active and pass traffic.
[zuul@rtr-edge-01.v7.ipa.dev] > routing/route/print
Flags: X - disabled, F - filtered, U - unreachable, A - active; c - connect, s - static, r - rip, b - bgp, o - ospf, d - dhcp, v - vpn, m - modem, a - ldp-address, l - ldp-mapping, y - copy;
H - hw-offloaded; + - ecmp, B - blackhole
DST-ADDRESS GATEWAY AFI DISTANCE SCOPE TARGET-SCOPE IMMEDIATE-GW
Ab 0.0.0.0/0 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
UbH 0.0.0.0/0 10.255.44.1 ip4 200 40 30
Ab 1.0.0.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.0.0.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
b 1.0.4.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
Ab 1.0.4.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
b 1.0.5.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
Ab 1.0.5.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
b 1.0.6.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
Ab 1.0.6.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.7.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.0.7.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.38.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.0.38.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.64.0/18 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.0.64.0/18 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
b 1.0.128.0/17 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
Ab 1.0.128.0/17 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.128.0/18 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.0.128.0/18 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.128.0/19 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.0.128.0/19 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.128.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.0.128.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.129.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.0.129.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
b 1.0.131.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
Ab 1.0.131.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
b 1.0.139.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
Ab 1.0.139.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.142.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.0.142.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.160.0/19 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.0.160.0/19 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
b 1.0.160.0/21 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
Ab 1.0.160.0/21 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.192.0/18 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.0.192.0/18 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.192.0/19 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.0.192.0/19 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.192.0/21 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.0.192.0/21 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
b 1.0.208.0/22 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
Ab 1.0.208.0/22 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.212.0/23 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.0.212.0/23 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.214.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.0.214.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.224.0/19 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.0.224.0/19 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.240.0/20 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.0.240.0/20 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.1.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.1.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.8.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.8.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.32.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.32.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.64.0/19 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.64.0/19 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.114.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.114.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.115.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.115.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.116.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.116.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.117.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.117.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.118.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.118.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.119.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.119.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.120.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.120.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.121.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.121.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.122.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.122.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.123.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.123.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.124.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.124.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.125.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.125.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.126.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.126.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.127.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.127.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
b 1.1.128.0/17 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
Ab 1.1.128.0/17 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.128.0/18 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.128.0/18 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.128.0/19 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.128.0/19 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.128.0/21 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
Ab 1.1.136.0/22 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.136.0/22 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
b 1.1.141.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
Ab 1.1.141.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
b 1.1.142.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
Ab 1.1.142.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.144.0/20 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
Ab 1.1.160.0/19 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.160.0/19 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.160.0/20 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.160.0/20 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
b 1.1.181.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
Ab 1.1.181.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.184.0/22 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.184.0/22 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.190.0/23 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.190.0/23 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.192.0/18 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.192.0/18 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.192.0/19 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.192.0/19 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.192.0/20 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
Ab 1.1.208.0/21 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
Ab 1.1.216.0/22 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.216.0/22 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.222.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.222.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.224.0/19 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
Ab 1.1.224.0/21 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
Ab 1.1.232.0/21 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
Ab 1.1.240.0/21 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.240.0/21 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.248.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.248.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.249.0/24 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.249.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.254.0/23 203.0.113.1 ip4 20 40 10 203.0.113.1%vlan901-isp1-hooli
b 1.1.254.0/23 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
[zuul@rtr-edge-01.v7.ipa.dev] > routing/route/print
Flags: X - disabled, F - filtered, U - unreachable, A - active;
c - connect, s - static, r - rip, b - bgp, o - ospf, d - dhcp, v - vpn, m - modem, a - ldp-address, l - ldp-mapping, y - copy; H - hw-offloaded; + - ecmp, B - blackhole
DST-ADDRESS GATEWAY AFI DISTANCE SCOPE TARGET-SCOPE IMMEDIATE-GW
UbH 0.0.0.0/0 10.255.44.1 ip4 200 40 30
Ab 1.0.0.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.4.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.5.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.6.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.7.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.38.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.64.0/18 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.128.0/17 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.128.0/18 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.128.0/19 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.128.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.129.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.131.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.139.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.142.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.160.0/19 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.160.0/21 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.192.0/18 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.192.0/19 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.192.0/21 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.208.0/22 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.212.0/23 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.214.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.224.0/19 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.0.240.0/20 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.1.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.8.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.32.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.64.0/19 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.114.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.115.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.116.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.117.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.118.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.119.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.120.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.121.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.122.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.123.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.124.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.125.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.126.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.127.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.128.0/17 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.128.0/18 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.128.0/19 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.136.0/22 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.141.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.142.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.160.0/19 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.160.0/20 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.181.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.184.0/22 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.190.0/23 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.192.0/18 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.192.0/19 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.216.0/22 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.222.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.240.0/21 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.248.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.249.0/24 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Ab 1.1.254.0/23 198.51.100.1 ip4 200 40 30 100.126.12.2%vlan3000-ptmp-edge-routers
Unfortunately, no. I just tested on IPv6 BGP, i disabled the eBGP peer on the rosv6 router and no routes were added from the v7 router.
/interface bridge
add name=lo-ipv4
add name=lo-ipv6
/interface bonding
add mode=802.3ad name=bonding1 slaves=sfp-sfpplus1,sfp-sfpplus2 transmit-hash-policy=layer-3-and-4
/interface vlan
add interface=bonding1 name=vlan901-isp1-hooli vlan-id=901
add interface=bonding1 name=vlan3000-ptmp-edge-routers vlan-id=3000
add interface=bonding1 name=vlan3100-ptp-core vlan-id=3100
/routing bgp instance
set default as=1016 router-id=100.127.1.1
/routing ospf instance
set [ find default=yes ] router-id=100.127.1.1
/ip address
add address=100.126.1.1/29 interface=vlan3100-ptp-core network=100.126.1.0
add address=100.127.1.1 interface=lo-ipv4 network=100.127.1.1
add address=203.0.113.2/29 interface=vlan901-isp1-hooli network=203.0.113.0
add address=100.126.12.1/29 interface=vlan3000-ptmp-edge-routers network=100.126.12.0
/ip dhcp-client
add disabled=no interface=ether8
/ipv6 address
add address=200:1ce:a1a:3100::1 advertise=no interface=vlan3100-ptp-core
add address=200:1ce:127::1/128 advertise=no interface=lo-ipv6
add address=3ffe:1001:1002::2 advertise=no interface=vlan901-isp1-hooli
add address=200:1ce:a1a:3000::1 advertise=no interface=vlan3000-ptmp-edge-routers
/routing bgp network
add network=198.18.0.0/22
/routing bgp peer
add default-originate=always name=peer-ipv4-rtr-core-01 out-filter=as1016-ipv4-internal-permit-default remote-address=100.127.1.3 remote-as=1016
add default-originate=always name=peer-ipv4-rtr-edge-02 remote-address=100.126.12.2 remote-as=1016
add default-originate=always name=isp1-hooli out-filter=as1016-ipv4-internal-permit-default remote-address=203.0.113.1 remote-as=65101
/routing filter
add action=accept chain=as1016-ipv4-internal-permit-default prefix=198.18.0.0/22 prefix-length=23-32 set-bgp-communities=1016:4
add action=accept chain=as1016-ipv4-internal-permit-default prefix=0.0.0.0/0 set-bgp-communities=""
add action=discard chain=as1016-ipv4-internal-permit-default set-bgp-communities=""
/routing ospf interface
add interface=vlan901-isp1-hooli network-type=broadcast passive=yes
add interface=vlan3000-ptmp-edge-routers network-type=point-to-point
add interface=vlan3100-ptp-core network-type=point-to-point
/routing ospf network
add area=backbone network=100.126.1.0/29
add area=backbone network=100.126.12.0/29
add area=backbone network=100.127.1.1/32
add area=backbone network=203.0.113.0/29
/system clock
set time-zone-name=America/Chicago
/system identity
set name=rtr-edge-01.rosv6.ipa.dev
/tool romon
set enabled=yes
The problem with your design is it isn't using the standard ibgp full mesh
Can you disable ibgp-rr and just use ibgp and get the same result of ALL ebgp routes being shared to ibgp neighbors?
[zuul@rtr-core-01.v7.ipa.dev] > routing/stats/origin/print where name="bgp-IP-100.127.1.1" or name="bgp-IP-100.127.1.2"
Flags: Y - synthetic; Z - terminal; X - stopping; A - abandoned; H - hold; U - attrs-updated; M - attrs-merge
14 name="bgp-IP-100.127.1.1" instance-id=1686044931 publisher-idx=14 route-type="8" pid=bgp-remote-3
route-count=0,422501,0,0,0,0,0,0,0,0,0,0,0,0 total-route-count=422501
15 name="bgp-IP-100.127.1.2" instance-id=1686044931 publisher-idx=15 route-type="8" pid=bgp-remote-2
route-count=0,348845,0,0,0,0,0,0,0,0,0,0,0,0 total-route-count=348845
Wait hold up - your core router is v7 - the issue i have is v7 sending ibgp routes (ebgp learned and non ibgp-rr configured) to v6 ... v6 sends all routes to v7 fine.
What routes are being sent to the v6 router? the current real internet routing table or one you generated?