*) dns - query upstream DNS servers for other record types even if static entry exists;
This change, while not necessarily wrong, is not great either. Previously when I set record of any type, it took over the whole name, i.e. it blocked all other types from upstream. Simple example, public server www.something.tld has both IPv4 and IPv6 addresses (A and AAAA records), but from the network where it's hosted it should be accessed directly using internal address, and for some reason IPv4 only. With older RouterOS, this was it:
/ip dns static add type=A name=www.something.tld address=10.0.0.10
If client asked router (as DNS resolver) for AAAA www.something.tld, it got nothing, no data. But now it gets real AAAA record from public DNS. I agree that this can be useful (for something else). But the previous behaviour was useful too, and now I don't see any good way how to achieve it. If it's just about blocking AAAA, I could set it to some invalid value (which is terrible "solution"). But if I want to block all other types, because there isn't just A/AAAA, it's now impossible.
As a bare minimum, there should be proper way for removing upstream records, e.g.:
/ip dns static add type=AAAA name=www.something.tld no-data=yes
And something for overriding the whole name, same way as it worked in previous versions, would be nice too.