I've noticed that /ip/dns/static/add takes an address-list option. I've tried using it but it doesn't seem to work. If I create a record:
/ip/dns/static/add name="spaghetti.lan" address-list=k8s-v4-ingress
The address-list looks like this:
/ip firewall address-list
add address=192.168.7.11 list=k8s-v4-ingress
add address=192.168.7.12 list=k8s-v4-ingress
add address=192.168.7.13 list=k8s-v4-ingress
add address=192.168.7.14 list=k8s-v4-ingress
If I print the static entry it shows up as:
9 name="spaghetti.lan" type=(unknown) ttl=1d address-list="k8s-ingress"
If I try to set a type of "A" I get an error;
failure: bad A data: IPv4 address expected
And a dns lookup for spaghetti.lan fails with an NXDOMAIN response.
Am I trying to use the wrong thing? Does anyone have an example of an static dns entry pointing to an address-list? I know I could use multiple static DNS entries, but it would be nice to point to an address-list.