thanks for reporting this, we will check how to fix this in upcoming versions
docker buildx build --sbom=true --provenance=true ...
# ...
- name: Build and push
uses: docker/build-push-action@v4
with:
context: .
push: true
sbom: false
provenance: false
platforms: linux/arm64,linux/arm/v7
Thanks that workedI got it working using a build earlier than latest. Try; adguard/adguardhome:v0.108.0-b.25
Thanks, it worked for me!I got it working using a build earlier than latest. Try; adguard/adguardhome:v0.108.0-b.25
There is a bug in RouterOS that prevent a pull'ed image built using a newer metadata format from loading. So until Mikrotik fixes the bug, no. It's not just adguard affected by this bug, so imagine a fix will come in the next release.Did somebody managed to run the latest version without downloading the file to pc first?
Thanks! Well, I hope that a new release is coming soon, at least as a beta!There is a bug in RouterOS that prevent a pull'ed image built using a newer metadata format from loading. So until Mikrotik fixes the bug, no. It's not just adguard affected by this bug, so imagine a fix will come in the next release.Did somebody managed to run the latest version without downloading the file to pc first?
The tar file don't contain any metadata so it avoid the bug, but you can only get those using the desktop clients.
Thanks. Manual download and run worked for me as well!While the import issue is getting resolved, to update to the latest version of the container you can do this.
...
Fix is included in upcoming betaThanks! Well, I hope that a new release is coming soon, at least as a beta!
There is no adguardhome tag for that image, see: https://hub.docker.com/r/adguard/adguardhome/tagsadguard:adguardhome
importing remote image: adguard, tag: adguardhome
error response getting manifests: 401
was unable to import, container bdd79662-4b0f-46ca-9deb-24d5890d6891
Could be related to ROS docker image compatibility (OCI manifest format), try this solution: viewtopic.php?t=193727#p985424adguard/adguardhome
importing remote image: adguard/adguardhome, tag: latest
was unable to import, container c3a3d65f-612f-421b-83df-8b30dc724ad3
no 401 message.
Can you check if it works with 7.9rc1?
It still doesn't work in Release 7.9rc1, help!Fix is included in upcoming betaThanks! Well, I hope that a new release is coming soon, at least as a beta!
Hello, fix hopefully will come with next beta release.
you mean 7.10 beta?beta will be released immediately after stable release. Probably next week.
Thanks, this worked for meWhile the import issue is getting resolved, to update to the latest version of the container you can do this.
From your computer :
1.) docker pull adguard/adguardhome:latest@sha256:aa84b1ff0b5710052bdb8e63b4528dc9b634780019a125d3d4de320868b6cbf2
(where the digest corresponds to your Mikrotik's architecture e.g. ARM64)
2.) docker save adguard/adguardhome > adguardhome.tar
3.) Upload to your RouterOS Device and use the uploaded file to create the container
/interface/veth/add address=172.21.0.201/24 gateway=172.21.0.254 name=veth201
/interface/bridge/port/add bridge=dockers interface=veth201
/container/envs/add name=adguard_envs key=TZ value="Asia/Jerusalem"
/container/config/set registry-url=https://registry-1.docker.io tmpdir=usb1-part1/pull
/container/mounts/add dst=/opt/adguardhome/conf name=adguardhome_conf src=usb1-part1/adguardhome/conf
/container/mounts/add dst=/opt/adguardhome/work name=adguardhome_work src=usb1-part1/adguardhome/work
/container/add remote-image=adguard/adguardhome:latest interface=veth201 logging=yes mounts=adguardhome_conf,adguardhome_work root-dir=usb1-part1/adguardhome/root envlist=adguard_envs start-on-boot=yes
I've got the same version on my Chateau and CLI shows correct IPs, just checked it... so U are right - Winbox bugYep, seems to be a Winbox bug.
On a RB3011 lab box, running the latest beta 7.11 BETA6 this "issue" is present.
I think if you disable NAT on docker bridge, it will solve your problem.Is there any way to get real client IP addresses in Adguard stat? The easiest thing is to use LAN IP address instead of IP from docker subnet...
But in this case how it's better configure access from Container to the Internet?I think if you disable NAT on docker bridge, it will solve your problem.Is there any way to get real client IP addresses in Adguard stat? The easiest thing is to use LAN IP address instead of IP from docker subnet...
You should apply NAT to your container in the same way as you do for the rest of your network, on the outgoing WAN interface. So you should have a rule that is only natting when a device from your internal network tries to access the internet through your WAN interface.But in this case how it's better configure access from Container to the Internet?
I think if you disable NAT on docker bridge, it will solve your problem.
My current NAT settings:You should apply NAT to your container in the same way as you do for the rest of your network, on the outgoing WAN interface. So you should have a rule that is only natting when a device from your internal network tries to access the internet through your WAN interface.
But in this case how it's better configure access from Container to the Internet?
If I will disable it Container will loose connection to the Internet, by the way I've tried - the same - only docker's bridge IP is showing in statTry disabling the last rule. Everything should work.
Looks like your docker container does not have a default gatewayIf I will disable it Container will loose connection to the Internet, by the way I've tried - the same - only docker's bridge IP is showing in statTry disabling the last rule. Everything should work.
e.g. does the VETH for the container have the bridge IP as the gateway?Looks like your docker container does not have a default gatewayIf I will disable it Container will loose connection to the Internet, by the way I've tried - the same - only docker's bridge IP is showing in stat
Yes, VETH interface used for Adguard Container has IP address and Gateway (Bridge IP address)e.g. does the VETH for the container have the bridge IP as the gateway?
Looks like your docker container does not have a default gateway