Main Thread (Start of my post): viewtopic.php?p=985420#p984701
Other Example: viewtopic.php?p=985420#p929511
Other Example: viewtopic.php?p=985420#p963157
Version: 7.8rc2 (but tested on 7.7 stable and 7.8rc1 and it doesn't work there either)
Model: CCR2216-1G-12XS-2XQ
Notes:
1) No firewall rules blocking anything, just the accept rule for fasttrack.
2) In a more complex setup I am able to get non-VLAN traffic from another port on the CCR (like sfp28-2) to any VLAN on the bridge to be offloaded. But the key is that inter-VLAN traffic from a VLAN on the bridge to another VLAN on the bridge is not offloaded.
Steps to Reproduce:
1) Setup a downstream switch with multiple VLANs that will be trunked from a single port on the switch to a single port on the CCR. For example have a switch with 8 GbE ports and 2 SFP+ ports. Access ports for individual VLANs on ports 2-5 of the switch correspond to VLANs 2-5 and have them all trunked to a single SFP+ uplink that you connect to one of the CCR's sfp28 ports.
2) Setup a bridge on the CCR.
3) Add a bridge port with the desired sfp28 interface.
3) Create bridge VLAN entry with the VLAN's 3-5 tagged and the sfp28 port as well as bridge tagged.
4) Attempt to pass traffic (iperf3 or any traffic SMB/FTP etc.) from a workstation on VLAN 3 to another workstation on VLAN 4.
--- Expected functionality, is that within the appropriate connection limits etc, the traffic should be offloaded as per the documentation on L3HW offloading. Actual functionality is that the traffic is not offloaded.
Simple Config:
Code: Select all
/interface bridge
add frame-types=admit-only-vlan-tagged name=bridge pvid=4094 vlan-filtering=\
yes
/interface vlan
add interface=bridge name="IoT Wifi" vlan-id=5
add interface=bridge name="Mobile Wifi" vlan-id=4
add interface=bridge name="Secure Wifi" vlan-id=3
add interface=bridge name="WAN (4000)" vlan-id=4000
/interface ethernet switch
set 0 l3-hw-offloading=yes
/interface ethernet switch port
set 0 l3-hw-offloading=no
set 1 l3-hw-offloading=no
set 2 l3-hw-offloading=no
set 3 l3-hw-offloading=no
set 4 l3-hw-offloading=no
set 5 l3-hw-offloading=no
set 6 l3-hw-offloading=no
set 7 l3-hw-offloading=no
set 8 l3-hw-offloading=no
set 9 l3-hw-offloading=no
set 10 l3-hw-offloading=no
set 11 l3-hw-offloading=no
set 12 l3-hw-offloading=no
set 13 l3-hw-offloading=no
set 14 l3-hw-offloading=no
set 15 l3-hw-offloading=no
set 16 l3-hw-offloading=no
set 17 l3-hw-offloading=no
set 18 l3-hw-offloading=no
set 19 l3-hw-offloading=no
/interface bridge port
add bridge=bridge frame-types=admit-only-vlan-tagged interface=sfp28-12 pvid=\
4094
/interface bridge settings
set use-ip-firewall=yes use-ip-firewall-for-pppoe=yes \
use-ip-firewall-for-vlan=yes
/interface ethernet switch l3hw-settings
set ipv6-hw=yes
/interface bridge vlan
add bridge=bridge tagged=bridge,sfp28-12 vlan-ids=3-5,4000