I have a new RB2011 routerboard that I am wanting to use as a residential network device. I have the unit up and running easily and am pretty happy with the unit thus far.
HOWEVER!!!! I run a very small game server (Dungeons & Dragons on the FoundryVTT platform hosting on a headless linux box). This server was recently running without any problems on localip:30000 with a port forward set up to resolve a https domain to my public ip and then into my server.
I set up NAT forwarding rules on the RB2011(forwarding set for port 80, 443, and 30000 as the server relays jitsi video) and after a bit of research tried to amend the correct firewall rules to allow my server be publicly accessible. So far all I can muster is a "connection refused". Open port check tools cannot see my service on 30000 but I can access my server locally on localip:30000 as well as ssh into the linux box locally.
I am not as up to date on networking as I used to be and wanted to take a whirl at the mikrotik boards as they seemed like a really neat resource but I am finding it difficult to decipher some of the firewall rules in particular. Below are the NAT rules and some additional info I have seen requested elsewhere.
Thank you in advance for any help and patience! Next D&D session is Thursday! Oh hell!
Nat rules:
Code: Select all
/ip firewall nat
add chain=dstnat action=dst-nat dst-address=*publicip* to-addresses=192.168.88.254 to-ports=30000 protocol=tcp dst-port=80
Code: Select all
/ip firewall nat
add chain=dstnat action=dst-nat dst-address=*publicip* to-addresses=192.168.88.254 to-ports=443 protocol=tcp dst-port=443
More details:
Code: Select all
/ip address print detail:
0 ;;; defconf
address=192.168.88.1/24 network=192.168.88.0 interface=ether2 actual-interface=bridge
1 D address=*publicip*/18 network=76.187.128.0 interface=ether1 actual-interface=ether1
Code: Select all
/ip route print detail:
0 ADS dst-address=0.0.0.0/0 gateway=76.187.128.1 gateway-status=76.187.128.1 reachable via ether1 distance=1 scope=30 target-scope=10 vrf-interface=ether1
1 ADC dst-address=76.187.128.0/18 pref-src=*publicip* gateway=ether1 gateway-status=ether1 reachable distance=0 scope=10
2 ADC dst-address=192.168.88.0/24 pref-src=192.168.88.1 gateway=bridge gateway-status=bridge reachable distance=0 scope=10