Community discussions

MikroTik App
 
dperdue
just joined
Topic Author
Posts: 1
Joined: Sun Jan 18, 2015 4:48 am

L2TP & IPSec RoadWarriors Connecting but No Traffic Flowing

Sun Sep 13, 2015 3:04 am

I'm helping manage a business network with one central location and 11 remote offices. We've recently transition a lot of our gear to RouterBoard's. Over all, once I got my head wrapped around establishing the IPSec tunnels for the remote locations, things have gone pretty smoothly.

I've hit a road block when it comes to allowing users to connect while on the road to the main office. For them, I've decided on L2TP and IPSec for broad compatibility. I have the configuration to the point where users can connect, but currently, no traffic flows to the internal IP addresses of the home office network (192.168.103.0/24). I can connect to the router using the l2tp-server address (192.168.210.1) so I know traffic can flow over the tunnel, but my clients don't know how to reach the internal IP addresses. I feel like I'm missing a critical step, but I've been searching and can't find it.

Any help you can offer would be greatly appreciated.

Here's the relevant code I used to establish the L2TP/IPSec connection capability.
/ip ipsec proposal
add enc-algorithms=3des name=l2tp pfs-group=none
/ip pool
add name=vpn-pool ranges=192.168.210.10-192.168.210.100
/ppp profile
add change-tcp-mss=yes dns-server=192.168.210.1 local-address=192.168.210.1 name=l2tp remote-address=vpn-pool use-encryption=yes
/interface l2tp-server server
set default-profile=l2tp enabled=yes
/ip firewall filter
add chain=input port=1701,500,4500 protocol=udp
add chain=input protocol=ipsec-esp
/ip firewall nat
add chain=srcnat dst-address=192.168.210.0/24 src-address=192.168.103.0/24
/ip ipsec peer
add comment=L2TP exchange-mode=main-l2tp generate-policy=port-override nat-traversal=no
/lcd interface pages
set 0 interfaces=wlan1
/ppp secret
add name=dperdue profile=l2tp
 
descartes
just joined
Posts: 21
Joined: Sun Sep 20, 2015 3:04 pm

Re: L2TP & IPSec RoadWarriors Connecting but No Traffic Flowing

Tue Sep 22, 2015 6:01 pm

Hi,

perhaps you check this info:
http://wiki.mikrotik.com/wiki/Manual:Interface/L2TP

Also, how is your remote office connecting to the main office, is it via a Mikrotik Device as well?
there must be an IP routing on the home office device (192.168.103.0/24 network) to the main office LAN, and also your main office LAN devices, like servers, printers, etc must know how to route to your home office (192.168.103.0/24).

hope this helps.