feature request: comment field in crs switch vlan config
Posted: Thu Nov 26, 2015 2:48 pm
it would be soo nice to have a comment attribute in the switch CLI so i can remember why i configured that vlan.
right now everything is cool inside the "router part", but the switch config is clunky.
i'd also have a vlan name there - similar to the interface names in routerOS.
a name what i could use to reference to VLANs as objects in other part of the switch configuration:
this is just for UI interaction and abstraction. of course the actual values need to be programmed into the switch chip, and i understand the consequences: when i change something in a vlan object, it needs to re-program all the stuff which is normally generated by the other config commands referencing somehow the changed vlan object.
but the comment part is piece of cake. please.
right now everything is cool inside the "router part", but the switch config is clunky.
i'd also have a vlan name there - similar to the interface names in routerOS.
a name what i could use to reference to VLANs as objects in other part of the switch configuration:
Code: Select all
/interface ethernet switch vlan add name="management" vlan-id=666 comment="guess what is this" ports="ether1,ether2"
/interface ethernet switch ingress-vlan-translation add ports=ether1 new-customer-vid=management
/interface ethernet switch egress-vlan-tagging add tagged-ports=ether2 vlan-id=management
but the comment part is piece of cake. please.