/tool fetch https://127.0.0.1/ dst-path=path/to/create/xxx
/file remove path/to/create/xxx
No idea why the script creates user, group and whatever. Given you have http-ssl service enabled this should suffice:
Alternatively use whatever webserver. It creates a file as well, just remove that:Code: Select all/tool fetch https://127.0.0.1/ dst-path=path/to/create/xxx
Code: Select all/file remove path/to/create/xxx
{
# ----- Create directory tree with /fetch -----
# Take note of the 'dot' (or 'space') in place of 'file name',
# this will prevent the fetched website from actually being saved as a file
# even if fetch is successful
:local path "disk1/complex/directory/tree/."
:do { /tool fetch dst-path=($path) url="https://127.0.0.1/"; } on-error={ :put "Script will continue dispite an error"; }
:local otherpath "disk1/some/other/dir/."
/tool fetch dst-path=($otherpath) url="https://www.google.com/"
}
status: failed
failure: cannot open file
/ip smb shares add name=sharethis directory=moab
/ip smb shares remove [find name=sharethis]
> /file/add name="/MyFolder/MySubFolder/MyFile.txt" contents="Hello MikroTik :)" ;
> /file/print detail where name="MyFolder/MySubFolder/MyFile.txt" ;
3 name="MyFolder/MySubFolder/MyFile.txt" type=".txt file" size=17 creation-time=may/31/2023 08:45:15 contents=Hello MikroTik :)
> /file/remove numbers="MyFolder/MySubFolder/MyFile.txt" ;
> /file/print detail where name="MyFolder/MySubFolder" ;
2 name="MyFolder/MySubFolder" type="directory" creation-time=may/31/2023 08:46:05
> /system/resource/print file="/MyFolder/MySubFolder/ResData.txt" ;
> /file/print detail where name="MyFolder/MySubFolder/ResData.txt" ;
Hello,Since the ROS Release v7.9 2023.05.02.:
(!) The symbol for root ("/") is not consistent.
Thank you very much colleague!Hello,Since the ROS Release v7.9 2023.05.02.:
(!) The symbol for root ("/") is not consistent.
an absolutely genuine, perfect post!
Dis is why it is always worthy coming here.
Thank you, colleague in arms!