Community discussions

MikroTik App
 
User avatar
kaptain46
just joined
Topic Author
Posts: 22
Joined: Thu Sep 18, 2008 1:27 pm
Location: Rho
Contact:

Hotspot with PCC Balancer

Wed Feb 10, 2016 12:55 pm

Hi,
I'm testing an hotspot configuration with 2 different hotspot service on 2 different ports (eth4/eth5) and 2 WAN connection in failover (eth1/eth2).

Basically what I need is that all traffic from both hotspot will be balanced through the 2 WAN (for failover and failback I've introduce a route control based on recursive ping).

Here the address list created where 88.x/89.x are hotspot's subnet and 10.x/11.x are WAN subnet:
/ip firewall address-list add address=192.168.88.0/24 list=Connected
/ip firewall address-list add address=192.168.89.0/24 list=Connected
/ip firewall address-list add address=192.168.10.0/24 list=Connected
/ip firewall address-list add address=192.168.11.0/24 list=Connected
and here my mangle list:
/ip firewall mangle
add chain=prerouting dst-address-list=Connected src-address-list=Connected
add action=mark-connection chain=prerouting connection-mark=no-mark \
    dst-address-type=!local hotspot=auth in-interface=ether4 \
    new-connection-mark=WAN1 per-connection-classifier=both-addresses:2/0
add action=mark-connection chain=prerouting connection-mark=no-mark \
    dst-address-type=!local hotspot=auth in-interface=ether4 \
    new-connection-mark=WAN2 per-connection-classifier=both-addresses:2/1
add action=mark-connection chain=prerouting connection-mark=no-mark \
    dst-address-type=!local hotspot=auth in-interface=ether5 \
    new-connection-mark=WAN1 per-connection-classifier=both-addresses:2/0
add action=mark-connection chain=prerouting connection-mark=no-mark \
    dst-address-type=!local hotspot=auth in-interface=ether5 \
    new-connection-mark=WAN2 per-connection-classifier=both-addresses:2/1

add action=mark-connection chain=input connection-mark=no-mark in-interface=\
	ether1 new-connection-mark=WAN1 passthrough=no
add action=mark-connection chain=input connection-mark=no-mark in-interface=\
    ether2 new-connection-mark=WAN2 passthrough=no
add action=mark-routing chain=prerouting connection-mark=WAN1 in-interface=\
	ether4 new-routing-mark=WAN1-mark
add action=mark-routing chain=prerouting connection-mark=WAN2 in-interface=\
    ether4 new-routing-mark=WAN2-mark
add action=mark-routing chain=prerouting connection-mark=WAN1 in-interface=\
    ether5 new-routing-mark=WAN1-mark
add action=mark-routing chain=prerouting connection-mark=WAN2 in-interface=\
    ether5 new-routing-mark=WAN2-mark
add action=mark-routing chain=output connection-mark=WAN1 \
    new-routing-mark=WAN1-mark passthrough=no
add action=mark-routing chain=output connection-mark=WAN2 \
	new-routing-mark=WAN2-mark passthrough=no
Testing this configuration, all traffic pass on eth2 (subnet 192.168.89.0/24) and nothing pass on eth1 (only the recursive ping).

Does anyone have any idea about it? It making me crazy :shock: