Hi there !
I have been a weird problem with Load Balancing.
There are speed drops in the aggregated link.
If I use 2 Mbps + 2 Mbps I should get around 4 Mbps. I tried to download file and when it starts it gives around 4 Mbps speed but after some times the speed drops to 1.5 Mbps, after some times it gets up to 3 Mbps . The speed never gets constant.
If I disable 1 of the connections .. I get constant 2 Mbps speed , with no speed Drops.
I have nth Load balancing with hotspot.
Even after switching off hotspot I am getting the same results.
I think I messed up with the config somewhere
Please have a look
/interface pppoe-client
add disabled=no interface=Wan1 max-mru=1480 max-mtu=1480 name=pppoe-out1 \
password=simna user=simnamuz
add disabled=no interface=Wan2 max-mru=1480 max-mtu=1480 name=pppoe-out2 \
password=simna user=simnamuz1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
add dns-name=my.login.com hotspot-address=192.168.40.1 html-directory=\
Hotspotsimna login-by=http-chap name=hsprof1
/ip pool
add name=hs-pool-1 ranges=192.168.40.2-192.168.40.254
/ip dhcp-server
add address-pool=hs-pool-1 disabled=no interface=local lease-time=1h name=\
dhcp1
/ip hotspot
add address-pool=hs-pool-1 addresses-per-mac=1 disabled=no interface=local \
name=hotspot1 profile=hsprof1
/ip hotspot user profile
add address-pool=hs-pool-1 name=512 open-status-page=http-login rate-limit=\
512000/512000 shared-users=5 transparent-proxy=yes
add address-pool=hs-pool-1 name=256 open-status-page=http-login rate-limit=\
256000/256000 transparent-proxy=yes
add address-pool=hs-pool-1 name=1024 open-status-page=http-login rate-limit=\
1024000/1024000 transparent-proxy=yes
/ppp profile
set [ find name=default ] name=default
set [ find name=default-encryption ] name=default-encryption
/ip address
add address=192.168.40.1/24 interface=local network=192.168.40.0
add address=192.168.20.1 interface=ether4 network=192.168.20.1
/ip dhcp-server network
add address=192.168.40.0/24 comment="hotspot network" gateway=192.168.40.1
/ip dns
set allow-remote-requests=yes cache-size=20000KiB max-udp-packet-size=20000 \
servers=8.8.8.8,8.8.4.4
/ip firewall filter
add action=passthrough chain=unused-hs-chain comment=\
"place hotspot rules here" disabled=yes
/ip firewall mangle
add action=mark-connection chain=prerouting connection-state=new \
in-interface=local new-connection-mark=conn1 nth=2,1
add action=mark-routing chain=prerouting connection-mark=conn1 in-interface=\
local new-routing-mark=conn1 passthrough=no
add action=mark-connection chain=prerouting connection-state=new \
in-interface=local new-connection-mark=conn2 nth=1,1
add action=mark-routing chain=prerouting connection-mark=conn2 in-interface=\
local new-routing-mark=conn2 passthrough=no
/ip firewall nat
add action=passthrough chain=unused-hs-chain comment=\
"place hotspot rules here" disabled=yes
add action=masquerade chain=srcnat connection-mark=conn1 out-interface=\
pppoe-out1
add action=masquerade chain=srcnat connection-mark=conn2 out-interface=\
pppoe-out2
add action=masquerade chain=srcnat comment="masquerade hotspot network" \
src-address=192.168.40.0/24
add action=dst-nat chain=dstnat dst-port=2341-2343 in-interface=pppoe-out1 \
protocol=tcp to-addresses=192.168.40.240 to-ports=2341-2343
add action=dst-nat chain=dstnat dst-port=2344-2346 in-interface=pppoe-out2 \
protocol=tcp to-addresses=192.168.40.164 to-ports=2344-2346
add action=dst-nat chain=dstnat dst-port=2341-2343 in-interface=pppoe-out1 \
protocol=udp to-addresses=192.168.40.240 to-ports=2341-2343
add action=dst-nat chain=dstnat dst-port=2344-2346 in-interface=pppoe-out2 \
protocol=udp to-addresses=192.168.40.164 to-ports=2344-2346
/ip hotspot ip-binding
add mac-address=14:07:08:09:B7:CD type=bypassed
add mac-address=8C:E7:48:26:42:AC type=bypassed
/ip hotspot user
add name=admin password=apurv
add name=owner password=123456 profile=1024
add name=staff1 password=staff1 profile=256
add name=staff2 password=staff2 profile=256
add name=staff3 password=staff3 profile=256
add name=restaurant password=123456 profile=512
add name=reception password=123456 profile=512
add name=housekeeping password=123456 profile=512
add name=apurv password=gyan
add name=navneethere08 password=absolution47
add name=owner1 password=123456 profile=1024
add name=2001 password=2001 profile=512
add name=2002 password=2002 profile=512
add name=2003 password=2003 profile=512
add name=2004 password=2004 profile=512
add name=3001 password=3001 profile=512
add name=3002 password=3002 profile=512
add name=3003 password=3003 profile=512
add name=3004 password=3004 profile=512
add name=3005 password=3005 profile=512
add name=3006 password=3006 profile=512
add name=3007 password=3007 profile=512
add name=3008 password=3008 profile=512
add name=4001 password=4001 profile=512
add name=4002 password=4002 profile=512
add name=4003 password=4003 profile=512
add name=4004 password=4004 profile=512
add name=4005 password=4005 profile=512
add name=4006 password=4006 profile=512
add name=4007 password=4007 profile=512
add name=5001 password=5001 profile=512
add name=5002 password=5002 profile=512
add name=5003 password=5003 profile=512
add name=5004 password=5004 profile=512
add name=5005 password=5005 profile=512
add name=5006 password=5006 profile=512
add name=5007 password=5007 profile=512
add name=reception2 password=123456 profile=512
add name=staff4 password=staff4 profile=512
/ip route
add distance=1 gateway=pppoe-out1 routing-mark=conn1 scope=255
add distance=1 gateway=pppoe-out2 routing-mark=conn2 scope=255
add distance=1 gateway=pppoe-out1
add distance=1 gateway=pppoe-out2
/system clock
set time-zone-name=Australia/Brisbane
/system identity
set name=Simna
/system routerboard settings
set cpu-frequency=650MHz protected-routerboot=disabled
/tool romon port
add disabled=no