Community discussions

MikroTik App
 
User avatar
mdsekawsar
just joined
Topic Author
Posts: 19
Joined: Tue Nov 04, 2014 12:55 am
Location: Joypurhat, Bangladesh
Contact:

Dual WAN PCC load balance with VLAN

Wed Apr 20, 2016 8:49 am

Hi,

I have two WAN Interface. I make load balance for that on pcc method. It works fine. Some time some of my clients making complain that internet is slow. I went to customer side. I saw, ping time and all everything is fine. But really the internet is slow. I am not sure, how could I solve the issue. If anyone could help me, I will be grateful to him. Thanks in advance.

Here is my load balance scenario.
Loadbalance Image.png
I have to WAN interface

WAN1--
VLAN1-Internet (15 Mbps)--172.16.16.2/30
VLAN2-Youtube (15 Mbps)--172.16.16.6/30

WAN2--
Internet (25 Mbps)--192.168.13.2/30

LAN--192.168.255.1/24 (LAN have several sub nets)

Now I tried the following mangle rule---

/ip address
add address=192.168.255.1/24 network=192.168.0.0 broadcast=192.18.255.255 interface=Local
add address=172.16.16.2/30 network=192.168.1.0 broadcast=172.16.16.3 interface=WAN1
add address=192.168.13.2/30 network=192.168.2.0 broadcast=192.168.13.3 interface=WAN2

/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=8.8.8.8

/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn

add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2

add chain=prerouting dst-address=172.16.16.2/30 action=accept in-interface=Local
add chain=prerouting dst-address=192.168.13.2/30 action=accept in-interface=Local

add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/2 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes

add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1
add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2

/ip route
add dst-address=0.0.0.0/0 gateway=172.16.16.2/30 routing-mark=to_WAN1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.13.2/30 routing-mark=to_WAN2 check-gateway=ping

add dst-address=0.0.0.0/0 gateway=172.16.16.2/30 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.13.2/30 distance=2 check-gateway=ping

/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade


Now tell me the problem. Sometimes its works fine. Sometime the customer making complains that the internet is slow. Could anyone tell me any proper suggestion that i can write on? I need smooth browsing for all of my clients. How could this will be done.

Thanks
Kawsar
You do not have the required permissions to view the files attached to this post.