Community discussions

MikroTik App
 
dballester
just joined
Topic Author
Posts: 5
Joined: Thu Sep 20, 2012 3:26 pm

v6.24 and v6.32 simple queues and hotspot users

Fri May 20, 2016 5:02 pm

Hi,

I'm trying to implement simple queues for hotspot users. AFAIK, is so simple as:

Create a simple queue to delimitate global limits.
Inform in the hotspot user profile the rate limits and the parent queue.

I did that and I got "unexpected results":

I've a xDSL line with 10mb download and 1M upload. I wanna give to clients a maximum of 6M download and 800k upload to share between them.
I'm using a 450G router, with 5 ethernet ports. eth0 is connected to the DSL router/modem and eth2, eth3 and eth4 being part of a bridge where hotspot authenticates internal clients.

I've created a parent simple queue to limit globally
 0    name="general_hotspot1" target="" parent=none packet-marks="" priority=8/8 queue=default-small/default-small limit-at=0/0 max-limit=800k/6M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s 
(under winbox I can se the target pointing to 0.0.0.0/0 but in terminal the same parameter is void)

Then I inform in the hotspot profile, to use limits and queues
 0 * name="default" status-autorefresh=1m shared-users=100 add-mac-cookie=yes mac-cookie-timeout=8w4d rate-limit="800k/6M" insert-queue-before=hs-<hotspot1> parent-queue=general_hotspot1 queue-type=ethernet-default address-list="" transparent-proxy=no 
[admin@dlf000003] > 
When an user is authentificated in the hotspot, the dynamic queue is created as expected,
 1  D name="<hotspot-ZZ6300>" target=10.0.12.198/32 parent=general_hotspot1 packet-marks="" priority=8/8 queue=ethernet-default/ethernet-default limit-at=800k/6M 
      max-limit=800k/6M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
but:

Download limit is applied to the user, upload limit not at all (in a speed test, user downloaded at 5.10Mbps and uploaded at 16.50Mbps)

limits are applied by user basis, but global limits are not applied. Following the example, with a limit of 6Mb, if 2 users downloads at same time, each one gets a limit of 6Mb, but in total they are consuming 12Mb

I'm sure that I'm not appliying something well, but I don't see my error.

Anyone could help me showing me the "good way"?

Thanks

FYI, I'm following the documentation "Dynamic QoS RouterOS v6.3" by Valens Riyadi from MUM-EU-2014
 
facuxt
just joined
Posts: 3
Joined: Sat Nov 05, 2016 1:58 pm

Re: v6.24 and v6.32 simple queues and hotspot users

Sat Nov 05, 2016 2:07 pm

Hello There... maybe if you update your ROS version it came alltogether... But i can suggest you a workaround...

In user profile, you could set an specifical ip-pool... so when the user logins the router assigns him an "virtual ip" (dont know the exact term), then you can simple queue that pool of ips... for example

First add a pool.
/ip pool add name=USN ranges=192.168.63.2-192.168.63.100

Then add a user profile that uses this pool.
/ip hotspot user profile add name=USN shared-users=99 address-pool=USN

Then create a user for that recently created profile
/ip hotspot user add name=USN password=changeme profile=USN server=server1

Then create a simple queue to limit that group.
/queue simple add name=USN target=192.168.63.0/24 max-limit=800K/6M


*You also have to add the ip address in the interface where the hotspot runs. For example in ip-address you could use 192.168.0.1/16


sorry for the delay.. im new in this forum and im searching something similar as you.. i want to do this all automatic and not to create one of each of this per user... the dynamic queues that are created when the user logins are per device connected and not per user basis. Im using ROS 6.30