Page 1 of 1

CAPsMAN OIDs

Posted: Mon May 23, 2016 5:58 pm
by squeezypiano
Hi,

Hoping someone can help me, please. I am running CAPsMAN with multiple radios and have the OID for getting the total number of active clients (.1.3.6.1.4.1.14988.1.1.1.6.0) and it works a treat. However, I am looking to get more granual info (with a view to create a location map in Cacti/Weathermap showing where the clients are). Are there any OIDs to get clients per radio, clients per SSID, clients per SSID per radio etc.? Or are there any other suggestions for getting that info?

Many thanks.

Re: CAPsMAN OIDs

Posted: Fri Aug 12, 2016 3:29 pm
by lbachero
Hello.


Could you find anything?
I need this too.



Thanks.



Regards,
Leandro de Lima Camargo

Re: CAPsMAN OIDs

Posted: Sat Aug 13, 2016 3:24 pm
by squeezypiano
Hi,

I didn't find any OIDs, I ended up writing and scheduling a script that takes the raw data from the registration table and FTPs it to my monitoring server where another script pushes the data in to the monitoring system. It works pretty well and gives me all the info I need.
:local filecontent;
/file remove [find name=reg-list.txt]
/file print file=reg-list.txt
/file set [find name=reg-list.txt] contents=""
delay 1s;
:foreach int in=[/caps-man registration-table find] do={
    :set filecontent ($filecontent . [/caps-man registration-table get $int ssid] . "::" . [/caps-man registration-table get $int interface] . "\r\n");
}
/file set [find name=reg-list.txt] contents=$filecontent
:set filecontent ("")
delay 1s;
/tool fetch address=X.X.X.X port=21 src-path=reg-list.txt user=username mode=ftp password=password dst-path=reg-list.txt upload=yes
delay 5s;
/file remove [find name=reg-list.txt]
The output looks a bit like this (depending on how you identify your APs in the registration list, Mine all start with 'cap')...
ssid1::cap001-1
ssid1::cap001-1
ssid1::cap001-2
ssid2::cap001-1-1
ssid1::cap001-1
ssid2::cap002-2-1
ssid1::cap003-2
ssid1::cap001-2
ssid2::cap001-2-1
The output let's me count the total registrations (although there is an OID for that .1.3.6.1.4.1.14988.1.1.1.6.0) by counting the lines, count the clients per access point (by counting, e.g. cap001, cap002), the clients per said (by counting ssid1, ssid2 etc.) and clients per ssid on each radio, e.g. ssid1::cap001-2 is ssid1 on the 5GHz radio of cap001, etc. etc.