My RB2011UiAS version=6.35.2
Found a page that shows a setup for QoS And VoIP at http://wiki.mikrotik.com/wiki/Voip
The code on that page shows things like parent=global-in and parent=global-out but there is only global in the Parent drop down list.
The code on that wiki page is:
Code: Select all
/queue tree
add name="IN" parent=global-in priority=1
add name="OUT" parent=global-out priority=1
add name="SIP_IN" packet-mark=SIP_IN parent=IN priority=2
add name="SIP_OUT" packet-mark=SIP_OUT parent=OUT priority=2
add name="ALL_ELSE_IN" packet-mark=ELSE_IN parent=IN priority=8
add name="ALL_ELSE_OUT" packet-mark=ELSE_OUT parent=OUT priority=8
/ip firewall mangle
add action=mark-packet chain=prerouting comment="SIP Only" disabled=yes in-interface=WAN\
new-packet-mark=SIP_IN passthrough=no src-address=192.168.0.16
add action=mark-packet chain=postrouting disabled=yes dst-address=192.168.0.16\
new-packet-mark=SIP_OUT out-interface=WAN passthrough=no
add action=mark-packet chain=prerouting comment="All Else" disabled=yes in-interface=WAN\
new-packet-mark=ELSE_IN passthrough=no src-address=!192.168.0.16
add action=mark-packet chain=postrouting disabled=yes dst-address=!192.168.0.16\
new-packet-mark=ELSE_OUT out-interface=WAN passthrough=no
add action=mark-packet chain=prerouting comment="SIP Web Server" disabled=yes in-interface=WAN\
new-packet-mark=ELSE_IN passthrough=yes protocol=tcp src-address=192.168.0.16 src-port=80
add action=mark-packet chain=postrouting disabled=yes dst-address=192.168.0.16\
dst-port=80 new-packet-mark=ELSE_OUT out-interface=WAN passthrough=yes protocol=tcp
Code: Select all
avg. rate
Here is what I have now:
Code: Select all
/ip firewall mangle
add action=mark-packet chain=forward comment="VoIP IN" dst-port=5060,10251-15000 new-packet-mark=VoIP passthrough=no \
protocol=udp src-address=107.6.xxx.xxx
add action=mark-packet chain=forward comment="VoIP OUT" dst-address=107.6.xxx.xxx dst-port=5060,10000-15000 \
new-packet-mark=VoIP passthrough=no protocol=udp
Code: Select all
/queue tree
add name=VoIP-IN packet-mark=VoIP parent=global priority=2 queue=default
add name=VoIP-OUT packet-mark=VoIP parent=voice_vlan priority=2 queue=default
How to set this up correctly seeing as there is only a 'GLOBAL' in Parent Drop Down
Thanks for your help!