I'm trying to get a Set-top Box (STB) to receive an IP from ISP's DHCP.
This is the setup:
ISP --- DSL modem --- Mikrotik1 (((--))) Mikrotik2 --- Set-top Box
- Mikrotik1 (M1) is a Router/wireless AP. The physical wireless interface is in "ap bridge" mode. Standard configuration for internet access. I created a VirtualAP interface, which is used just for M2.
- M2 is in "station pseudobridge" mode. M2 is connected to M1 over the wifi link.
- On M2, I created a bridge interface (bridge-iptv) and added the port that the STB is connected to (ether1-gateway) and the wlan physical interface (wlan-iptv).
- STB (or a PC), connected to ether1-gateway on M2 does not receive an IP from ISP
- A DHCP client created on M2's bridge-iptv does not receive an IP from ISP
- A DHCP client created on M2's wlan-iptv DOES receive an IP from ISP
This is M2's bridge/port configuration:
Code: Select all
/interface bridge
add name=bridge-iptv
add admin-mac=XX:XX:XX:XX:XX:XX auto-mac=no name=bridge-local
/interface bridge port
add bridge=bridge-local interface=ether2-master-local
add bridge=bridge-iptv interface=wlan-iptv
add bridge=bridge-iptv interface=ether1-gateway
Any help will be greatly appreciated. Thanks.
EDIT: Solved with razortas' help. The correct mode on M2 was "station bridge".
My bad for not trying it in the first place. I had problems establishing a connection in another/different setup, and got it working with pseudobridge, that's why I started with it.