execute on/down ppp profile script problem
Posted: Tue Oct 04, 2016 11:13 pm
Hey
I have a script for PPPOE clients to change their dynamic queues to static queue on log on and remove the static queues on log out by using ppp profile scripts (on up and on down)
on up to make me able to change static queues based on day and night times and the other parameters like what i could do before 6.31
:local ppp ("<pppoe-$user>");
:local maxl [/queue simple get $ppp max-limit];
:local burstl [/queue simple get $ppp burst-limit];
:local burstt [/queue simple get $ppp burst-time];
:local burstth [/queue simple get $ppp burst-threshold];
:local prio [/queue simple get $ppp priority];
:local limitat [/queue simple get $ppp limit-at];
:local target [/queue simple get $ppp target];
[/queue simple remove $ppp];
[/queue simple add target=$target max-limit=$maxl burst-limit=$burstl burst-time=$burstt burst-threshold=$burstth priority=$prio limit-at=$limitat name=$ppp];
on down
:local ppp ("<pppoe-$user>");
[/queue simple remove $ppp];
they work fine but the problem is when some users log on together the scripts do not work for some of them and when remove the pppoe client interface manually some times it works and some time no matter how many time you remove the pppoe interface , scripts don't work but when you remove the clients that scripts applied on one time then scripts on log out and log on again work fine .
is it a bug ?
is the ppp profile script made for ppp server ? or it's mad only for ppp clients?
I have a script for PPPOE clients to change their dynamic queues to static queue on log on and remove the static queues on log out by using ppp profile scripts (on up and on down)
on up to make me able to change static queues based on day and night times and the other parameters like what i could do before 6.31
:local ppp ("<pppoe-$user>");
:local maxl [/queue simple get $ppp max-limit];
:local burstl [/queue simple get $ppp burst-limit];
:local burstt [/queue simple get $ppp burst-time];
:local burstth [/queue simple get $ppp burst-threshold];
:local prio [/queue simple get $ppp priority];
:local limitat [/queue simple get $ppp limit-at];
:local target [/queue simple get $ppp target];
[/queue simple remove $ppp];
[/queue simple add target=$target max-limit=$maxl burst-limit=$burstl burst-time=$burstt burst-threshold=$burstth priority=$prio limit-at=$limitat name=$ppp];
on down
:local ppp ("<pppoe-$user>");
[/queue simple remove $ppp];
they work fine but the problem is when some users log on together the scripts do not work for some of them and when remove the pppoe client interface manually some times it works and some time no matter how many time you remove the pppoe interface , scripts don't work but when you remove the clients that scripts applied on one time then scripts on log out and log on again work fine .
is it a bug ?
is the ppp profile script made for ppp server ? or it's mad only for ppp clients?