Community discussions

MikroTik App
 
dalvyk
just joined
Topic Author
Posts: 3
Joined: Thu Feb 02, 2017 9:57 am

How to use mangle and queue tree correctly?

Thu Feb 02, 2017 10:37 am

I recently bought a Mikrotik router which is great. I prioritize my game port but it sill lags when someone downloads & watches online. This is the commands that I used.
/ip firewall mangle
add action=mark-connection chain=prerouting comment="STEAM UDP" disabled=no src-address=192.168.2.2 dst-port=27015-27030 new-connection-mark="GAME-conn" passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment="STEAM TCP" disabled=no src-address=192.168.2.2 dst-port=27015-27030 new-connection-mark="GAME-conn" passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="STEAM GAME TRAFFIC" disabled=no src-address=192.168.2.2 dst-port=27000-27015 new-connection-mark="GAME-conn" passthrough=yes protocol=udp

/ip firewall mangle
add action=mark-packet chain=prerouting comment="GAME ALL CLIENTS" connection-mark="GAME-conn" disabled=no new-packet-mark=GAME-pkt passthrough=no
/queue tree
add name="GAME ALL CLIENTS" parent=global-out packet-mark=GAME-pkt limit-at=220k queue=default priority=7 max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s