I assume your AP is directly connected to your HEx Lite so that you can actually pass VLAN tags. The untagged default/native network already exists, otherwise you wouldn't be able to access anything. You are looking to add a new VLAN for your guest network, so you need to create the VLAN on the switch...of course if you also want to have DHCP and routing on that network you will need to create a VLAN interface.
The default/native/untagged VLAN can safely be assumed to be VLAN1, and nothing would need to change there. If you want your Guest VLAN to be VLAN 10 then you need something like below, just exclude your WAN interface from the list for VLAN access.
Add VLAN to switch
/interface ethernet switch vlan
add independent-learning=no ports=ether2-master,ether3,ether4,ether5,switch1-cpu switch=switch1 vlan-id=10
Add VLAN interface for DHCP and routing:
/interface vlan
add comment="Guest network" interface=ether2-master name=vlan10-guest vlan-id=10
/ip address
add address=192.168.103.1/24 comment="Guest Gateway" interface=vlan10-guest network=192.168.103.0
Configure DHCP server on that network:
/ip dhcp-server network
add address=192.168.10.0/24 comment="Guest Network" dns-server=8.8.8.8,8.8.4.4 gateway=192.168.10.1 netmask=24
/ip dhcp-server
add add-arp=yes address-pool=Guest disabled=no interface=vlan10-guest lease-time=8h name="Guest Network"
You will then need to create appropriate firewall rules to allow the guest network access to the Internet and to prevent access from your "main" network if you wish.