Create bandwidth profiles with mangle and queues
Posted: Fri Feb 24, 2017 6:58 pm
Hi,
I am looking for a way to use one queue in queue tree for every IP, basically want to add client's IP to address list and queue the same speed per IP's in the address list
eg:
Then I want to add a Queue in Queue tree that will limit automatically per client IP
eg:
I was thinking this was possible with PCQ but I do not want to share the Max-Limit bandwidth, I want every user to get the specified amount of bandwidth.
Is this possible?
I am looking for a way to use one queue in queue tree for every IP, basically want to add client's IP to address list and queue the same speed per IP's in the address list
eg:
Code: Select all
/ip firewall mangle
add action=mark-connection chain=forward comment=2Mbps_Client \
new-connection-mark=2Mbps_Client passthrough=yes src-address-list=\
2Mbps_Client
add action=mark-packet chain=forward connection-mark=2Mbps_Client \
new-packet-mark=2Mbps_Client passthrough=no
add action=mark-connection chain=forward comment=4Mbps_Client \
new-connection-mark=4Mbps_Client passthrough=yes src-address-list=\
4Mbps_Client
add action=mark-packet chain=forward connection-mark=4Mbps_Client \
new-packet-mark=4Mbps_Client passthrough=no
eg:
Code: Select all
/queue tree
add max-limit=20M name="Total Bandwidth Download" parent=LAN priority=1 queue=\
default
add max-limit=2M name="2Mbps_Client - rx" packet-mark=2Mbps_Client parent=\
"Total Bandwidth Download" queue=default
add max-limit=4M name="4Mbps_Client - rx" packet-mark=4Mbps_Client parent=\
"Total Bandwidth Download" queue=default
Is this possible?