Yes it is possible.
As i understand you want to save connections log to disk file inside your mikrotik device. This is not that much recommended scenario because it may use a lot of memory and processing depending on how many connections there are. there are some limits for the created file like number of lines. Usually this logs are sent to an other server and not saved on the same mikrotik device.
But a simple setup would be like this:
1 Setup a logging action
maximum lines of log file will be 9999
only one file will be created
if file is full will stop
/system logging action add name=tofile target=disk disk-lines-per-file=9999 disk-file-name=mylogfile disk-file-count=1 disk-stop-on-full=yes
2. Log firewall topics to action we created
/system logging add topics=firewall action=tofile
3. Setup firewall filer rules to log new tcp and udp connections. In src-address the network or ip's we want to monitor
/ip firewall filter add chain=forward src-address=192.168.88.0/24 protocol=tcp connection-state=new action=log
/ip firewall filter add chain=forward src-address=192.168.88.0/24 protocol=udp connection-state=new action=log