Hello
I've been using a Hex POE at home and in comparison to the ISP provided router, we see way more issues with TCP streams having out-of-order packets and duplicate ACKs. I've been capturing traces with a mirroring switch that lie between an XBox One and the router-under-test. I'm running the Xbox's detailed connectivity test and looking at the result.
Xbox --- switch --- Router ---- PPPOE
|
| Mirrored port
+----- PC (Wireshark)
WIth the ISP router there are 13 duplicate acks and 0 out of order packets, with the Hex POE there are 324 duplicate acks and 298 out of order packets. Across multiple runs alternating between routers, these are fairly typical results. It results in the Mikrotik router showing much smaller download bandwidth, upload bandwidth looks the same.
The firewall seems like it might be a candidate involved here, though not sure how that'd come to pass, the config is:
/ip firewall filter
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment="defconf: accept established,related" connection-state=established,related
add action=drop chain=input comment="defconf: drop all from WAN" in-interface=pppoe-infinity
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related" connection-state=established,related
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new \
in-interface=wan1
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pppoe-infinity
Are there any other configuration areas that might lead to this issue? [ I found one or two similar reports in the forums, but no outcome, e.g. viewtopic.php?f=3&t=108428&p=538125&hil ... te#p538125 ]
Thanks
MrZipf