Page 1 of 1

Unwanted IPv6

Posted: Sat Jul 15, 2017 1:37 pm
by mrzipf2
Hi folks

We noticed our router seems to be forwarding IPv6 over our PPPoE connection to the outside world. This was a bit surprising as we had not enabled IPv6 nor installed the module. We installed the module and disabled everything and attempted to block it in the firewall and still we seem to have IPv6 working from hosts on the network.

Code: Select all

> nslookup youtube.com
Server: indnsc90.ukcore.bt.net
Address: 213.120.234.10

Non-authoritative answer:
Name: youtube.com
Addresses: 2a00:1450:4009:80a::200e
216.58.213.110

Code: Select all

> ping -t 2a00:1450:4009:80f::200e

Pinging 2a00:1450:4009:80f::200e with 32 bytes of data:
Reply from 2a00:1450:4009:80f::200e: time=315ms
Reply from 2a00:1450:4009:80f::200e: time=332ms
Reply from 2a00:1450:4009:80f::200e: time=386ms
Reply from 2a00:1450:4009:80f::200e: time=12ms
Reply from 2a00:1450:4009:80f::200e: time=339ms
Reply from 2a00:1450:4009:80f::200e: time=60ms
Reply from 2a00:1450:4009:80f::200e: time=334ms

Ping statistics for 2a00:1450:4009:80f::200e:
Packets: Sent = 7, Received = 7, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 12ms, Maximum = 386ms, Average = 254ms
Having installed IPv6 module, we've set it up to try to disable this traffic:

Code: Select all

> ipv6 export
# jul/15/2017 11:31:26 by RouterOS 6.39.2
# software id = 597B-RF8Z
#
/ipv6 firewall filter
add action=drop chain=input
add action=drop chain=forward
add action=drop chain=forward
add action=drop chain=input in-interface=pppoe-infinity
/ipv6 settings
set accept-redirects=no accept-router-advertisements=no forward=no
The lengthy delay and variation on RTTs makes sites reporting IPv6 painful to use. We can manually disable IPv6 on some devices on the network, but not all.

Is there anything we can do differently in the config to address this?

Thanks in advance

Re: Unwanted IPv6

Posted: Sat Jul 15, 2017 1:48 pm
by mrzipf2
The thought that this might be a weird tunneling interaction, but if I capture the traffic with a port mirroring switch I see IPv6 native traffic on the wire in wireshark looking at the mirrored port, e.g.

Code: Select all

167 8.371006 2a00:23c4:7329:f400:24a3:77:a96c:d0d6 2a00:1450:4009:80f::200e ICMPv6 94 Echo (ping) request id=0x0001, seq=136, hop limit=128 (no response found!)
168 8.678449 2a00:1450:4009:80f::200e 2a00:23c4:7329:f400:24a3:77:a96c:d0d6 ICMPv6 94 Echo (ping) reply id=0x0001, seq=136, hop limit=54 (request in 167)
Help appreciated in how to disable this at the router level. Thanks!

Re: Unwanted IPv6

Posted: Sat Jul 15, 2017 6:09 pm
by Sob
There must be something else you're not telling us, because your rules say very clearly that there will be no IPv6 traffic passing through this router. Are you sure you see this traffic on router's PPPoE interface? Can't there be some other router connected to same network (check default gateway at clients)?

Re: Unwanted IPv6

Posted: Sat Jul 15, 2017 7:54 pm
by mrzipf2
Looking a bit closer, it looks like there is a device on the network that will unexpectedly tunnel IPv6.

Image

The network is configure as 10.0.0.0/24. But there's a device with a SAGEM OUI mac address that ARPs for 192.168.1.0/24 address. The mac address of this device is in the IPv6 packets. So presumably this device is tunneling / routing the IPv6. I have no idea what it is. It doesn't have a DHCP lease, nor does it's MAC address appear in the routers list of ARP addresses.

The client machine which is sending the IPv6 packets has two NICs - one that binds to the network via a switch and a second that is unbound but collects mirror traffic from the switch. The same behaviour occurs if the client machine is connected directly to one of the routers bridge interfaces. Just need to find the mystery device now and figure out how that communicates with the outside world.

Re: Unwanted IPv6

Posted: Sat Jul 15, 2017 7:55 pm
by mrzipf2
The image URL is a filtered snapshot from wireshark:
https://pasteboard.co/GB4H7n5.png

Re: Unwanted IPv6

Posted: Sun Jul 16, 2017 10:04 am
by mrzipf2
GOT HOMEPLUG? ALWAYS, ALWAYS CHANGE YOUR HOMEPLUG NETWORK NAME!

<tl;dr>
Sorry folks, this is nothing to do with any Mikrotik gear.

It appears to stem from the use HomePlugAV in the house to extend ethernet into other rooms. Changing the HomePlug network name appears to have removed this issue. I was under the misunderstanding that when the devices paired they produced a shared DES key. That can't be the case. These are also detached houses and some docs suggest this isn't possible. However, after changing the network name there are no IPv6 router advertisements from the unknown device with a Sagem OUI MAC address.

If I think hard about odd behaviors I may have been able to see 2 different neighbors routers at different times. There is is the SAGEM OUI MAC address that we've seen IPv6 router advertisements from and I recall seeing a BSkyB OUI MAC address with a spanning tree ethernet frame and I'd guess that is a neighbour's Sky router.

The HomePlug management software has never shown any unknown HomePlug adapters. I had been meaning to replace HomePlug anyway as it is slower internally than the incoming internet connection. There is 50 yards of cat6 set aside for the job, but we are in the process of moving house so that is on hold.
</tl;dr>

Re: Unwanted IPv6

Posted: Sun Jul 16, 2017 11:22 am
by mrzipf2
We were feeding the neighbours cats today so I took a look at their networking setup:

1) Their ISP provided router has the MAC address of the router advertising IPv6. The ISP says they do not support IPv6 for consumers.

2) The neighbour has Trendnet AV Homeplug adapters, we have TP-Link.

The hole seems to relate to broadcast packets - I've found a total of 3 routers in historic packet traces (BT, BSkyB, and unknown device with AzureWave OUI).

Re: Unwanted IPv6

Posted: Sun Jul 16, 2017 9:17 pm
by idlemind
Good tip! So your electrical service must be shared or at least behind a common transformer. This would allow these Ethernet over electrical devices to see each other. Like you said if they are both set to a common network name then try to link the link the networks like you'd expect. This totally explains why you were seeing traffic you weren't expecting.

Good find! Great tip for the community, I know I've used Ethernet over electrical adapters as a stop gap before.

Re: Unwanted IPv6

Posted: Sun Jul 23, 2017 12:52 pm
by mrzipf2
Yes, the homes affected are quite close to a common transformer. The HomePlug AV generation adapter advertise 300m reach and I'd estimate that there's less than 30m of cabling from either home to the transformer. I thought it was quite interesting tracking this issue down so have written it up publicly. There's a photo in part ii of the homes and the transformer.

https://specklepattern.wordpress.com/20 ... rk-part-i/
https://specklepattern.wordpress.com/20 ... k-part-ii/

I've been thinking about how to avoid this kind of snafu beyond just changing the HomePlug network name. For instance, if the home plug adapters where attached to routed interfaces rather than bridged, we could drop and log packets from other private IPv4 network ranges. We could even encrypt the traffic on those interfaces internally using PPPoE tunnels. No need for anything faster than 80Mbps.

Re: Unwanted IPv6

Posted: Sun Jul 23, 2017 4:47 pm
by Sob
I don't have any experience with these devices, but if the whole security depends just on "network name", that's really bad. Unless there's clearly written somewhere that "network name" is supposed to be "long and secret password". Lets hope that it at least stays in device and isn't broadcasted to everything connected. :)