I have 2 Vdsl Line which have same speeds 50m/2m
I have PCC loadbalance rules
They connected to mikrotik with pppoe from Ether 1 and Ether 2
Ether 3 is my local Lan output
My problem is, when I connect my computer directly to mikrotik I can get 100m/4m...,When I connect the internet via acces point (acces point connected the mikrotik via ether3) I can get only 50m/4m
The interesting thing is 2 pppoe connection share the 50mbit download 25/25 but 4 mbit upload speed remain still same
PCC works fine only if I connect my computer to mikrotik directly
Code: Select all
# jul/28/2017 19:08:37 by RouterOS 6.39.1
# software id = D30F-EWV3
#
/interface ethernet
set [ find default-name=ether3 ] name=Local
set [ find default-name=ether5 ] master-port=Local
/interface pppoe-client
add disabled=no interface=ether1 max-mru=1480 max-mtu=1480 name=pppoe-out1 \
add disabled=no interface=ether2 max-mru=1480 max-mtu=1480 name=pppoe-out2 \
/ip pool
add name=dhcp_pool0 ranges=192.168.2.2-192.168.2.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=Local name=dhcp1
/interface l2tp-server server
set caller-id-type=ip-address
/ip address
add address=192.168.2.1/24 interface=Local network=192.168.2.0
/ip dhcp-server network
add address=192.168.2.0/24 gateway=192.168.2.1
/ip dns
set allow-remote-requests=yes cache-size=5000KiB max-udp-packet-size=512 \
servers=8.8.8.8,8.8.4.4
/ip firewall mangle
add action=mark-routing chain=prerouting dst-port=443 new-routing-mark=HTTPS \
passthrough=no protocol=tcp
add action=mark-connection chain=input in-interface=pppoe-out1 \
new-connection-mark=wan1_conn passthrough=yes
add action=mark-connection chain=input in-interface=pppoe-out2 \
new-connection-mark=wan2_conn passthrough=yes
add action=mark-routing chain=output connection-mark=wan1_conn \
new-routing-mark=to_wan1 passthrough=yes
add action=mark-routing chain=output connection-mark=wan2_conn \
new-routing-mark=to_wan2 passthrough=yes
add action=mark-connection chain=prerouting dst-address-type=!local hotspot=\
"" in-interface=Local new-connection-mark=wan1_conn passthrough=yes \
per-connection-classifier=both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting dst-address-type=!local hotspot=\
"" in-interface=Local new-connection-mark=wan2_conn passthrough=yes \
per-connection-classifier=both-addresses-and-ports:2/1
add action=mark-routing chain=prerouting connection-mark=wan1_conn hotspot="" \
in-interface=Local new-routing-mark=to_wan1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=wan2_conn hotspot="" \
in-interface=Local new-routing-mark=to_wan2 passthrough=yes
add action=accept chain=prerouting in-interface=pppoe-out1
add action=accept chain=prerouting in-interface=pppoe-out2
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pppoe-out1
add action=masquerade chain=srcnat out-interface=pppoe-out2
/ip route
add check-gateway=ping distance=1 gateway=pppoe-out1 routing-mark=to_wan1
add check-gateway=ping distance=1 gateway=pppoe-out2 routing-mark=to_wan2
add check-gateway=arp distance=3 gateway=pppoe-out1 routing-mark=HTTPS
add check-gateway=arp distance=4 gateway=pppoe-out2 routing-mark=HTTPS
add check-gateway=ping distance=1 gateway=pppoe-out1
add check-gateway=ping distance=2 gateway=pppoe-out2