I am following this tutorial:
https://wiki.mikrotik.com/wiki/Vlans_on ... nvironment
and I am trying to replicate third example.
Basically, I have a device between two trunk ports.
Trunking is working fine. I am able to ping from each "side".
Problem arise when I try to add access port on "middle" Mikrotik device.
I stricly followed tutorial's step:
- add VLAN with correct vlan-in on bridge-trunk
- add bridge for VLAN
- bridge that VLAN on new bridge
- bridge ethernet port on new bridge
Anyway, it is not working.
Odd enough, it seems that ping works fine for few seconds, and then stops.
Any help?
LEFT DEVICE (ether9 is trunk)
Code: Select all
/interface vlan
add interface=ether9 name=vlan100 vlan-id=100
/interface bridge
add name=bridge-vlan100
/interface bridge port
add bridge=bridge-vlan100 interface=ether7
add bridge=bridge-vlan100 interface=vlan100
Code: Select all
/interface vlan
add interface=ether2 l2mtu=1514 name=vlan-100 vlan-id=100
/interface bridge
add name=bridge-vlan100
/interface bridge port
add bridge=bridge-vlan100 interface=ether3
add bridge=bridge-vlan100 interface=vlan-100
Code: Select all
/interface bridge
add name=bridge-trunk
/interface bridge port
add bridge=bridge-trunk interface=ether1
add bridge=bridge-trunk interface=ether2
Code: Select all
/interface vlan
add interface=bridge-trunk name=vlan100 vlan-id=100
/interface bridge
add name=bridge-vlan100
/interface bridge port
add bridge=bridge-vlan100 interface=vlan100
add bridge=bridge-vlan100 interface=ether3