Thank you very much for your reply @mkx.
So to get an idea of the layout, I am enclosing below:
So we have a RB5009 which feeds this site, there are seveal vlans setup, nothing too special. A couple of remote ways into winbox/ssh and a server in the lan but all are ACL down to a few selected IPs. We also have a bond over two links which feed the network.
The VPN client itself (wireguard but managed by netclient) is running on a server on 10.29.10.100 and the RB5009 has several routes which is routing the traffic to it, so that everyting on the LAN knows how to reach those addresses.
Note, I only have two routes for the VPN defined atm due to this issue and testing is easier with a smaller subset of rules/routes to look though.
There is currently two sites defiend (10.27.0.0/24 and 172.19.255.0/24) as I was testing to see if the problem was on all and it is. Only when the invalid rule is disabled, it then works as expected.
Below I have dumpted the relivent parts of the config which hopefully will explain a little more then I can in words.
Please let me know if theres something you need to be clarified or if I have missed something.
Thanks in advance for your help.
Kind Regards,
Simon
Interfaces/VLANs
/interface bridge
add admin-mac=18:FD:74:XX:XX:XX auto-mac=no disabled=yes name=bridge
/interface ethernet
set [ find default-name=ether1 ] comment="CISCO | SW01 | LAG| PORT 1" poe-out=off
set [ find default-name=ether2 ] comment="CISCO | SW01 | LAG | PORT 2" poe-out=off
set [ find default-name=ether3 ] disabled=yes poe-out=off
set [ find default-name=ether4 ] disabled=yes poe-out=off
set [ find default-name=ether5 ] disabled=yes poe-out=off
set [ find default-name=ether6 ] disabled=yes poe-out=off
set [ find default-name=ether7 ] disabled=yes poe-out=off
set [ find default-name=ether8 ] disabled=yes poe-out=off
set [ find default-name=sfp-sfpplus1 ] comment="City Fibre | ONT"
/interface vlan
add comment="XX Broadband | VLAN" interface=sfp-sfpplus1 name=vlan911 vlan-id=911
/interface bonding
add comment="CISCO | SW01 | LCAP" mode=802.3ad name=bond0 slaves=ether1,ether2 transmit-hash-policy=layer-2-and-3
/interface pppoe-client
add add-default-route=yes comment="XX Broadband | Internet" disabled=no interface=vlan911 name=pppoe0 use-peer-dns=yes user=XXX@XXX.XX.XX
/interface vlan
add comment="Core | Network" interface=bond0 name=vlan2910 vlan-id=2910
add comment="Trusted | Network" interface=bond0 name=vlan2920 vlan-id=2920
add comment="Work | Network" interface=bond0 name=vlan2930 vlan-id=2930
add comment="Guest | Network" interface=bond0 name=vlan2950 vlan-id=2950
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface bridge port
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=ether6
add bridge=bridge comment=defconf interface=ether7
add bridge=bridge comment=defconf interface=ether8
add bridge=bridge comment=defconf interface=sfp-sfpplus1
/interface list member
add comment=untagged interface=bond0 list=LAN
add comment=untagged interface=sfp-sfpplus1 list=WAN
add comment="Core | Network" interface=vlan2910 list=LAN
add comment="Trusted | Network" interface=vlan2920 list=LAN
add comment="Work | Network" interface=vlan2930 list=LAN
add comment="Guest | Network" interface=vlan2950 list=LAN
add comment="XXX | Broadband" interface=vlan911 list=WAN
add comment="WAN | Internet" interface=pppoe0 list=WAN
Firewall Rules & ACLs
/ip firewall address-list
add address=XX.XX.19.5 comment="Dad's | Home" list=TRUSTED
add address=XX.XX.123.10 comment="Simons | Home" list=TRUSTED
add address=XX.XX.24.146 comment="Steven's | Work" list=TRUSTED
add address=XX.XX.79.236 comment="Trudie's | Home" list=TRUSTED
add address=10.29.10.0/24 comment="Core | Network" list=TRUSTED
add address=10.29.20.0/24 comment="Trusted | Network" list=TRUSTED
add address=XX.XX.52.120 comment="Hetzner | Dedicated" list=TRUSTED
add address=******* comment="Steven's | Home" list=TRUSTED
/ip firewall filter
add action=accept chain=input comment="accept established,related,untracked" connection-state=established,related,untracked
add action=accept chain=input comment="accept to local loopback" dst-address=127.0.0.1
add action=jump chain=input comment="allow icmp" jump-target=icmp
add action=drop chain=input comment="drop invalid" connection-state=invalid
add action=jump chain=input comment="allow access to router" jump-target=router
add action=drop chain=input comment="drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment=fasttrack connection-state=established,related hw-offload=yes
add action=accept chain=forward comment="accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="drop invalid" connection-state=invalid log=yes log-prefix=drop_invalid
add action=jump chain=forward comment="allow access to lan" jump-target=lan
add action=drop chain=forward comment="drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
add action=accept chain=icmp comment="0:0 and limit for 5 packets per second" icmp-options=0:0-255 limit=5,5:packet protocol=icmp
add action=accept chain=icmp comment="3:3 and limit for 5 packets per second" icmp-options=3:3 limit=5,5:packet protocol=icmp
add action=accept chain=icmp comment="3:4 and limit for 5 packets per second" icmp-options=3:4 limit=5,5:packet protocol=icmp
add action=accept chain=icmp comment="8:0 and limit for 5 packets per second" icmp-options=8:0-255 limit=5,5:packet protocol=icmp
add action=accept chain=icmp comment="11:0 and limit for 5 packets per second" icmp-options=11:0-255 limit=5,5:packet protocol=icmp
add action=accept chain=router comment="accept udp dns queries from lan" dst-port=53 in-interface-list=LAN protocol=udp
add action=accept chain=router comment="accept tcp dns queries from lan" dst-port=53 in-interface-list=LAN protocol=tcp
add action=accept chain=router comment="accept udp ntp queries from lan" dst-port=123 in-interface-list=LAN protocol=tcp
add action=accept chain=router comment="accept SSH to router *trusted*" dst-port=22 log=yes log-prefix=test_log protocol=tcp src-address-list=TRUSTED
add action=accept chain=router comment="accept Winbox to router *trusted*" dst-port=8291 protocol=tcp src-address-list=TRUSTED
add action=accept chain=lan comment="accept access to mgmt01 *trusted*" dst-port=10022 in-interface-list=WAN protocol=tcp src-address-list=TRUSTED
/ip firewall nat
add action=masquerade chain=srcnat ipsec-policy=out,none out-interface-list=WAN
add action=dst-nat chain=dstnat dst-port=10022 in-interface-list=WAN protocol=tcp to-addresses=10.29.10.100 to-ports=10022
Routes
/ip route
add check-gateway=none disabled=no distance=1 dst-address=10.27.10.0/24 gateway=10.29.10.100 routing-table=main scope=30 suppress-hw-offload=no \
target-scope=10
add disabled=no dst-address=172.19.255.0/24 gateway=10.29.10.100 routing-table=main suppress-hw-offload=no