I am using the ether1 interface for the outside to the world and ether2 for the inside network.
I first started with the quickset option and just used NAT option.
since then I have added some queues to handle VoIP and such to try to help out but I havent heard if that has helped the phone problem or not but the download issue still exists.
viewtopic.php?t=73214
I went and tested some other things and it seems to be with TCP traffic I am guessing I show nice high bandwidth with UDP which is what I am guessing btest uses but when I use iperf through the router using TCP it is slow on downloads
Thanks again
/ip firewall filter
chain=input action=accept connection-state=established connection-type="" log=no log-prefix=""
chain=input action=accept connection-state=related log=no log-prefix=""
chain=input action=accept protocol=icmp log=no log-prefix=""
chain=input action=accept protocol=ipsec-esp log=no log-prefix=""
chain=input action=accept in-interface=ether2 log=no log-prefix=""
chain=input action=drop in-interface=ether1 log=no log-prefix=""
chain=forward action=accept connection-state=established log=no log-prefix=""
chain=forward action=accept connection-state=related log=no log-prefix=""
chain=forward action=drop connection-state=invalid log=no log-prefix=""
/ip firewall nat
chain=srcnat action=masquerade out-interface=ether1
/queue tree
add max-limit=5M name=LEVEL_A_UP parent=ether1 queue=default
add max-limit=100M name=LEVEL_A_DOWN parent=ether2 queue=default
add max-limit=5M name=LEVEL_B_UP parent=ether1 queue=default
add max-limit=100M name=LEVEL_B_DOWN parent=ether2 queue=default
add max-limit=9M name=LEVEL_C_UP parent=ether1 queue=default
add max-limit=750M name=LEVEL_C_DOWN parent=ether2 queue=default
add name=VOIP_U packet-mark=VOIP parent=LEVEL_A_UP priority=1 queue=default
add name=VOIP_D packet-mark=VOIP parent=LEVEL_A_DOWN priority=1 queue=default
add name=ACK_U packet-mark=ACK parent=LEVEL_B_UP priority=1 queue=default
add name=ACK_D packet-mark=ACK parent=LEVEL_B_DOWN priority=1 queue=default
add name=DNS_U packet-mark=DNS parent=LEVEL_B_UP priority=2 queue=default
add name=DNS_D packet-mark=DNS parent=LEVEL_B_DOWN priority=2 queue=default
add name=UDP_U packet-mark=UDP parent=LEVEL_B_UP priority=3 queue=default
add name=UDP_D packet-mark=UDP parent=LEVEL_B_DOWN priority=3 queue=default
add name=ICMP_U packet-mark=ICMP parent=LEVEL_B_UP priority=4 queue=default
add name=ICMP_D packet-mark=ICMP parent=LEVEL_B_DOWN priority=4 queue=default
add name=HTTP_U packet-mark=HTTP parent=LEVEL_C_UP priority=1 queue=default
add name=HTTP_D packet-mark=HTTP parent=LEVEL_C_DOWN priority=1 queue=default
add name=HTTP_BIG_U packet-mark=HTTP_BIG parent=LEVEL_C_UP priority=2 queue=default
add name=HTTP_BIG_D packet-mark=HTTP_BIG parent=LEVEL_C_DOWN priority=2 queue=default
add name=OTHER_U packet-mark=OTHER parent=LEVEL_C_UP priority=3 queue=default
add name=OTHER_D packet-mark=OTHER parent=LEVEL_C_DOWN priority=3 queue=default