SOLVED: Adding wlan to VLAN aware bridge 6.41rc56
Posted: Wed Dec 06, 2017 1:32 pm
Greetings, dear forumers! This is my first post in your forum.
After a couple of days worth of trying to learn the MikroTik-way, I have the hAP up and running fine with VLANs in the new VLAN aware bridge. Firstly; the new VLAN aware bridge is way better than the switch or old bridge, coming from a Cisco/HP world. I do only switching and 1 management IP on the hAP.
The problem now is that I want the wlan added to the bridge. I am now using a work-around(?) with a separate bridge for wireless, config as follows:
Side note: I assume fast-forward is not nessecary when just switching?
Vlan78 being vlan interface on ether1 (my upstream trunk-port).
This works, but I would assume it's not the right way in version 6.41rc56? I have tried a number of configs where I added the wlan1+2 in the "main" bridge and tried tagging and untagging everywhere, but never would the packets go out the trunk (ether1, vl78).
Here is my bridge/bridge port/bridge vlan config in full:
I hope someone can either tell me I'm doing it the right way, or help me out - I've googled as deep as I think I can!
After a couple of days worth of trying to learn the MikroTik-way, I have the hAP up and running fine with VLANs in the new VLAN aware bridge. Firstly; the new VLAN aware bridge is way better than the switch or old bridge, coming from a Cisco/HP world. I do only switching and 1 management IP on the hAP.
The problem now is that I want the wlan added to the bridge. I am now using a work-around(?) with a separate bridge for wireless, config as follows:
Code: Select all
/interface bridge
add fast-forward=no name=bridge-wl
Code: Select all
/interface bridge port
add bridge=bridge-wl interface=VL78 pvid=78
add bridge=bridge-wl interface=wlan2-5ghz pvid=78
add bridge=bridge-wl interface=wlan1-2ghz pvid=78
This works, but I would assume it's not the right way in version 6.41rc56? I have tried a number of configs where I added the wlan1+2 in the "main" bridge and tried tagging and untagging everywhere, but never would the packets go out the trunk (ether1, vl78).
Here is my bridge/bridge port/bridge vlan config in full:
Code: Select all
/interface bridge
add fast-forward=no mtu=1598 name=bridge-wl
add igmp-snooping=yes name=bridge1 vlan-filtering=yes
/interface bridge port
add bridge=bridge1 interface=ether1 pvid=78
add bridge=bridge1 interface=ether2 pvid=78
add bridge=bridge1 interface=ether3 pvid=78
add bridge=bridge1 interface=ether4 pvid=78
add bridge=bridge1 interface=ether5 pvid=3752
add bridge=bridge-wl interface=VL78 pvid=78
add bridge=bridge-wl interface=wlan2-5ghz pvid=78
add bridge=bridge-wl interface=wlan1-2ghz pvid=78
/interface bridge vlan
add bridge=bridge1 tagged=ether1 vlan-ids=116
add bridge=bridge1 tagged=ether1 untagged=ether2,ether3,ether4 vlan-ids=78
add bridge=bridge1 tagged=ether1 untagged=ether5 vlan-ids=3752